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Introduction 
The CRM Widget offers integration and communication between LiveEngage 2.0 and most 
popular CRM/Ticketing solution platforms such as Freshdesk, NetSuite, Microsoft Dynamics, 
Sugar, and more. This guide will walk you through the steps to install, configure and use the 
Freshdesk Widget. The LiveEngage Freshdesk Widget will allow viewing Freshdesk 
information, the creation of tickets, and attaching chat transcripts to the tickets, inside 
LiveEngage platform.  
If you are currently subscribed to other or different CRM/Ticketing solution, please contact 
your Account Manager to obtain the correct User Guide. 

 

Step 1: Sign Up 
CRM Widget Signing Up 

1. Go to the signup URL: https://crmwidget.liveperson.com/signup 

 
 

2. Make sure you choose ‘Microsoft CRM Dynamics’ within the ‘CRM Integration’ drop-
down 

 

 
 

3. Once you’ve signed up and gone through the approval process by a LivePerson 
Account Manager (within 1 business day), you will receive an email (please check your 
SPAM/Junk folder) from: CRM Widget SignUp No-

https://crmwidget.liveperson.com/signup
https://crmwidget.liveperson.com/signup
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Reply<crmwidget@liveperson.com>, with subject: Your CRM Widget Admin Portal 
Information 

4. The email will provide credentials required to access the admin panel, where you could 
continue to configure the CRM Widget for your business use. 

Step 2: Configuring the CRM Widget 
Accessing the CRM Widget 
This section describes how to configure the CRM Widget for Microsoft Dynamics to be 
customized for LiveEngage use.   
 
CRM Widget Settings and Configuration 

1. Go to the admin panel, URL: https://crmwidget.liveperson.com/admin-panel 
2. Please verify your company profile information 

a. From Menu -> Settings -> ‘Update Profile’ 
b. To update/change company profile information: Company Name, Contact 

Name, Email, Username, and Password 

 

3. Navigate the URL to update/change the Widget Configuration: 
a. From Menu -> Settings -> Widget Config (tab) 

mailto:crmwidget@liveperson.com
https://crmwidget.liveperson.com/admin-panel
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b. Enabling/disabling entities that can be created within Microsoft Dynamics 
c. Enabling/disabling how chat transcript are to be linked/created within the Notes 

section of enabled entities 
4. Support Info tab: See support email, and process to open a ticket for support.  

a. From Menu -> Settings -> Support (tab) 
5. LiveEngage info tab: See the URL that will be required to setup the widget within 

LiveEngage 
a. From Menu -> Settings -> LE Widget Info (tab) 

 

 
 

b. Version and Build of Widget can also be viewed within this tab 
6. Navigate the URL to update/change the license configuration:  

a. From Menu -> Customer’s Accounts 
b. Review your CRM Widget Customer Key 
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c. Click on the ‘info’ icon next to the details of the customer key to modify 
connection to your Microsoft Dynamics instance 

d. Enabling/ disabling the connection to your Microsoft Dynamics account and 
Microsoft Dynamics Client ID and Secret setup. [Detailed step-by-step, next 
section] 

 

 
 

e. Rename CRM Label (optional) 
 

 
 

7. Agents and CRM Instances Mapping: This feature enables you to assign an agent to 
CRM instances. For example, if you have more than 2 CRM instances and you only 
want some agents to access to one CRM while others can access both or all. To use 
this feature, please ensure the username matches with LiveEngage login ID. 

a. From Menu -> Agents -> click on ‘New Agents’  

  
 

Configuring Microsoft Dynamics  
This section describes how to configure Microsoft Dynamics to allow our CRM Widget to 
access your data through web services API.   
Create a New ‘Application ID and Secret’ Entry 
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Creating an ‘Application ID and Client Secret’ entry enables our CRM Widget to access your 
Microsoft Dynamics instance.  

Azure Active Directory 

For the CRM Widget to gain access to Microsoft Dynamics, an Azure Active Directory is 
required as part of the setup. Azure Active Directory allows for seamless OAuth v2.0 
integration, so that profile level permissions could be applied, and a trusted third-party 
application (CRM Widget) is registered to access the necessary components of Microsoft 
Dynamics. 
 

From Microsoft Azure Menu -> Azure Active Directory -> App Registrations -> New Application 
Registration 
 
You will need the following information: 

1. Name = Example [le-crmwidget] 
2. Application Type = Native 
3. Redirect URI = https://crmwidget.liveperson.com/oauth2 
4. Then click “Create”  

 
 

After you enter the above info, an entry will be created. In this example it is "le-crmwidget"  

 

Click on “le-crmwidget" and follow the steps below:  
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1. Copy the Application ID, you will need this later in the setup 
2. Click on “Required permissions” 

 
3. Click Add -> Select an API -> Dynamics CRM Online -> “Select” 

 
4. Click Select permission -> Access CRM Online as organization user -> “Select” 

 
5. Click on Keys, and enter the following: 

a. Description = Example [CRM Widget] 
b. Expires = Never 
c. Click Save, and Copy the Value (this is the Client Secret) that it auto-

generates, you will need this later in the setup 

 
 
Microsoft CRM Dynamics 

Login to your Microsoft CRM Dynamics as an admin, and follow the steps below: 

1. Click on Settings -> Customization -> Developer Resources 
2. Under the Instance Reference Information, Copy the value within the field called Unique 

Name 
 

 

3. This value (subdomain) will be needed later in the setup 

CRM Widget Setup 

Login to the CRM Widget Customer Admin Panel (https://crmwidget.liveperson.com/admin-
panel), and follow the steps below: 

1. Click on the ‘info’ icon next to the details of the customer key to modify connection to 
Microsoft Dynamics 
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2. Click on View -> Edit, next to the label Client ID 
a. Enter the Application ID value from Azure Active Directory setup 
b. Click ‘OK’ to save 

3. Click on View -> Edit, next to the label Client Secret 
a. Enter the Client Secret value from Azure Active Directory setup 
b. Click ‘OK’ to save 

4. Click on View -> Edit, next to the label Subdomain 
a. Enter the Subdomain value from Azure Active Directory setup 
b. Click ‘OK’ to save 

Step 3: Setting up the Widget in LiveEngage 
Configure the Widget on LiveEngage 
Now that you’ve updated the CRM Widget profile and license information, it is time to go to 
LiveEngage and configure the widget.  
 

Note: Your LiveEngage user must be defined as an Administrator to configure the widget. 
 

1. Access “Night Vision” settings menu: click on the icon on the top right of your screen as 
shown in the screenshot below: 

 
 

2. Once in Night Vision, click on “Agent Workspace Configuration” 
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3. Click “+” icon to add a new widget. If you have used up 5 widgets, please contact your 
LivePerson Account Manager. 

 
 

4. Choose the name for the Widget (you can use “Microsoft Dynamics” to have “MD” as 
the widget label, if you are using only one CRM, if you are using multiple, then use 
“CRM Widget”) 

5. Choose “Double Widget” or “Triple Widget” 
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6. Enter the following URL  
o https://crmwidget.liveperson.com/?apiKey=YOUR_APP_KEY&debug=true, this is 

found in CRM Widget Settings and Configuration section, Step #5 

7. Click on “Add Visit Info parameters” and add this mapping:  
o visitorName = Visitor Name. Then click “+”. Then click “Save Parameters” 

https://crmwidget.liveperson.com/?apiKey=YOUR_APP_KEY&debug=true
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8. Open the “Advanced settings for the LivePerson Integration SDK” 
o Define the following URL under “In case widget didn’t load, display the following 

link” https://crmwidget.liveperson.com/loadFailure?apiKey=YOUR_APP_KEY 
o “Show Link after” - Define “60” seconds. This means that if the agent is not 

logged into Dynamics, after 60 seconds he/she will see the message you defined 
with the link defined above.  

9. Click “Save” 
 

Dynamics Widget: Features and Capabilities 

Overview 
 

Below is an overview of the widget capabilities, in this section, we will cover the following 
topics: 

• Introducing the Dynamics Widget 
• Widget Search Capabilities: 

o Dynamics Records 
o Previous Chat Transcripts 

• Creating a New Account Record from LiveEngage 
• Creating a New Contact Record from LiveEngage 
• Creating a New Lead Record from LiveEngage 
• Linking a Chat Transcript to an Existing Record 

 

Introducing the Dynamics Widget 
• Following the above configuration, you may login to start working the new widget 

 

https://crmwidget.liveperson.com/admin-panel
https://crmwidget.liveperson.com/admin-panel
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• Accept a chat, click on the Dynamics Widget and you will be able to view and create 
accounts, contacts and leads directly from LiveEngage.  

• The Administrator can change the CRM instances to a preferable alias through CRM 
Widget Admin Panel 

o For example, “Dynamics” instead of default “Microsoft Dynamics”. 
 

Note: If your Company, is using more than one CRM, your login screen could have more than one 
CRM instance listed in the dropdown. It depends on how many CRMs your company is subscribed 
to. This list is automatically generated based on your APP_KEY that will be provided by your 
Account Manager. 
 

Widget Search Capabilities  
Search Dynamics Records 

The search bar in the Widget enables you to search for any matching contents in following 
standard Dynamics objects: 

• Account Object 
• Contact Object 
• Lead Object 
• Opportunity Object 
 

Note: If you have a visitor name in your pre-chat survey, the visitor name value will be 
automatically populated in the search string and the search will be performed once you click on the 
widget icon. 
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View Previous Chat Transcripts 

To view chat history, click on the link of the record. It will expand out and showing the 
information in the top section.  

• The bottom section will show all previous chat transcripts entries.  
• Click on the specific transcript ID to see the full details of the chat transcripts as show in 

the screen below: 
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Create a New Account Record 
In case you want to create a new Account record, click on the ‘Create Account’.  

• Fill in all the relevant fields in the form  
o All required fields are denoted with an asterisk (First Name, Last Name, Email, 

and Phone Number).  

• Some of these fields will be automatically populated from the answers provided in the 
pre-chat survey (if pre-chat survey is enabled). 

• Click “Create” to save.  
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Create a New Contact Record 
In case you want to create a new Contact record, click on the ‘Create Contact’.  

• Fill in all the relevant fields in the form  
o All required fields are denoted with an asterisk (First Name, Last Name, Email, 

Phone Number).  

• Some of these fields will be automatically populated from the answers provided in the 
pre-chat survey (if pre-chat survey is enabled). 

• Click “Create” to save.  
 

 

Create a New Lead Record 
In case you want to create a new Lead record, click on the ‘Create Lead’.  

• Fill in all the relevant fields in the form  
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o All required fields are denoted with an asterisk (First Name, Last Name, Email, 
Phone Number, Company).  

• Some of these fields will be automatically populated from the answers provided in the 
pre-chat survey (if pre-chat survey is enabled). 

• Click “Create” to save.  
 

 
 

Linking a Chat Transcript to an Existing Record  
In case the chat is related to an existing record, you can link the chat to that relevant record in 
Dynamics.  

• You can attach a current chat transcript to an Account, Contact, Lead or Opportunity 
record by clicking on the “Link Chat” button once the session has ended.  

 

Note: “Link Chat” can only be done when the chat session has ended. The “Link Chat” button is 
disabled throughout an active engagement. 
 

The screen below is shown when the Link Chat is disabled or when chat is active. 
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Unlinking Chat Transcripts 
 

This functionality is currently not available. Once a chat is linked to a record, it cannot be 
deleted, or unlinked from the widget. If a change is needed, you will need to login on Microsoft 
Dynamics from a separate browser and make a change from there. 

 

This document, materials or presentation, whether offered online or presented in hard copy ("LivePerson Informational Tools") is for informational purposes 
only. LIVEPERSON, INC. PROVIDES THESE LIVEPERSON INFORMATIONAL TOOLS "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR 
PURPOSE.  

The LivePerson Informational Tools contain LivePerson proprietary and confidential materials. No part of the LivePerson Informational Tools may be 
modified, altered, reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, 
photocopying, recording, or otherwise), without the prior written permission of LivePerson, Inc., except as otherwise permitted by law. Prior to publication, 
reasonable effort was made to validate this information. The LivePerson Information Tools may include technical inaccuracies or typographical errors.  
Actual savings or results achieved may be different from those outlined in the LivePerson Informational Tools. The recipient shall not alter or remove any 
part of this statement. 

Trademarks or service marks of LivePerson may not be used in any manner without LivePerson's express written consent. All other company and product 
names mentioned are used only for identification purposes and may be trademarks or registered trademarks of their respective companies.  

LivePerson shall not be liable for any direct, indirect, incidental, special, consequential or exemplary damages, including but not limited to, damages for loss 
of profits, goodwill, use, data or other intangible losses resulting from the use or the inability to use the LivePerson Information Tools, including any 
information contained herein. 

 

© 2017 LivePerson, Inc. All rights reserved.    
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