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Kapitel 5 
Die Powerfunktionen von Sketch 5

Was macht Sketch zur ersten Wahl für digitale Produktdesigner? Funktioniert alles magi-

scherweise automatisch? Ganz so einfach ist es nicht. Als Erstes unterstützt Sketch dich da-

bei, schneller und effizienter Entscheidungen zu treffen, aber das machen andere Tools

auch.

Dieses Kapitel heißt »Power-Funktionen«, weil alle Werkzeuge und Funktionen, die du

hier kennenlernst, Sketch von herkömmlicher Software unterscheiden. Sie machen deutlich,

dass es sich bei Sketch um eine neue Generation von Design-App handelt. Sie unterstützen

dich auf neue Weise bei zuvor arbeitsintensiven und langwierigen Routinen. Sketch macht

die schwierigen Aufgaben leichter und ist für ein effektives Design-Team konzipiert, entwi-

ckelt und designt.

Die Power-Funktionen sind acht verschiedene Tools aus allen Bereichen. Stile und Sym-

bole sind wiederverwendbare Objekte, die du im Dokument oder als separate Library-Datei

speichern kannst. Das Exportieren-Werkzeug und die Data-Funktion sind klar aufgebaut

und verleihen dir Superkräfte, wenn du deine Ideen teilst und mit echten Daten füllst. Um

deine Ideen zu präsentieren, baust du schnell einen Prototyp und lädst ihn in die Sketch

Cloud hoch, damit alle deine Arbeit sehen können. Bevor das Design fertig ist, geben dir As-

sistants weitere Hinweise auf Verbesserungen.

5.1    Stile für Ebenen und Texte

Als Designer kennst du bestimmt Fragen wie: »Kannst du mal schnell die Schrift überall än-

dern?«, oder: »Ist es schlimm, wenn wir den Rahmen doch wieder wie am Anfang machen?«

Viele Designer waren schon in dieser Situation und wussten sofort, dass diese Frage viel Ar-

beit bedeutet. Einige Überstunden und Nachtschichten haben hier ihren Anfang genom-

men. Mit Sketch muss das nicht sein.

In diesem Abschnitt lernst du, Stile zu erstellen und erfährst, wie du alles aus Ebenen-

und Textstilen rausholst. In der Handhabung unterscheiden sich die beiden Stilarten für

Ebenen und Texte kaum, deswegen kann man sie in einem Kapitel gemeinsam behandeln.

Ebenen- und Textstile speichern die Eigenschaften deiner Ebene und machen sie in weni-

gen Klicks für andere Ebenen verfügbar. Der gespeicherte Stil steuert das Aussehen aller

Elemente, die mit ihm verknüpft sind. So kannst du schnell hunderte oder tausende Ele-

mente in deinem Design mit einem Klick verändern. Eine neue Schriftart oder neue Farbe ist

so kein Problem.



200

Kapitel 5 Die Powerfunktionen von Sketch

Der Stil hinterlegt alle Einstellungen, die du im Inspector im Abschnitt »Appearance« fin-

dest. Dazu gehören Farben, Schatten, Verläufe und Typografie. Stile gelten nur für das

Dokument, in dem sie gespeichert sind. Aber wenn du sie über Libraries (Abschnitt 5.3) mit

anderen teilst, sorgen sie für ein einheitliches Aussehen auch über Dokumente hinweg.

Stile können darüber hinaus auch eine wichtige Rolle für das Aussehen von Symbolen

(Abschnitt 5.2) spielen.

5.1.1    Einen neuen Stil erstellen

Wähle eine Ebene aus und klicke im Inspector im Bereich Appearance auf das Feld Create.

Schon hast du einen neuen Stil erstellt, das Aussehen wurde im Dokument gespeichert. Alle

gezeichneten Formen und alle Gruppen können Ebenenstile haben, Textstile übertragen

sich nur auf Textebenen.

Abbildung 5.1  Die Optionen und Schaltflächen für Stile im Inspector

Erstellst du einen neuen Stil, dann ist der Ebenenname automatisch auch der Name deines

Stils. Nachdem du den Stil benannt hast, siehst du in der Zeile eine kleine Vorschau des

Stils, seinen Namen und den Pfad. Wie in einer Ordnerstruktur kannst du deine Stile mit »/«

verschachteln. Alles, was vor dem letzten Schrägstrich steht, zeigt Sketch als kleinen Text

unter dem Stilnamen.

Angenommen, du änderst etwas an der Ebene – zum Beispiel die Farbe. Dann wird Sketch

den Namen des Stils kursiv setzen und ein * am Ende des Namens zeigen. Damit ist die

Ebene weiterhin mit dem Stil verknüpft, aber als Abweichung gekennzeichnet. Weicht ein

Stil von seiner Vorlage ab, dann wird er bei der nächsten Aktualisierung auf die Vorlage zu-

rückgesetzt.

Klicke auf den Button Update, um die Abweichung in diesem Stil zu speichern und alle

anderen Ebenen, die auch denselben Stil haben, mit den Änderungen zu aktualisieren.

Klickst du auf Create, wird aus der Abweichung ein neuer Stil.

Die Ebene kannst du auch vom Stil lösen. Dann geht die zentrale Steuerung verloren, ihr

Aussehen behält sie aber bei.
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5.1 Stile für Ebenen und Texte

Bei More öffnet sich ein Kontextmenü: Dort benennst du den Stil um oder setzt das Ausse-

hen auf die gespeicherten Werte zurück, wenn der Stil abweicht. Wenn der Stil aus einer

Library stammt, zeigt dir das Programm auch einen Link zur Library.

Was ist in einem Stil gespeichert? | Pauschal kann man sagen, dass alle Informationen, die

im Inspector unter dem Eintrag Appearance gelistet sind, auch im Stil gespeichert werden.

Das umfasst die Deckkraft und den Mischmodus der Ebene. Wenn du einen Textstil anlegst,

dann speichert Sketch auch die Einstellungen aus dem Inspector-Abschnitt Text im Stil ab.

Das entspricht allen Einstellungen, die auch in Abschnitt 4.3, »Das Text-Werkzeug«, erklärt

wurden.

Das bedeutet aber auch, dass ein paar wichtige Einstellungen nicht in Stilen gespeichert

werden – zum Beispiel Abmessungen und die Position auf dem Canvas, der Radius für die

Eckenrundung oder Informationen zum Prototyping.

Stile auf Ebenen anwenden | Es ist sehr einfach, einen Stil anzuwenden. Wähle eine oder

mehrere Ebenen aus, und klicke dann im Inspector auf die Schaltfläche No Text Style (bezie-

hungsweise No Layer Style), um ein Dropdown-Menü zu öffnen.

Sketch präsentiert dir alle Stile deines Dokuments und alle Libraries mit Stilen. Wenn du

jetzt tippst, dann durchsucht Sketch alle Stilnamen und zeigt dir die relevantesten Treffer.

Oder du klickst dich durch das Menü und wendest mit dem letzten Klick den Stil auf deine

Auswahl an. Alle gespeicherten Eigenschaften übertragen sich.

Abbildung 5.2  Du kannst die Stile durch-
suchen oder dich durch das Menü klicken.
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Genauso gehst du vor, wenn du einen anderen Stil auf die ausgewählten Ebenen anwenden

möchtest.

Auf Gruppen kannst du nicht alle Eigenschaften eines Ebenenstils übertragen. Sketch be-

rücksichtigt nur die Darstellungsoptionen Deckkraft (Opacity) und Schatten (Shadows).

Stile mit anderen Designern teilen | Stile vereinheitlichen dein Design und ordnen das Durch-

einander aus verschiedenen Schriften, Farben und Einstellungen. Um sie als Grundlagen dei-

ner Designs zu nutzen, solltest du sie über Dokumente hinweg synchronisieren. Dafür gibt

es Libraries, sie sammeln Symbole und Stile und stellen sie allen Sketch-Dokumenten zur

Verfügung.

Wenn du deine Stile unabhängig von einem Sketch-Dokument speichern möchtest,

brauchst du ein Sketch-Plugin, das sie dir exportiert.

5.2    Symbole – wiederverwendbare Objekte

Ein Programm ist wie ein Werkzeug – es hilft dir, ein Problem zu lösen oder eine Aufgabe zu

erledigen. So wie ein Pinsel dir hilft, ein Bild zu malen, unterstützt dich Sketch dabei, deine

Kreativität auszuleben. Ein gutes Werkzeug steht nicht zwischen Idee und Ergebnis, son-

dern macht dich besser beim Lösen des Problems. Symbole sind ein gutes Beispiel dafür, wie

Sketch dir hilft, ein Problem schnell, einfach und dauerhaft zu lösen.

Sketch macht dich mit Symbolen zu einem effizienteren Designer. In diesem Abschnitt

lernst du sie Schritt für Schritt kennen, erstellst und bearbeitest sie. Du lernst, sie mit Varia-

blen auszustatten und zu überschreiben. Diese Overrides genannte Funktion kann auch die

Größe des Symbols beeinflussen. Dafür benutzt du die Einstellungen von Smart Layout.

5.2.1    Symbole kurz erklärt

Angenommen, du benutzt Sketch, um eine Website oder deine erste App zu gestalten.

Dabei gibt es Elemente, die du immer wieder brauchst, zum Beispiel die Kopfzeile (Header),

die klassischerweise ein Menü, eine Überschrift oder ein Logo zeigt. Stell dir vor, du planst,

sie auf jedem Artboard einzusetzen.

Abbildung 5.3  Die Menüleiste in einem Design könnte dein erstes Symbol sein.
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Es wäre aufwändig, jedes Mal wieder diese Leiste anzulegen. Und weil es jedes Mal das glei-

che Element ist, möchtest du Änderungen später nicht in mühevoller Kleinarbeit auf jedes

Artboard übertragen. Stattdessen helfen dir Symbole bei diesen Aufgaben.

Merke: Symbole fassen Objekte in deinem Design zusammen und speichern sie.

Zwischen dem gespeicherten und dem wiederverwendeten Objekt besteht eine Bezie-

hung. Das Symbol ist zweigeteilt in eine Vorlage und die Instanzen. Wenn sich etwas an der

Vorlage ändert, dann überträgt sie sich auf alle Kopien.

Abbildung 5.4  Die Vorlage steuert das Aussehen der Symbolinstanzen.

Symbole müssen nicht alle gleich aussehen, aber dazu später mehr. Lass uns ein Symbol er-

stellen und benutzen, damit die Verwendung direkt klar ist.

SCHRITT FÜR SCHRITT

Ein Symbol erstellen und verwenden 

Ein einfaches Beispiel für ein Symbol ist ein Button mit Text. Er besteht aus einem Rechteck

und einem darauf zentrierten Text. Wähle das Rechteck-Werkzeug (R), klicke und ziehe auf

dem Canvas, und erstelle eine neue Ebene. In dem Beispiel hat sie die Abmessungen

191 × 60. Drücke dann (T), um das Text-Werkzeug auszuwählen, und klicke einmal in das

Rechteck. Sketch erstellt eine Textebene mit »Type something«, die du mittig platzierst.

Abbildung 5.5  Erstelle und markiere die Elemente für dein Symbol.

Um ein Symbol zu erstellen, wähle beide Ebenen aus, und klicke auf Layer > Create Symbol

oder drücke (cmd)+(Y).
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Abbildung 5.6  Markiere die Ebenen, die du als Symbol zusammenfassen möchtest. Erstelle ein Symbol 
mit Create Symbol.

Es öffnet sich ein Dialogfenster, das dich darum bittet, das neue Symbol zu benennen. Ver-

suche immer, möglichst genau und kurz zu beschreiben, um was für ein Objekt es sich han-

delt. Darunter siehst du ein Dropdown-Menü, in dem du Layout-Einstellungen setzen

kannst. Mehr dazu liest du später in diesem Abschnitt unter »Smart Layout – automatische

Größenanpassung«.

In der Ecke links unten aktivierst du die Option, dass dieses Symbol auf einer eigenen

Seite gespeichert werden soll. Die Symbole-Seite sammelt alle Symbole und hält dadurch

dein Design ordentlicher. Mit einem Klick auf Create hast du das Symbol gespeichert und

kannst es jetzt verwenden.

Abbildung 5.7  Symbolvorlage und -instanz unterscheiden sich in kleinen Details bei der Darstellung 
auf dem Canvas.

5.2.2    Handhabung und Einfügen von Symbolen

Alle gespeicherten Symbole findest du im Menü Insert > Symbols mit Namen aufgelistet.

Klicke auf einen Eintrag, um das Symbol zu platzieren. Wenn du im Symbolnamen einen

Schrägstrich (/) verwendest, dann verschachtelt Sketch das Menü, sofern mehr als eine Va-

riante in diesem Pfad verfügbar ist. Die Instanz »klebt« dann an deinem Mauszeiger. Mit

einem weiteren Klick auf dem Canvas fügst du die neue Instanz deinem Design hinzu.
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Symbole bleiben mit ihrer Vorlage verknüpft, wenn du sie duplizierst, kopierst und wieder

in deinem Dokument einfügst. Kopierst du ein Symbol und setzt es in ein neues Sketch-

Dokument ein, wird Sketch dir automatisch ein neues Symbol dort anlegen.

Wenn du eine Instanz verkleinern und vergrößern möchtest, ziehe an den eckigen Griffen.

Sie verhält sich wie eine Gruppe. Für einen solchen Fall solltest du die Resizing-Optionen

(Abschnitt 3.9, »Resizing – ein Design für alle Geräte«) einstellen.

Mit einem Doppelklick auf die Instanz springst du zur Vorlage des Symbols. Das Verhalten

eines Symbols weicht hier etwas ab; dort würde ein Doppelklick die Bearbeiten-Optionen

im Inspector anzeigen. Wenn du etwas am Aussehen ändern möchtest, dann musst du die

Vorlage bearbeiten.

Symbole verschachteln | Symbole miteinander zu verschachteln bedeutet, dass ein Symbol

Teil eines anderen Symbols ist. Wie eine Box in einer Box oder das Kinderspielzeug Ma-

trjoschka. Jedes Update des verschachtelten Symbols spiegelt sich dann auch in den Instan-

zen wider. Ein verschachteltes Symbol erzeugst du, indem du eine Instanz in eine Vorlage

einfügst – oder wenn du mehrere Vorlagen markierst und aus ihnen ein neues Symbol er-

stellst. Du kannst Symbole so tief ineinander verschachteln, wie du willst.

Abbildung 5.9  Auf der Symbols-Seite siehst du, dass eine Instanz des Menu-Symbols in der Menüleiste 
eingefügt ist.

Abbildung 5.8  Das Symbol 
klebt an deinem Mauszeiger, 
bis du es durch Klicken plat-
zierst. Die roten Hilfslinien 
helfen dir dabei.
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Symbole löschen | Wähle eine Instanz aus, und drücke die Taste (_í). Sketch entfernt sie

vom Canvas und aus der Ebenenliste, wie eine normale Ebene. Wenn du ein Symbol kom-

plett löschen möchtest, dann drücke bei ausgewählter Symbolvorlage die Taste (_í). Das

Programm weist dich darauf hin, dass Instanzen dann nicht mehr mit dieser Vorlage ver-

knüpft sind und in Gruppen umgewandelt werden. Es gibt keinen Befehl, um sowohl die In-

stanzen als auch die Vorlage gemeinsam zu löschen.

5.2.3    Symbole im Inspector

Weil Symbole in Vorlage und Instanz zweigeteilt sind, gibt es auch zwei verschiedene An-

sichten bei den Einstellungen im Inspector. Als erstes siehst du die Einstellungen für Instan-

zen, danach die für Vorlagen.

Abbildung 5.10  Symboleinstellungen im Inspector

Die Instanzen zeigen den Namen und Ort des Symbols. In dem Dropdown-Menü kannst

du die Instanz durch ein anderes Symbol ersetzen. Wie bei den Ebenen- und Textstilen

gibt es eine Suche, die die Namen der Symbole findet. Alle Symbole deines Dokuments

und aus den verknüpften Libraries sind hier verfügbar. Klicke auf ein anderes Symbol, und

Sketch ersetzt es.

Darunter ist der Button Detach, der die Instanz von der Vorlage trennt. Wenn du hier

klickst, dann wird die Instanz komplett unabhängig von der Vorlage. Halte die (alt)-Taste,

bevor du auf Layer > Detach from Symbol klickst. Dann ändert sich der Befehl zu Detach all

Contents from Symbol. Mit diesem Befehl trennen sich alle Instanzen von der Vorlage.

Es gibt keine Möglichkeit, abgetrennte Instanzen wieder zu verknüpfen. Mit dem Befehl

Layer > Replace with… kannst du aber bestehende Elemente mit einem Symbol ersetzen.

Rechts davon siehst du Edit Master, mit dem du zur Vorlage springst. Der folgende Ab-

schnitt dreht sich genau um dieses Thema: Unter der Überschrift Overrides findest du

einen Bereich, in dem du die Inhalte und Stile der Instanz überschreiben kannst.
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Vorlagen bearbeiten | Du kannst Vorlagen bearbeiten und damit alle Instanzen auf einmal

aktualisieren. Es reicht eine Instanz anzuklicken und (¢) zu drücken, schon springt Sketch

zur Vorlage. Symbolvorlagen sind als Artboards angelegt und im Inspector deswegen sehr

ähnlich. Du erkennst Vorlagen-Artboards daran, dass ihr Name violett geschrieben ist und

auch das Icon in der Ebenenliste violett eingefärbt ist.

Abbildung 5.11  Im Inspector entscheidest du über Smart Layout und die Overrides.

Erstens setzt du hier die Einstellungen für Smart Layout, eine Funktion für automatische

Größenanpassungen des Symbols, der im Abschnitt »Smart Layout – automatische Grö-

ßenanpassung« ausführlicher behandelt wird (Abschnitt 5.2.5).

Zweitens entscheidest du unter dem Punkt Manage Overrides, welche Ebenen in den In-

stanzen überschrieben werden können. Jede Ebene in deiner Vorlage taucht hier auf und

kann mit verschiedenen Optionen aktiviert und deaktiviert werden. Später in diesem Kapi-

tel lernst du die Overrides und Ihre Funktionen genau kennen.

Jede Veränderung auf dem Vorlagen-Artboard funktioniert wie auf einem normalen Art-

board. Sketch hält die beiden Teile eines Symbols synchron, die Änderungen werden sofort

in allen Instanzen deines Symbols umgesetzt.

Du kannst auch das Artboard vergrößern und verkleinern, dann ändert sich auch die

Größe des Symbols auf dem Canvas. Ein Symbol-Artboard hat eine Besonderheit, die für die

einfachen Artboards nicht gilt: Alle Ebenen, die in der Ebenenliste dem Artboard zugeordnet

sind, zeigt Sketch auch auf dem Canvas an. 

Abbildung 5.12  Ein Symbol-Artboard beschneidet den sichtbaren Bereich nicht.
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Bei normalen Zeichenflächen wird der sichtbare Bereich durch die Grenzen beschnitten.

Das ist besonders bei Schatten praktisch, weil sie nicht abgeschnitten werden.

Löschst du die Vorlage, trennt Sketch die Verbindung und wandelt alle Instanzen in Grup-

pen um. Wähle die Symbolvorlage aus, und klicke dafür auf Symbol > Convert Symbol to

Artboard oder drücke (cmd)+(ª)+(Y).

Abbildung 5.13  Möchtest du wirklich das Symbol auflösen und alle Instanzen in Gruppen umwandeln?

5.2.4    Overrides – Symbole überschreiben und Varianten anlegen

Es wäre sehr aufwändig, für jede Variation deines Designs ein neues Symbol anzulegen.

Stattdessen kannst du einfach die Vorlage so konfigurieren, dass die Instanzen einzelne

Werte und Inhalte selbst steuern. Im Endeffekt erlaubt dir diese Funktion, aus einer Vorlage

sehr viele unterschiedliche Instanzen zu machen. Selbst einfache Elemente wie Buttons

werden mit Overrides wandelbar, und du hast schnell verschiedene Versionen.

Abbildung 5.14  Eine Vorlage, viele verschiedene Instanzen dank der Overrides-Funktion

Für all diese Veränderungen brauchst du kein neues Symbol, sondern arbeitest mit den be-

stehenden Elementen deiner Vorlage.

� In die erste Kategorie von Overrides gehören die Inhalte, also Texte, Bilder und andere

Symbolinstanzen, die du für jede Variante individuell setzen kannst.
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� Die zweite Kategorie betrifft das Aussehen von Texten und Ebenen; so tauschst du in

jeder Instanz die Ebenen- und Textstile aus.

� Drittens kannst du auch Einstellungen aus dem Prototyping überschreiben.

Overrides einrichten und benutzen | Im Inspector steuerst du die Overrides. In der Symbol-

vorlage bestimmst du, welche Werte verändert werden können. In der Symbolinstanz ent-

scheidest du, wie die Werte verändert werden. Als Platzhalter- und Standardwerte benutzt

Sketch immer die Einträge aus der Symbolvorlage.

Abbildung 5.15  Der Inspector steuert, welche Overrides in den Instanzen möglich sind.

Der Bereich Manage Overrides zeigt bei Vorlagen die erlaubten Overrides an. Die erste

Checkbox schaltet alle Overrides ein oder aus. Danach siehst du den Namen der Ebene, und

darunter die Werte, die geändert werden können. Standardmäßig sind alle Overrides einge-

schaltet. Sicherlich bietet dies die größte Flexibilität, es kann bei großen Symbolen aber

auch schnell unübersichtlich werden.

Symbolinstanzen zeigen nur die Einstellungen, die du in der Vorlage aktiviert hast. In der

gleichen Reihenfolge wie bei der Vorlage findest du alle Ebenen aufgelistet. Je nach Typ bietet

dir Sketch ein Drop-down-Menü, Freitextfelder oder die Möglichkeit, eine Datei einzubetten

an. Neben den Overrides für Bilder und Texte siehst du ein kleines Icon, das die Data-Funktion

aktiviert. Damit kannst du zufällige Daten aus unterschiedlichen Quellen beziehen.

Wenn du nicht zufrieden bist, dann setze alle Overrides auf die Vorlage zurück – nutze

das kleine Symbol neben der Overrides-Übersicht, und klicke auf Reset Overrides.

Texte in einer Instanz ersetzen | Der Text aus der Symbolvorlage ist im Inspector bereits grau

eingetragen. Klicke in das Feld, und beginne zu tippen. Mit (¢) beendest du die Eingabe, und

der Override wird angewendet. Drückst du (esc), dann gehen die Änderungen verloren.
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Abbildung 5.16  Du kannst auf den Text klicken und dann den Inhalt überschreiben.

Erinnerst du dich an die Textebenen und die drei verschiedenen Zeilenumbrüche (Abschnitt 4.3,

»Das Text-Werkzeug«)? Es gibt die Wahl zwischen keinem automatischen Zeilenumbruch,

einer automatisch passenden Variante und einem Umbruch ohne Anpassung. Sketch greift

auf diese Einstellung zurück, wenn der neue Text länger als der alte wird.

Kurz gesagt wachsen Textebenen ohne Zeilenumbruch einfach weiter nach rechts. Mit

automatischem Zeilenumbruch entstehen am Ende neue Zeilen, und der Text wächst nach

unten. Bei einem Zeilenumbruch ohne Anpassung werden überschüssige Zeichen abge-

schnitten und sind nicht mehr sichtbar.

Textfelder leer lassen

Wenn du einen Text nicht anzeigen möchtest, drücke als Override die Leertaste, anstatt einen neuen Text 
einzutragen, und bestätige mit (¢). Sketch erkennt, dass in diesem Feld kein Text steht, und löscht die 
Ebene in dem Override.

Bilder überschreiben | Jede Form, die in deiner Vorlage mit einem Bild oder Muster gefüllt

ist, kannst du überschreiben. Bilder, die du als Bitmap-Grafik einfügst, überschreibt Sketch

nicht. Im Inspector siehst du dafür den Button Choose image…, mit dem du eine Datei über

den Finder auswählen kannst, die die Vorlage ersetzt. Oder du ziehst dein Bild mit der Maus

auf diesen Button, und schon wird es ersetzt.

Abbildung 5.17  Überschreibe Bilder mit Drag & Drop oder indem du nach einem Bild suchst.
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Text- und Ebenenstile verändern | Wechsele auch die Formatierung deiner Symbolinstanz

mit nur wenigen Klicks im Inspector. Alle Text- und Ebenenstile aus deinem aktuellen Doku-

ment und den verknüpften Libraries stehen dir dafür zur Verfügung.

Abbildung 5.18  Für die Vorlage müssen die Overrides aktiviert sein, damit du sie in der Instanz nutzen kannst.

Text- und Ebenenstile können dein Symbol in einem ganz neuen Licht erscheinen lassen.

Zum Beispiel kannst du so schnell zeigen, wie ein Button geklickt oder deaktiviert aussieht.

Wenn du keine Stile pflegst, dann wirst du auch nicht in vollem Umfang von Overrides bei

Symbolen profitieren.

Hotspots überschreiben | Hotspots sind eine Funktion von klickbaren Prototypen (mehr dazu

gleich). Du kannst sie dir wie eine klickbare Fläche vorstellen, die ein Artboard mit einem an-

deren verbindet. Wie alle anderen Ebenen kannst du sie in einem Symbol verwenden. Be-

sonders ist, dass du das Klickziel des Hotspots nachträglich anpassen kannst. Das ist zum

Beispiel sehr praktisch in der Menüleiste auf dem Icon. Wenn du das Icon wechselst, kannst

du auch das Ziel ändern. Um einen Hotspot zu überschreiben, klicke auf das Dropdown-

Menü, und wähle ein neues Ziel aus allen Artboards des Sketch-Dokuments.

Abbildung 5.19  Wenn in der Vorlage ein Hotspot angelegt ist, kannst du ihn in der Instanz überschreiben.
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Symbole überschreiben | Erinnern wir uns an den Workshop »Ein Symbol erstellen und ver-

wenden« (in Abschnitt 5.2). Dort hast du schon gelernt, dass auch Instanzen Teil eines

neuen Symbols werden können. Sketch nennt diese Möglichkeit Nested Symbols – ver-

schachtelte Symbole. Die Overrides-Funktion ändert auch verschachtelte Symbole. Das ist

besonders praktisch, wenn du eine große Icon-Sammlung hast und schnell von einem zum

anderen Icon wechseln möchtest. Wenn du ein verschachteltes Symbol ausblenden möch-

test, klicke auf No Symbol.

Abbildung 5.20  Fahre mit dem Mauszeiger über den Eintrag, mit dem du ersetzen möchtest.

Overrides und Data-Funktion | Zu Sketch gehört die Funktion Data, die aus unterschiedli-

chen Quellen Texte und Bilder in dein Design einfügen kann. Echte Daten sind zum Beispiel

Namen, Orte oder Bilder von Gesichtern. Um echte Daten auch in deinen Symbolen zu ver-

wenden, musst du die Symbolvorlage verändern. Wähle dort zum Beispiel eine Textebene,

und verknüpfe sie mit einer Quelle für Daten. Wenn du zufällige Gesichter verwenden

möchtest, wähle in der Vorlage eine Ebene aus, und klicke auf Layer > Data > Sketch Data >

Faces. Sie ist jetzt mit einem Bild gefüllt.

Abbildung 5.21  Ein Klick auf das Data-Icon 
zeigt dir die Optionen zum Überschreiben 
mit zufälligen Daten.
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Sobald diese Einstellungen gesetzt sind, kannst du die Data-Funktion auch als Override in

einer Symbolinstanz benutzen. Drücke auf (cmd)+(ª)+(D), um die Daten in deinen Ebenen

zu aktualisieren.

Um eine Instanz mit zufälligen Daten zu überschreiben, muss deine Vorlage aber nicht

mit einer Datenquelle verknüpft sein. Im Inspector bei der Instanz gibt es ein kleines Icon

neben dem Ebenennamen. Klicke hier, und du siehst alle Datenquellen, mit denen du diese

Ebene füllen kannst.

5.2.5    Smart Layout – automatische Größenanpassung

Okay, du hast alle Overrides kennengelernt und kannst jetzt aus einem Symbol viele dut-

zend Varianten erstellen. Allerdings musst du die Symbole immer noch selbst anpassen,

wenn sich die Textlänge ändert. Und wenn du durch die Overrides eine Ebene ausgeblendet

hast, dann behält die Instanz ihre Größe bei. Smart Layout ist die Funktion in Sketch, die ein

Symbol automatisch anpasst. Abhängig davon, wie viel Text ein Button hat, ändert sich die

Größe automatisch.

Abbildung 5.22  Deine Textänderungen haben Einfluss auf die Größe deiner Symbolinstanzen, 
wenn du Smart Layout benutzt.

Smart Layout gilt aber auch für ein Icon oder ein verschachteltes Symbol. Stell dir vor, du

hast eine Liste mit Überschrift und drei Einträgen als Symbol angelegt. Wenn du einen Ein-

trag aus der Liste entfernst, passt Sketch die Größe automatisch an. Lerne in diesem Ab-

schnitt, wie du Smart Layout einrichtest und im Inspector steuerst.
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Abbildung 5.23  Smart Layout funktioniert auch für verschachtelte Symbole.

Smart Layout einrichten | Wenn du ein neues Symbol anlegst, fragt dich Sketch bereits nach

der Smart-Layout-Einstellung. Solltest du dir noch nicht sicher sein, findest du alle Möglich-

keiten für Smart Layout auch im Inspector, indem du das Vorlagen-Artboard oder einen

Ordner auswählst. Im Bereich Layout findest du die Einstellungen für die Richtungen, in die

Änderungen angewendet werden sollen.

Abbildung 5.24  Sechs verschiedene Richtungen für Smart Layout sind im Inspector möglich.

Jede Symbolvorlage und jede Gruppe, die eine Smart-Layout-Einstellung hat, markiert Sketch

mit einem eigenen Icon in der Ebenenliste. Möchtest du eine Textebene nicht automatisch

verkleinern oder vergrößern, sperre sie in der Vorlage mit (cmd)+(ª)+(L).

Wenn du die verschiedenen Möglichkeiten von Smart Layout kombinierst, erkennst du,

wie sehr es dich unterstützen kann. In dem Beispiel in Abbildung 5.25 siehst du, dass die But-

tons einen eigenen Modus haben. Wenn ein Icon oder ein längerer Text sie füllt, dann wirken

sie dennoch ausgeglichen. Damit die beiden den Abstand zueinander halten, fasst du sie in

einer eigenen Gruppe zusammen ((cmd)+(G)), die von rechts nach links wachsen soll.

Das ganze Artboard wiederum vergrößert sich von oben nach unten, wenn ein Element

zu lang wird. In dem Beispiel siehst du, dass der Beschreibungstext die Größe des Elements

verändert.
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Abbildung 5.25  Drei Einstellungen für Smart Layout ermöglichen es, schnell viele Varianten herzustellen.

Ein bisschen verhält sich Smart Layout also wie der Textmodus. Dabei vergleicht Sketch die

Abmessungen des Texts in der Vorlage mit denen der Instanz, um zu verstehen, wie sich

das Layout verändert. Darauf solltest du deine Textebenen einstellen – wenn du die Größe

der Textebene fixierst oder die Ebene sperrst, bleibt das Layout fest in den Formen.

5.3    Libraries – Symbole und Stile teilen

Egal ob du mit anderen Designern, Entwicklern oder deinem Nachbarn an einem Projekt ar-

beitest – alle sollten auf dem neuesten Stand sein. Dabei ist die Balance aus Kontrolle und

Freiraum ein wichtiges Element. Alle wollen ihre Ideen umsetzen, aber ohne gemeinsame

Regeln geht es meistens nicht. Die Libraries (Bibliotheken) versuchen genau diese Balance

zu halten. Es sind Sketch-Dateien, deren Symbole, Stile und gespeicherte Farben in allen Do-

kumenten verfügbar sind.

In diesem Abschnitt lernst du, wie Libraries funktionieren, wie du ein Dokument zur Li-

brary machen kannst und welche Besonderheiten es für Symbole und Stile gibt. Außerdem

siehst du, wie du Updates für die gespeicherten Komponenten machst.

5.3.1    Libraries kurz erklärt

Eine Library ist ein Sketch-Dokument, das du als Sammlung für verschiedene Design-Kom-

ponenten benutzt. Im Gegensatz zu den lokalen Symbolen und Stilen einer Datei sind die

Komponenten aus einer Library für alle Sketch-Dokumente auf deinem Mac verfügbar.

Gibst du anderen Personen Zugriff auf die Datei, dann profitieren viele Designer von deiner

Library und benutzen die gleichen Komponenten.
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Aber nicht nur deine eigenen Designs haben Platz in einer Library. Auch eine Icon-Samm-

lung könnte so zur Verfügung stehen, und für die Bedienelemente von iOS und Android gibt

es sogar offizielle Libraries zum Herunterladen.

Abbildung 5.26  Sketch Libraries vererben ihre Symbole und Stile an alle Sketch-Dokumente, mit denen 
sie verknüpft sind.

An den gespeicherten Komponenten können sich alle bedienen und sie auch aktualisieren.

Jede einzelne Person hat großen Freiraum beim Design, während es gleichzeitig eine Kon-

trolle durch die standardisierten Komponenten gibt.

Wenn es Änderungen an den Komponenten einer Library gibt, dann synchronisiert Sketch

sie mit allen Dokumenten. So können Änderungen an Farben, Schriften oder zum Beispiel

einem Button-Stil schnell in einem ganzen Design Team geteilt werden.

5.3.2    Ein Dokument zur Library machen

Es soll so einfach wie möglich sein, eine Library zu erstellen. Jedes Dokument mit einem

Symbol kann bereits eine Library sein. Wenn du das gerade geöffnete Dokument zur Library
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erklären möchtest, klicke auf File > Add as Library. Fertig. Jetzt sind die dort gespeicherten

Symbole, Stile und Farben für alle Dokumente auf deinem Computer verfügbar.

Libraries in den Einstellungen verwalten | Öffne die Programmeinstellungen von Sketch un-

ter Sketch > Preferences…, oder du drückst (cmd)+(,), klickst auf den Tab Libraries und dann

auf den Button Add Library….

Abbildung 5.27  Eine Übersicht zu deinen Libraries findest du in den Sketch-Einstellungen.

In der Liste ist bereits eine Library aufgeführt; es handelt sich um die Apple iOS UI Library.

Apple stellt eine aktuelle Version der Benutzeroberfläche für iPhone und iPad bereit. Du

kannst sie per Klick installieren. In diesen Dokumenten findest du fast alle Bedienelemente,

die in iOS und iPadOS verwendet werden. So kannst du die aktuellen Tastaturen, Menüs,

Texte, Farben und vieles mehr kostenlos verwenden. Für macOS findest du diese und an-

dere Libraries auf der Entwickler-Website von Apple unter https://developer.apple.com/

design/resources/. Der Haken vor dem Listeneintrag zeigt an, dass die Komponenten in

Sketch verfügbar sind.

Die Libraries sind immer automatisch auf dem neuesten Stand. Dokumente, die sich nicht

auf deinem Computer befinden, sind offline verfügbar, und Sketch versucht sie zu aktuali-

sieren, sobald eine Internetverbindung besteht.

Mehr Einstellungen verbergen sich hinter dem Zahnrad-Symbol. Die Optionen sind Dis-

able Library (deaktivieren), Preview Library (Vorschau öffnen), Show in Finder (im Finder zei-

gen), Open (Datei öffnen) und remove Library (entfernen). Es gibt kein Limit für die Anzahl

von Libraries in Sketch. Um eine schönes Vorschaubild für deine Library zu bekommen, lege
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im Dokument ein Artboard mit dem Namen »Library Preview« an. Es wird dann als in der

Liste gezeigt.

Fester Speicherort für Libraries

Einmal eingerichtet, solltest du den Namen oder Speicherort deiner Library nicht mehr ändern. Sonst kann 
Sketch keine Verknüpfung zu deiner Datei und den Symbolen herstellen. Um die Verknüpfungen zwischen 
den Komponenten und ihrer Vorlage wiederherzustellen, klicke mit rechts und dann auf Locate missing 
Library…

5.3.3    Als Team an einer Library arbeiten

Es gibt vier verschiedene Wege, als Team an einer Library zusammenzuarbeiten. Für jeden

brauchst du einen gemeinsam genutzten Speicherort. Entweder du speicherst die Library

auf einem lokalen Server, bei einem Webdienst wie Google Drive, in der Sketch Cloud oder

auf deinem eigenen Online-Server.

1. Lokaler Server: Lege deine Datei auf einem gemeinsamen Dateisystem ab. Frage bei dei-

nen Administratoren nach, ob du bereits Zugriff auf ein solches System hast.

2. Bei Google Drive, Dropbox oder GitHub: Hierfür brauchst du ein Konto bei dem entspre-

chenden Dienst. Außerdem musst du eine Software installieren, mit der die Dateien in

deinem Finder zugänglich gemacht werden. Alle Teilnehmer an der Library brauchen

ebenfalls Zugriff, je nach Dienst müssen also auch andere Personen die Software instal-

lieren.

3. Sketch Cloud: Jedes Dokument, das du in der Sketch Cloud speicherst, kann auch als Li-

brary benutzt werden. In der Sketch Cloud vererben sich nur Änderungen des Library-

»Besitzers« auf die verknüpften Instanzen. Lade deine Library in die Sketch Cloud hoch.

Klicke in der Werkzeugleiste auf Cloud und dann auf den Button Upload Document. Auf

der Web-Oberfläche der Sketch Cloud machst du dein Dokument zu einer Library. Mit

genau diesem Link abonniert dein Team die freigegebene Library. Sie wird automatisch

in den lokalen Programmeinstellungen angezeigt.

4. Online-Server: Das Abonnieren einer Sketch Library funktioniert auch, wenn die Datei

auf einem Server im Internet gespeichert ist. Um die Datei abzurufen, brauchst du viel-

leicht Unterstützung von einem Entwickler. Wenn du mehr über diesen Weg wissen

möchtest, schau in der Dokumentation für Entwickler (https://developer.sketch.com/

app#add-shared-library) nach.

5.3.4    Darstellung und Handhabung von Library-Symbolen

Ein Symbol aus einer Library wird in der Ebenenliste mit dem Icon für Libraries markiert. So

kannst du es gut von anderen Komponenten in deinem Dokument unterscheiden.
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Abbildung 5.28  Achte auf das Icon in der Ebenenliste, um ein Library-Symbol zu erkennen.

Libraries unterstützen auch die Ordnerstruktur für Symbole. So kannst du Symbole besser

sortieren und klarer benennen. Auch Text- und Ebenenstile funktionieren auf diese Weise.

Um Symbole zu verschachteln, nutze den Schrägstrich »/«, um einen Unterordner zu erstel-

len: Level 1 / Level 2 / … / Symbol.

Library-Symbole bearbeiten | Wenn du eine Instanz eines Library-Symbols auswählst und

danach (¢) drückst, warnt dich Sketch davor, dass du zum Bearbeiten das aktuelle Doku-

ment verlässt. Alle Änderungen, die du an Vorlagen in der Library vornimmst, gelten für alle

Instanzen in allen Dokumenten. Überlege deswegen, ob sich deine Änderungen auf alle

diese Dokumente übertragen lassen.

Abbildung 5.29  Entscheide, wie du beim Bearbeiten von Library-Symbolen vorgehen möchtest.

Klicke auf Open in Library, um die Vorlage zu bearbeiten. Als Alternative bietet Sketch an,

die Verknüpfung zu löschen. Das Symbol wird dann geklont und als lokale Kopie in deinem

Dokument gespeichert.
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5.3.5    Stile in Libraries

Alle Stile, die du in einer Library-Datei angelegt hast, sind auch in anderen Dokumenten ver-

fügbar. So kannst du schnell und effizient viele Dokumente für viele Designer beeinflussen

und zum Beispiel Farben anpassen oder die Schriftart updaten. Stile aus Libraries findest du

mit dem Namen der Library aufgelistet im Dropdown. Bei so vielen Stilen verliert man schnell

den Überblick. Die eingebaute Suche ist schon aktiviert, fang einfach an zu schreiben.

Abbildung 5.30  Alle Stile aus verschiedenen Dokumenten kannst du über die Suche erreichen.

Änderungen für den Stil nimmst du in der Library-Datei vor. Jedes Dokument, das mit den

älteren Stilen arbeitet, wird daraufhin benachrichtigt, dass eine neue Version bereitsteht.

Wann die Änderungen übernommen werden, steht nicht fest.

Problematisch ist es, wenn die Schriftart eines Stils nicht auf deinem Mac gespeichert ist.

Diese Stile kannst du nicht anwenden und Sketch markiert sie mit einem gelben Warndrei-

eck. Lade die Schrift herunter oder speichere die Schriftart in das Library-Dokument ein. Wie

das geht, liest du in Abschnitt 4.3.2, mehr über Stile erfährst du im Abschnitt 5.1, »Stile für

Ebenen und Texte«.

5.3.6    Updates überprüfen und anwenden

Du entscheidest selbst, ob und welche Änderungen aus einer Library du übernimmst. Eine

Zahl an der Glocke in der oberen rechten Ecke deines Sketch-Fensters weist dich darauf hin.

Alle Änderungen, die du oder jemand anderes an der Library vorgenommen hat, kannst du

so überprüfen.
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Abbildung 5.31  Rechts über der Werkzeugleiste zeigt dir Sketch, wenn es Neuigkeiten zu deinen Libraries gibt.

Das Fenster Library Updates zeigt dir eine Liste mit allen veränderten Elementen. Standard-

mäßig haben alle Elemente einen blauen Haken – diese Elemente wirst du übernehmen,

wenn du den Button Update Symbols anklickst. Deaktiviere den Haken, und die Änderun-

gen kommen nicht in dein Dokument.

Abbildung 5.32  Vergleiche die existierende Version mit der Änderung aus der Library, 
und entscheide, ob du die Änderungen übernehmen willst.

Daneben siehst du die Darstellung der alten und der neuen Elemente. Egal ob Symbol,

Ebenen- oder Schriftstil, alle Änderungen aus einer Library kannst du nachverfolgen. Alle

Updates, die du dieses Mal nicht angenommen hast, bekommst du weiterhin angezeigt.

Um Updates für bestimmte Elemente komplett abzuschalten, musst du die Symbole und

Stile von der Bibliothek trennen. Wähle dafür das betroffene Element aus und klicke auf

»Detatch« im Inspector.
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6.3    Sketch Runner

Mit Runner erreichst du schneller alle Sketch-Funktionen. Inspiriert von der Spotlight-Suche

auf dem Mac kannst du dank dieses Plugins alle Bereiche des Programms durchsuchen.

Dazu gehören sämtliche Befehle in der Menüleiste, die Ebenen, Seiten und Stile. Außerdem

kannst du alle Sketch Plugins durchsuchen und direkt installieren. Mit diesen Funktionen ist

Runner regelmäßig in Blog-Artikeln zu finden, in denen es um die besten Sketch Plugins

geht. Es wird wahrscheinlich am häufigsten von professionellen Designern installiert, die

beim Designen Zeit sparen wollen.

In diesem Kapitel lernst du, wie du mit Runner dank seiner Funktionen schneller durch

Menüs, Symbole und Stile navigieren kannst. Runner ist kein komplett kostenloses Plugin,

deswegen schauen wir uns auch noch die Lizenzen und Kosten für RunnerPro an, bevor du

zwei Beispiele zur Verwendung lesen kannst.

6.3.1    Was macht Sketch Runner?

Mit einer Tastenkombination eröffnet Runner dir die Möglichkeit, Sketch komplett zu

durchsuchen. Kern des Plugins ist das Suchfeld, in dem du durch Tippen nach einem Begriff

suchst. Runner findet dann passende Funktionen für dich.

Abbildung 6.20  Links die Spotlight-Suche von macOS, rechts der davon inspirierte Sketch Runner

Um alle Bereiche von Sketch abzudecken, sind die Aktionen im Plugin in sechs Kategorien

aufgeteilt.

� Run: Alle Einträge und Untermenüs aus der Menüleiste. Beginne zu tippen, um sie zu

durchsuchen.

� Goto: Damit kannst du Seiten, Artboards und Ebenen nach Namen filtern.

� Insert: Dieser Befehl durchsucht deine Symbole und Libraries.

� Create: Erstelle aus den aktuell ausgewählten Ebenen ein Symbol oder einen Ebenen-

bzw. Textstil.

� Apply: Wende einen Stil aus deinem Dokument oder einer Library an.

� Install: Finde ein Plugin bei GitHub, und installiere es direkt in Runner.

Um zwischen den Kategorien zu wechseln, drücke (ÿ).
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Pro-Funktionen: RunBar und Components Browser | Mit der Installation von Runner kom-

men noch zwei besondere Funktionen hinzu. Die erste ist die RunBar, eine Leiste am oberen

Rand deines Canvas. Sie enthält eine Navigation für dein Dokument auf der linken Seite und

einen Bereich für Plugin-Aktionen auf der rechten Seite.

Abbildung 6.21  Die RunBar mit Dokument-Navigation auf der linken und Plugin-Aktionen auf der 
rechten Seite

Die zweite Funktion, der Components Browser, ermöglicht dir eine übersichtliche Suche

durch alle Symbole und Stile in deinem Dokument. Für den Browser öffnet sich ein eigenes

Fenster mit ähnlichen Funktionen wie in der Komponenten-Übersicht (Abschnitt 2.4, »Ebe-

nenliste, Dokumentstruktur und Seiten«). Klicke und ziehe ein Icon oder einen Stil aus dem

Fenster, um es auf deinem Canvas zu positionieren.

Abbildung 6.22  Deine Symbole und Stile übersichtlich im Components Browser
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Der Vorteil eines eigenen Fensters: Du kannst es auf einem zweiten Bildschirm (zum Bei-

spiel einem iPad mit Apples Sidecar) anzeigen. So hast du deine Design-Komponenten

immer im Blick.

Eine einzige Tastenkombination | Bei der ersten Verwendung von Runner wirst du nach

einer Tastenkombination gefragt. Für das deutsche Tastaturlayout bietet sich zum Beispiel

(cmd)+(#) an, für ein englisches Layout macht Runner auch andere Vorschläge.

Abbildung 6.23  Beim Start fragt das Plugin nach deiner persönlichen Tastenkombination für Runner.

6.3.2    RunnerPro und Kosten

Nach einer Testzeit von 14 Tagen wirst du gebeten, die Pro-Version zu kaufen. Wenn du das

nicht möchtest, kannst du Runner in der Variante »Classic« weiterbenutzen. Dabei sperrt

das Plugin alle Funktionen bis auf Run und Install. Ein kleines Team entwickelt Sketch Run-

ner immer weiter. Für die Nutzung aller Funktionen verlangen sie einen einmaligen Betrag

von 45 Euro. Es gibt keine weiteren Kosten. Für Schüler und Studenten bietet Runner eine

vergünstigte Version an. Dafür brauchst du einen Ausweis oder eine verifizierte E-Mail-

Adresse deiner Schule.

Runner um 25 % reduziert

Mache ein Foto von dieser Doppelseite des Buchs, um dir 25 % Rabatt auf Runner zu sichern. Sende es mit 
einem freundlichen Gruß per Mail an hello@sketchrunner.com. (Es besteht kein Anspruch auf diesen Ra-
batt, und er ist auch nicht mit anderen Aktionen kombinierbar.)

6.3.3    Beispiele für die Verwendung

Am besten lernst du Sketch Runner kennen, wenn du die Kommandozeile selbst benutzt. Er

hilft dir, komplizierte Aufgaben in Sketch schnell wiederzufinden oder neue Plugins zu in-

stallieren.
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SCHRITT FÜR SCHRITT

Menüs durchsuchen – Icon-Library erstellen

Im vorherigen Abschnitt zu Automate Sketch hast du bereits eine Icon-Library erstellt. Dank

des Runner-Plugins brauchst du die Befehle nicht mehr mit dem Mauszeiger in der Menü-

leiste suchen. Stattdessen lernst du, die nächsten Schritte bei der Erstellung der Icon-Library

mit Runner auszuführen.

In dem Dokument sind die mehr als 700 Icons mittig ausgerichtet und in einem Raster

auf dem Canvas angeordnet.

Abbildung 6.24  Die Ausgangssituation: ein Sketch-Dokument mit 700 Icons

1 Runner öffnen

Jetzt gehst du einen Schritt weiter und erstellst daraus mit Hilfe eine Sketch Library. Öffne

dazu Runner mit deiner Tastenkombination, oder klicke auf Plugins > Runner > Run.

Abbildung 6.25  Runner ist bereit für deine Suche.
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2 Auswahl treffen

Als Erstes musst du im Sketch-Dokument alle Artboards auswählen. Beginne dafür, in Run-

ner »Select« zu tippen, und beobachte die Ergebnisse. Du suchst nach dem Befehl Select all

Artboards. Um einen Eintrag auszuwählen, drücke die Pfeiltaste (¼) oder (½). Mit (¢)

bestätigst du den Befehl Select all Artboards.

Abbildung 6.26  Runner sucht bereits bei der Eingabe nach einem passenden Menüeintrag.

3 Artboards in Symbole umwandeln

Sind alle Artboards ausgewählt, kannst du sie zu Symbolen machen. Anstatt das einzeln zu

tun, benutzt du eine Funktion des Automate-Plugins. Öffne erneut Runner, und beginne zu

schreiben: »Create …« Der Befehl Create Symbols from selected Layers sollte schon nach

den ersten Buchstaben sichtbar sein.

Abbildung 6.27  Du kannst auf einen Eintrag in der Suchliste auch doppelklicken, um ihn auszuführen.
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Jeder weitere Buchstabe grenzt die Suche weiter ein. Drücke wieder (¢), und du siehst den

Dialog des Automate-Plugins in Abbildung 6.28 – als hättest du selbst mit der Maus den Be-

fehl gesucht und geklickt.

Abbildung 6.28  Deaktiviere in diesem Fall den 
Haken bei Send Symbols to »Symbols« page.

Alle Artboards in deinem Dokument sind jetzt zu Symbolen umgewandelt.

4 Library hinzufügen

Bereits jetzt kannst du die Datei speichern und als Library in Sketch hinterlegen. Öffne Run-

ner wieder mit deiner Tastenkombination, und beginne deine Suche nach »Library«. Wähle

Add as Library mit den Pfeiltasten aus, und drücke dann (¢).

Abbildung 6.29  Runner findet Einträge unabhängig davon, mit welchem Wort sie beginnen.

Mit einer weiteren Suche nach Preferences… und Drücken von (¢) öffnen sich die Pro-

grammeinstellungen, und du siehst bereits, dass die Datei CSS Icons zu den Libraries gehört

(siehe Abbildung 6.30).
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Mehr ist nicht notwendig, um eine Icon-Library zu erstellen. Farbvarianten der Icons kannst

du über die Funktion Tints in jeder Symbolinstanz einzeln steuern.

SCHRITT FÜR SCHRITT

Plugins installieren

Egal ob du bereit bist, Runner Pro zu bezahlen oder nicht – die Funktion zum Installieren

von Plugins ist immer kostenlos. Wenn du also nach einem Plugin suchst, dann musst du

Sketch nicht mehr verlassen und auf der Website suchen. Runner erledigt Suche und Instal-

lation direkt für dich. Außerdem zeigt es dir die beliebtesten Plugins und welche Funktionen

ein Plugin mitbringt, noch bevor du es installierst.

1 Suchen

Drücke deine Tastenkombination, oder klicke Plugins > Runner > Run, um das Suchfeld zu

öffnen.

Abbildung 6.31  Sketch Runner, bereit für deine Eingabe

2 Plugin-Installation

Um zur Plugin-Installation zu kommen, drücke einmal (ª)+(ÿ) oder fünfmal (ÿ). So

springst du zwischen den einzelnen Suchbereichen. Bleibe beim Abschnitt Install stehen.

Abbildung 6.30  Die Library ist jetzt in den 
Einstellungen hinterlegt und über die Menüs 
in Sketch verfügbar.
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Dort siehst du alle offiziellen Sketch Plugins und eine Beschreibung. Auf der rechten Seite

ist vermerkt, ob das Plugin bereits installiert ist.

Abbildung 6.32  Die Liste ist nach der Anzahl der Sterne für das GitHub-Repository sortiert. 
Besonders beliebte Plugins stehen also oben.

3 Plugin suchen

In diesem Beispiel suchst du nach einem Eintrag mit dem Namen »Minimap«. Einmal instal-

liert, zeigt das Plugin eine kleine Karte aus den erstellten Artboards in deinem Dokument.

Abbildung 6.33  Meine Suche nach »Mini« ist bereits erfolgreich.
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Drücke (¢), und eine Vorschau für das Plugin erscheint. Auf der linken Seite findest du alle

relevanten Informationen zum Plugin. Rechts steht der Name, eine Kurzbeschreibung, der

Name des Entwicklers und eine Liste mit den verfügbaren Befehlen.

Plugins löschen

Runner kann auch Plugins aus deinem System löschen. Drücke dafür (cmd)+(ª)+(_í) auf einem Ein-
trag in der Plugin-Liste.

4 Befehle im Runner

Damit sind alle Befehle für das Plugin bereits in Runner verfügbar. Du öffnest wieder die

Suchleiste und suchst bei Run nach »Minimap«. Der Eintrag erscheint sofort, und schon

siehst du dein Dokument als kleine Karte.

Abbildung 6.35  Alle neuen Befehle sind direkt verfügbar.

Abbildung 6.34  Innerhalb 
von Sekunden ist das Plugin 
fertig installiert.
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6.3.4    Tipps und Tricks für Runner

Ein paar Funktionen sind noch versteckt, und es wäre zu schade, diese kleinen Tricks nicht

mit dir zu teilen.

� Den letzten Befehl erneut ausführen: Leg in den Runner-Einstellungen eine Tastenkombi-

nation fest, um den letzten Befehl nochmal auszuführen. Ich habe dafür (cmd)+(ª)+(#)

gespeichert.

� Die letzte Suche fortführen: Drücke (½), wenn du noch nichts eingegeben hast, und der

letzte Suchbefehl wird angezeigt. Drücke mehrfach, um durch die Suchhistorie zu springen.

� Libraries von der Suche ausschließen: In den Suchen Insert und Apply findest du einen

Button rechts in der Suchleiste. Klicke darauf, um zu steuern, welche Libraries durch-

sucht werden.

Abbildung 6.37  Leg fest, welche Libraries durchsucht werden sollen.

Abbildung 6.36  Eine kleine Karte deiner aktuell geöffneten 
Sketch-Seite erscheint.
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Sketch ist ein Programm, dass es dir leicht macht, Ideen direkt umzusetzen. Du sollst durch

die Verwendung der Software zu einem besseren Designer werden. In den vorangegange-

nen Kapiteln hast du die Werkzeuge in Sketch kennengelernt und hast gesehen, wie die

Funktionen bedient werden. Jetzt beginnst du, kleinere und größere Projekte zu realisieren.

In den folgenden Abschnitten bekommst du fünf praxisnahe Projekte für Designer in ver-

schiedenen Bereichen mit unterschiedlichen Erfahrungsstufen präsentiert. Die ersten bei-

den haben einen Schwerpunkt auf User Interface Design. Erst lernst du am Beispiel eines

Chats, dann anhand einer Marketing-Website mit Sketch deine Ideen umzusetzen.

Danach konzentrierst du dich mehr auf das User Experience Design. Es geht um den Auf-

bau eines digitalen Produkts, bevor du es visuell gestaltest. Du lernst UX-Prozesse kennen

und erstellst einen Wireframe für eine Musik-App.

Wenn du Zeichnen mit Sketch lernen möchtest, dann lies den vierten Abschnitt zu Icons

und Illustrationen. Schritt für Schritt erstellst du fünf Icons und lernst die Design-Regeln für

sie kennen.

Das letzte Beispielprojekt ist eine Anleitung für den Beginn eines Design-Systems. Es fasst

zentrale Komponenten deines Designs zusammen und dokumentiert dein Design für an-

dere Teammitglieder.

Den Abschluss des Praxisteils bildet dann auch ein Abschnitt über die bessere Zusam-

menarbeit im Team. Er zeigt, wie du die Tools von Sketch für eine bessere Kooperation ein-

setzt. Ähnlich wie im Grundlagen-Kapitel können diese Anleitungen nur der Ausgangspunkt

deiner Arbeit mit Sketch sein. Sie sind an manchen Stellen gerade so kurz gehalten, dass du

schnell zum Ziel kommst. Legen wir los!

8.1    Chat entwerfen

Schon eine scheinbar einfache Benutzeroberfläche kann eine echte Herausforderung für

Designer sein, denn in den Details kommt Design am stärksten zum Ausdruck. So solltest

du bei der Wahl deiner Farben, Schriftgrößen und Abstände genau arbeiten.

Ein überschaubares, erstes Praxisprojekt mit Sketch ist ein Chat für Smartphones. Wahr-

scheinlich hast du schon mal einen Chat benutzt und kannst dir ungefähr vorstellen, aus

welchen Teilen diese Funktion besteht. Schreib die wichtigsten Bestandteile eines Chats
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auf. Du kannst dafür direkt Sketch benutzen, es reicht aber auch ein Stift, mit dem du die

Liste hier ausfüllst.

�

�

�

�

�

Welche Bestandteile hast du? Lass uns vergleichen, vielleicht fällt dir etwas Wichtiges ein,

das hier nicht auftaucht. Das sind meine Vorschläge:

� Nachricht eingeben

� Nachrichten lesen

� Nachricht abschicken

� Empfänger der Nachricht

Jeder dieser Bestandteile erfüllt eine der Kernfunktionen, die wichtig für den Austausch von

Nachrichten ist. Überlege, was wirklich essentiell für dein Design ist (hier: Nachrichten zwi-

schen zwei Personen senden), dann reduziert sich der erste Aufwand für dein Design. Spä-

ter kannst du noch weitere Funktionen hinzufügen und ausschmücken.

Mit dieser Liste beginnst du dein Design; du kannst später an ihr abgleichen, ob alles in

deinem Design enthalten ist.

SCHRITT FÜR SCHRITT

Chat mit Sketch designen

Wenn noch nicht geschehen, öffne Sketch, erstelle ein neues Dokument mit Klick auf File >

New…, und speichere es mit einem eindeutigen Namen (zum Beispiel »Chat«) ab. Als Erstes

erstellst du ein Artboard. Drücke dafür (A), und wähle im Inspector bei den Apple Devices

das iPhone 11 Pro aus. Damit hat dein Artboard automatisch die richtigen Abmessungen:

375 × 812.

1 Nachrichten eingeben

Lass uns die Liste der Chat-Bestandteile von oben nach unten durchgehen. »Nachricht ein-

geben« steht dort ganz oben. Der erste Schritt zur Eingabe einer Nachricht ist die Tastatur.

Also beginnen wir damit, sie auf dem Artboard zu platzieren. Du musst jetzt nicht selbst

eine ganze Tastatur zusammenklicken, denn es gibt die iOS-Design-Komponenten direkt

zum Download in Sketch.

Wechsele dafür in die Programmeinstellungen (Sketch > Preferences…), und klicke dort

auf den Tab Libraries. Wenn du die Library Apple iOS UI Design Resources noch nicht instal-

liert hast, dann klicke auf den blauen Button Install, und durchlaufe den Installationspro-

zess. Du musst die Geschäftsbedingungen bestätigen und zum Schluss die Datei in den

Libraries-Ordner ziehen.
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Abbildung 8.1  Schalte die iOS-Komponenten über Preferences frei

Sobald die Library installiert ist, hast du Zugriff auf viele wichtige Bestandteile der Apple-

Design-Sprache auf iPhones, darunter auch verschiedene Tastaturen. Du findest das rich-

tige Symbol im Untermenü Insert > Symbols > Apple iOS UI > System > Keyboards > iPhone

> Light > alphabetic. Die Library ist so sehr verschachtelt, weil sie so viele Symbole enthält.

In der Vergangenheit hat sich die Struktur der Library schon geändert, vielleicht ist der ge-

naue Pfad in deiner Version also etwas anders. Wenn du die Tastatur ausgewählt hast,

kannst du sie mit einem Klick am unteren Ende des Artboards platzieren.

Abbildung 8.2  Platzierung der Tastatur
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Über die Tastatur kommt das Eingabefeld für die Nachricht. Benutze dafür ein Rechteck (R),

das du über der Tastatur platzierst. Du kannst dich an den Größen im Bild orientieren:

327 px Breite und 56 px Höhe. Schaue auf die Abstände zu den anderen Elementen.

Ändere im Inspector die Füllfarbe auf #FFFFFF, und füge eine Rahmenfarbe mit dem HEX-

Farbcode #3F95FD hinzu. Platziere den Rahmen auf der Außenkante, und trage bei Width 2

ein. Zuletzt ziehe den Regler bei Radius (Round Corners) auf 28.

Damit das Rechteck als Nachrichtenfeld erkennbar ist, trage einen Beispieltext ein. Drücke

dafür (T), und klicke einmal in das Feld. Als Beispieltext kannst du »Schreibe deine Nach-

richt…« benutzen. Der Text muss noch ein bisschen angepasst werden: Schriftart, Schrift-

schnitt, Schriftgröße, Zeilenhöhe und Farbe findest du im Inspector.

Was jetzt noch fehlt, um eine Nachricht einzugeben, ist der blinkende Strich am Beginn des

Textes. Diesen Cursor findest du auch in der Apple-iOS-Library.

Klicke dafür auf Insert > Symbol > Apple iOS UI > Controls > Text Field > x > Cursor, und

platziere den Cursor vor dem Text. Passe den Cursor noch an den Text an, indem du die

Länge im Inspector auf »24« änderst.

Abbildung 8.3  
Eingabefeld 1

Abbildung 8.4  Formatierung des Eingabefelds

Abbildung 8.5  Beispieltext for-
matieren, du kannst auch eine 
andere Schriftart benutzen.
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Wenn du jetzt (ª) hältst und dann auf das Rechteck klickst, sind Cursor und Eingabefeld

ausgewählt. Richte sie vertikal mittig aneinander aus.

2 Nachrichten lesen

In einer Chat-App sind die Nachrichten der Teilnehmer wahrscheinlich der wichtigste Teil.

Erstelle auch hier wieder ein Rechteck (218 × 40), und platziere es linksbündig 16 px über der

Nachrichteneingabe. Ändere auch wieder die Farbe und den Radius im Inspector.

Wähle die Ebene aus, und klicke dann auf Layer > Create Layer Style oder im Inspector auf

den Button Create im Abschnitt Appearance. Damit erstellst du einen Ebenenstil, den du

durch Tippen »light« nennst.

Jetzt erstellst du den Nachrichtentext mit Druck auf (T). Der Text sieht fast genauso aus

wie der Platzhaltertext im Nachrichtenfeld, nur die Farbe ist anders. Danach erstellst du

einen Textstil, indem du auf Layer > Create Text Style klickst. Als Name trägst du »dark« ein.

Positioniere den Text wie in der folgenden Abbildung. Achte auch darauf, dass die Breite der

Ebene stimmt und der Zeilenumbruch auf Auto Height eingestellt ist.

Markiere beide Ebenen, und drücke (cmd)+(Y) oder klicke auf Layer > Create Symbol. Nenne

es »Textfeld«, und stelle beim Layout Top to Bottom Layout ein. Der Haken bei Send Symbol

to »Symbols« Page sollte aktiv sein. Bestätige den Dialog mit Create.

Abbildung 8.6  Blinkenden Cursor einfügen

Abbildung 8.7  Nachrichtenfeld 
einrichten

Abbildung 8.8  Platzhaltertext 
für die Nachrichteneingabe
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Drücke (¢) und du wechselst zur Symbolvorlage. Dort legst du noch je einen weiteren Stil

für den Text und die Ebene an, indem du das Aussehen änderst und dann erneut auf Create

klickst. Wähle die Textebene, und ändere die Farbe auf #FFFFFF. Der Name für den Stil ist

»light«. Den gleichen Vorgang wiederholst du bei der Ebene – dort änderst du die Farbe auf

#0056BF und speicherst als »blue«. Kehre zurück zur Symbolinstanz auf dem Canvas. Dort

kannst du über den Dialog Insert > This Document > Textfeld selbstständig neue Nachrich-

ten einfügen.

Im Inspector findest du die Overrides für den Ebenen- und Textstil sowie den Textinhalt.

Mit diesen drei Variablen kannst du alle Nachrichten selbst anpassen. Durch die gewählten

Autolayout-Einstellungen passt sich die Größe der Ebene immer dem Inhalt an.

Wenn du die Symbole verwendest, dann achte wieder auf gleichmäßige Abstände zum Art-

board und zu anderen Ebenen.

3 Nachrichten abschicken

Es fehlt noch ein Button, um Nachrichten, die in das Feld getippt wurden, abzuschicken. Er-

stelle dafür einen Kreis (O) in der Größe 48 × 48. Um eine Farbe auszuwählen, drücke

(ctrl)+(C) für das Pipetten-Werkzeug, fahre mit der Lupe auf eine der blauen Nachrichten,

und klicke. Die Füllfarbe des Kreises sollte jetzt auch #0056BF sein.

Abbildung 8.9  Symbol Textfeld

Abbildung 8.10  Durch das Autolayout wird 
der Text automatisch angepasst.
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Das passende Icon findest du bei Feather Icons (http://feathericons.com). Durchsuche die

Liste nach send, und klicke auf den Eintrag auf der Website, um das Icon als SVG-Datei he-

runterzuladen.

Abbildung 8.12  Symbole bei Feather Icons

Aus den Downloads ziehst du das Icon auf den Canvas und platzierst es optisch mittig auf

dem Button. Das Icon wird in Schwarz eingefügt, aber wenn du auf das Plus-Zeichen bei

Tint im Inspector schaust, dann kannst du die Farbe des ganzen Icons auf #FFFFFF ändern.

Abbildung 8.11  Button 
erstellen 

Abbildung 8.13  Icon einfügen
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4 Empfänger der Nachricht

Als letzten Bestandteil des Designs fügst du den Empfänger der Nachricht hinzu. Die Dis-

playform des iPhone X und seiner Nachfolgemodelle solltest du in diesem Design besonders

beachten. Füge dafür zwei weitere Symbole aus der iOS-Library hinzu und platziere sie an

der oberen Kante des Artboards.

� Insert > Apple iOS UI > Device Bezels > iPhoneXS – Display Shape

� Insert > Apple iOS UI > Bars > Status Bar > iPhone > light

Danach legst du einen Kreis (O) in 48 × 48 und einen Text (T) am oberen Ende des Art-

boards an. Richte sie an den anderen Ebenen aus, und achte darauf, dass du so viel wie

möglich wiederverwendest: Abstände, Größe und Positionierungen aus Elementen von

unten sollten sich hier wiederholen.

Abbildung 8.14  Symbole hinzufügen
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Verknüpfe diese beiden Ebenen noch mit Datenquellen. Markiere dafür den Kreis, und kli-

cke auf Layer > Data > Sketch Data > Faces. Beim Text wählst du Layer > Data > Sketch Data

> Names.

Mit diesem Schritt ist das Design für einen Chat vorerst abgeschlossen. Vielleicht hast du 
schon Ideen, wie du den Entwurf weiter verändern und anpassen möchtest.

Abbildung 8.15  Einpassen 
der Symbole

Abbildung 8.16  Der Empfänger wurde eingefügt.
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