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Chapter

The Unity Editor

The most exciting part of learning a new application is getting it installed and firing it up for the
first time. Following that, the most frustrating part can be the process of becoming familiar with its
editing environment. Unity is no exception, especially if you are already familiar with DCC (digital
content creation) applications. In this chapter, you will be introduced to the Unity editor and many
of its key concepts. As this will serve as a light overview for the rest of the book, don’t stress over
trying to remember it all.

Installing Unity

The first order of business is to download and install Unity if you have not already done so.

Unity has two license types: free and Pro. When you download and install Unity for the first time,
you will have the option of using a free 30-day trial of the Pro version. It can be selected as a third
option right in the license dialog upon installing Unity or upon returning the currently active license
(an option that allows you to move Pro licenses to different machines). With a few exceptions,
most of the Pro features are aimed at the optimization of your projects and are beyond the scope
of this book. If you are considering the purchase of Unity Pro, you should be aware that, with

the exception of Windows Mobile, it will require a separate license for each of the mobile target
platforms you wish to author for.

Unity User Account

Currently, after you download and install Unity, if you don’t already have one, you will be required

to create a Unity user account during the installation. Your user account will provide access to the
downloads, Unity Forum, Unity Answers, and the Unity Asset Store. The forum provides a place for
discussion of all things Unity. Answers is where you can go to get quick solutions to your queries,
and the Unity Asset Store is where you can find assets of all kinds (3D models, animated characters,
textures, scripts, complete game environments, etc.) to help you with your project. Once Unity is
installed, you will find a direct link to each of these resources through the editor.
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To get started, go to www.unity3d.com/unity/download.

With the account created, you can download Unity for Windows or Mac. The download site will
automatically offer the version that matches the platform you are currently on.

Installing

This book was written using Unity 4.5. Because Unity regularly makes changes that can affect your
projects, you may wish to use the 4.5 version even if the current version is newer. If you prefer,

you can install multiple versions of Unity on the same machine, providing you name the folders
accordingly (e.g., Unity 4.5, Unity 4.6). You may only run one instance of Unity at a time, regardless
of the version. If you choose to have multiple versions, you will be required to start Unity from the
desired version rather than from the desktop icon or the project itself, as the previously run version
will open by default.

If that sounds like too much trouble, you can always check the book’s thread on the Unity Teaching
forum, http://forum.unity3d.com/forums/23-Teaching, where both errata and version-change
solutions will be posted and updated as necessary. A search for the book’s title will help you find
its thread.

1. Install Unity, following the prompts, including the sample project.

On a Windows machine, it will be installed in the Program Files x86 folder. Upon the release of Unity 5.0,
when it will be fully 64 bit, it should install itself in the regular Program Files folder. The sample project
will be installed in Documents » Public Documents » Unity Projects. On a Mac, you will find it in
/Users/Shared/Unity.

At this point, you should now see the Unity icon on your desktop (Figure 1-1).

Figure 1-1. The Unity application icon on the desktop

2. Click the icon to open Unity.

If you downloaded the sample project, Unity will open with it already loaded (Figure 1-2).
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Figure 1-2. The Unity sample project loaded

If the Scene window is blank, you can double-click the Unity icon in the Assets folder to load the
AngryBots scene. The demo scene Unity ships with changes occasionally, so yours may be different.

Tip  When opening Unity from the desktop icon, it will open the previously opened project, provided it
can be found.

If you did not choose to install the sample project, you will see the Project Wizard (Figure 1-3).



4 CHAPTER 1: The Unity Editor

—

Unity - Project Wizard (43.301) B
Open Froject| Create New Froject

Project Location:

C:\Users\Sue\DocumentsiNew Unity Project 1 Browse...

Import the following

|_| Character Controller.unityPackage A
[ ] class Refraction (Pro Only).unityPackage

[] 1mage Effects (Fra Only).unityPackage

C Light Cookies.unityPackage

Light Flares.unityPackage

|| Particles.unityPackage

|_| Physic Materials.unityPackage

|| Proiectors.unitvPackace
< >

Setup defaults for: 3D b

Figure 1-3. The Unity Project Wizard

From the Project Wizard, you can create a new project or browse to open an existing project. Initially,
exploring the editor with a finished project will make more sense. You can obtain the sample project
from the Unity Asset Store directly from a new project.

1. In the Project Wizard, select the Create New Project tab.

2. Set the Project Location manually using the Browse button, or accept the
default name and location.

Tip When you create a new project, you will be creating a folder to house the project. The folder /s the
project. You can only create a new project in an empty folder.

3. With the project name and location specified, click the Create button.
The new project and, as yet nameless, scene opens in the Unity editor.

Originally, if you pressed the Alt key down immediately after clicking the Unity icon on the desktop,

it would force the program to start with the Project Wizard. Because that required excellent timing and/or
a good dose of luck, Unity finally added the option to the Preferences section. While it may seem like
a nice time-saver to automatically open your last file, it has its drawbacks. If the project has become
corrupted, Unity will not be able to open it (giving you access to the file menu where you can open

a different file). If you are using multiple versions of Unity, it will recompile data if the last project was
opened in a different version. Depending on the version, the changes made could be permanent. To
avoid complications, the best practice is to set the preference to always start with the Project Wizard.

4. From the Edit menu, select Preferences.

5. Under General, turn on Always Show Project Wizard (Figure 1-4).
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Figure 1-4. Preferences set to Always Show Project Wizard

General Layout

With the project loaded, you should see Unity sporting its default layout. If you are using the free
version, the Ul should appear in light gray (Figure 1-5). If you have purchased, or are evaluating,
Unity Pro, the background will reflect the dark theme (Figure 1-6). For this book, the screenshots
will utilize the light theme for better contrast. If you have Pro and prefer the lighter version, you can
change the Skin in the General section of the Preferences.
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Figure 1-5. The Unity UI, light theme
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Figure 1-6. The Unity Ul dark theme

Unity’s Ul consists of four main “views” and several important features. The Scene view, Game view,
Hierarchy view, and Inspector view (typically referred to as the Inspector) are generally accessible in
any of the layout options, as are the playback controls, coordinate system options, and object/viewport
navigation buttons (Figure 1-7). If the term “views” seems a bit odd, it helps to know that depending
on which view is active, your input (or the events it triggers) will generate different results. The first
click in a different view will set the focus to it.
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Figure 1-7. The Unity GUI and its main features

With the default layout, the main feature is the Scene view. This is where you will be able to arrange
your 3D assets for each scene or level in your project.

In the tab next to the Scene view, you will find the Game view. In the default layout, when you click
the Play button, the Game tab is automatically opened. The game view is where you will interact with
your scene at runtime to test your game play.

To the left of the Scene/Game viewports, you will find the Hierarchy view. This is where you will find
the objects that are currently in the loaded scene or level.

Below the Scene/Game view is the Project view. This contains the resources or assets available to
the current project. This folder corresponds directly to the project’s Assets folder on your operating
system. Deleting files from the Project view will send them to the trash on your computer. If you
author from an external hard drive, you should be able to locate the deleted files in the drive’s own
trash folder. The main point here is that there is no “undo” for these deleted files.

To the far right, you will find the Inspector. This is where you will have access to the parameters,
options, and other particulars of selected assets, from the Hierarchy or Project views, as well as
general project-related settings.

At the top left, you will find the navigation controls that will allow you to move and arrange objects in
your scene and re-orient the Scene view itself for easier access to the various objects.
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To the right of the navigation tool controls are the coordinate system options. Here you can specify
Global or Local coordinates as well as using the object’s designated Pivot Point or the Center of its
bounding box as the rotation point.

In the top center, you will find the Playback buttons. The Play arrow will put you in Play mode, where
you can test your game’s functionality and presentation in a Windows or Mac environment. The
Background color of the Ul will also change, alerting you to the fact that you are in Play mode. The
Play button becomes a Stop button once you are in Play mode. You also have the option to Pause
the game, using the middle button, or to step through one frame at a time, using the right button.

At the top right, you will see two drop-down menus. The Layers button will allow you to set various
Layers to be active or inactive during Play mode, or define new layers. The Layout drop-down menu
provides a quick way to switch between several popular layout configurations.

Menus

The menu bar consists of seven menus, a few of which may already be familiar to you from other
applications.

The File menu (Figure 1-8) is where you will save and load both scenes and projects. It is also where
you will build, or compile, your game before sharing it with others.

File | Edit Assets GameObject Com

New Scene Ctrl+N
Open Scene Ctri+0
Save Scene Ctrl+S
Save Scene as.. Ctrl+Shift+S

New Project..
Open Project...
Save Project

Build Settings... Ctrl+Shift+B
Build & Run Ctrl+B
Exit

Figure 1-8. The File menu

In the Edit menu (Figure 1-9), you will find the usual editing options: Undo, Redo, Cut, Copy, Paste,
Duplicate, and Delete. The next couple of sections deal with functionality generally accessed
through keyboard shortcuts or Ul buttons, but that are useful for identifying the shortcuts. The Play
options are fairly self-explanatory. You will investigate Find later in the chapter. The Edit menu is also
where you can find access to Project and Render settings. These are settings that are not associated
with any particular scene object. Preferences is where you can go to customize the Unity editor for
matters other than layout. At the bottom, you can gain access to the snap options to help with the
arrangement of your scene assets.
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Preferences...
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Selection ¥
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Graphics Emulation v
Snap Settings...

Figure 1-9. The Edit menu

In the Assets menu (Figure 1-10), you will see the various options for creating, importing, and
exporting assets. This extremely useful menu can also be accessed in a couple of different places
in the editor, as you will see throughout the book. Topping the list is the Create submenu. This is
where you will create most of your Unity-specific assets, such as scripts, materials, and a variety
of other useful things. Along with the menus for importing assets such as textures and 3D models,
you will find a mainstay of Unity game development: the means of importing and exporting Unity
“packages.” Packages are the vehicle for transferring all things Unity with their relationships and
functionality intact.
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Assets | GameObject Component Window
; Create »
Show in Explorer
Open
Delete
Import New Asset...
Import Package L4
Export Package...
Find References In Scene
Select Dependencies
Refresh Ctri+R

Reimport
Reimport All

Sync MonoDevelop Project

Figure 1-10. The Assets menu

In the GameObiject menu (Figure 1-11), you will be able to create several types of pre-set objects,
from the most basic of Unity objects, an “Empty GameObject,” to primitives, lights, cameras, and a
nice variety of 2D and 3D objects. Also of note in this menu are the bottom three commands. They are
the means for positioning objects relative to one another, including Cameras and their views. In Unity,
anything that is put in your scene or level is called a gameObject (lower case g). More than just Unity's
name for an object, gameObject specifically refers to an object that inherits from the GameObject
class (upper case G), that is the code that defines the top level object and its basic behavior.

' GameObject | Component Window Help
Create Empty Ctrl+Shift+N
Create Other ’

Center On Children

Break Prefab Instance

Move To View Ctrl+Alt+F

Ctrl+5Shift+F

Alicon A+ A/
Algn vvitn v

Align View to

Figure 1-11. The GameObject menu

The Component menu (Figure 1-12), is where you can add components to define or refine your
gameObiject’s functionality. Any of the “Create Other” objects from the GameObject menu could be
built from scratch by adding the appropriate components to an empty gameObiject.
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Figure 1-12. The Component menu

Component | Window Help

—_—
L}

| Add..
! Mesh

| Effects

Physics
Physics 2D
Navigation
Audio
Rendering
Miscellaneous

Ctrl+Shift+A

1

The Window menu (Figure 1-13) is where you can go to open or change focus to Unity’s standard
and specialty views or editors. The shortcut keys are listed if they exist. Note the Asset Store item.

This will take you directly through Unity’s Asset Store, where you can import assets directly into

your game.

Figure 1-13. The Window menu

Window | Help

Next Window
Previous Window

Layouts

Scene

Game
Inspector
Hierarchy
Project
Animation
Profiler
Asset Store
Version Control
Animator
Sprite Packer

Lightmapping
Occlusion Culling
Navigation

Console

Ctrl+Tab
Ctrl+Shift+Tab

Ctri+1
Ctri+2
Ctrl+3
Ctri+4
Ctrl+5
Ctri+6
Ctrl+7
Ctrl+9
Ctri+0

Ctrl+Shift+C
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The Help menu (Figure 1-14), as expected, will provide you with the version number and license
information of your Unity installation. In this menu, you can find access to the three main pieces
of Unity documentation: the Unity manual, where you can find information on the workings and
concepts behind much of the Unity workflow and features; the Reference Manual, where you
can get specific information on Unity components; and the Scripting Manual, where you can find
Unity-specific API classes, examples, and scripting tips. Additionally, the menu supplies links to
the Unity Forum and Answers (when you just need a quick solution) and a means of reporting

a bug should the need arise.

elp]
About Unity...

Manage License...

Unity Manual
Reference Manual
Scripting Reference

Unity Forum

Unity Answers
Unity Feedback
Welcome Screen
Check for Updates

Release Notes

Report a Bug

Figure 1-14. The Help menu

Getting Started

Each of Unity’s “views” comes with its own options and settings. Most are along the top of the
viewport or panel, but there are a few that are located at the bottom. Once again, this is just a quick
overview to familiarize you with some of their key features.

If you didn’t choose to download and install the sample scene, AngryBots, with your Unity install,
you will need to fetch it from the Unity Asset Store if you wish to follow along with the next
section’s exercises. It is a free download and can be found in the Complete Projects category, Unity
Technologies section.

1. From the Windows menu, select Asset Store.
Select the Complete Projects category.
Select the Tutorials subsection.

Select Angry Bots.

Click the Download button’s drop-down arrow (on its right side).

@ g M w0 D

Select Download Only.
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7. Close the Asset Store window when the project has finished downloading.

8. In the Unity editor, from the files menu, select Open Project.

The Project Wizard opens (Figure 1-15).

Open Project | Create Mew Project.

Select recently opened project:

C:\Users\Sue\Documents\New Unity Project 1 A |

C:\Users\Public\Documents\Unity Projects\4-0_AngryBots

Figure 1-15. The Project Wizard

9. Select Open Other...

10. Navigate to where the project was installed, and select the parent folder,
4-0_AngryBots.

When Unity opens a project that you were previously working on, it will open to the scene you were
editing or viewing. If this is the first time the project has been opened, it will open to a new, unnamed
scene. Since all new scenes are created with a default camera, it won’t be entirely empty, but it also
won’t do you much good as you check out the various views.

One of the first things you will learn to do in Unity is to keep your projects organized. While it’s not
mandatory to do so, you will find that most developers create a folder called Scenes to store the
game’s scenes or levels in. You will find that AngryBots does indeed have a Scenes folder, but the
main scene was left on its own in the root folder. Unity helps you to locate various types of resources
through the use of various icons. The icon used for scenes is, appropriately, the Unity production.

1. In the Project view, select the Assets folder in the left column and locate the
AngryBots scene in the right column (Figure 1-16).
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Figure 1-16. The AngryBots scene in the Project view

2. Double-click on the AngryBots scene name and/or icon to load the scene.

The contents of the scene are shown in the Hierarchy view. The Scene view reflects the last
observation point from the last scene seen in the Unity editor, regardless of what project it was in.

Navigating the Scene View

The first thing you will probably want to do is explore the loaded scene in the Scene view. Because
viewport navigation varies quite a bit in 3D applications, this is a good place to start your Unity
experience. Let’s start by focusing in on an object in the Hierarchy view.

1. In the Hierarchy view, double-click on the Main Camera to focus the Scene
view to it.

Tip At the time of this writing, the double-click method to focus or find an object in the Scene view may no
longer work on all platforms. An alternate means of zooming in on the selected object is to move the cursor
into the viewport and press the F key. Both methods will “Frame” the selected object in the viewport.
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Your exact view may vary, but from any particular location, it will be looking toward the Main Camera
object (Figure 1-17). You will learn how to adjust the icon size and type in the Scene a little bit later.
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¥ Enemies
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¥ Environment{sounds)

> Environment(static)

| Main Camera

F Misc

# MoodBoxes

* Player

Figure 1-17. The Main Camera “found” in the Scene view

When a camera object is selected, you will also get an inset showing what it sees.

2. To orbit around the Scene view’s current focus, Main Camera, hold the
Alt key down on the keyboard, press the left mouse button, and move the
mouse around.

The scene view is orbited around the current center.

3. Release the Alt key, press the middle mouse button or roller, and move the
mouse.

The view is panned (moved up/down/left/right).

4. Holding the Alt key down once again, press the right mouse button and move
the mouse.

This time, you are zooming the scene in and out. You can also zoom by rolling the middle mouse roller.

5. Release the Alt key, and continue to hold the right mouse button down as
you move the mouse.

With no Alt key, the view is rotated from the viewpoint’s origin.
You can also perform fly-through navigation through the scene.

6. Hold the W key down on the keyboard and then press the right mouse
button. Move the mouse to perform direction changes.

The speed increases the longer the mouse button is held down, so you may want to try a few starts
and stops. Try experiments with the A, S, and D keys along with the right mouse button.
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Understanding the Scene Gizmo

In the Scene view, you have several options for working in the viewport as you create and refine your
scene. The two main options are to view the scene in perspective mode or an isometric mode.

1. Double-click the Main Camera once again in the Hierarchy view to get back to
some scene objects.

2. Using the right mouse button (or any of the alternative methods), rotate the
view and observe the Scene Gizmo (Figure 1-18).

# Scene
Taxtured

Figure 1-18. The Scene Gizmo in the upper right corner of the Scene view

The Scene Gizmo indicates the cardinal direction of the global or world directions. Currently you are
seeing the view in a perspective view, Persp, but you can use the Scene Gizmo to change to an iso
view, Iso. An 'iso' or isometric view is a view often used in drafting to create a 3D view without the
vanishing point perspective of the human eye. Unlike perspective, where objects farther back in the
scene appear smaller, in Iso, their size relative to each other is always correct. When coupled with
the cardinal directions (front, back top, bottom, left and right), Iso will show a flat orthographic view
that can make positioning objects much more accurate. When rotated off of the side or top/bottom
views, the view becomes isometric. You can toggle the lable to return to a perspective view.

3. Select the Y or top view arrow on the gizmo.

The scene is seen from the top (Figure 1-19), but it’s still the perspective view, as indicated by the
wedge-shaped icon next to the Top label, just below the gizmo.
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Figure 1-19. The perspective Top view

4. Click on the Top label.

Now the view is a flat orthographic view, as indicated by the three parallel bars of the new label
icon (Figure 1-20).

# scene ] € Game s
| Textured :| | RGB :|| 2D | & | <) | Effects +| | Gizmos | (G All )

Figure 1-20. The ortho Top view

5. Try clicking the other Scene Gizmo arrows to see the other views.

These views will allow you to position objects with respect to each other with far more accuracy than
a perspective view.

6. Use the right mouse button or its equivalent to rotate away from the current view.
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This time the view becomes an isometric view (Figure 1-21). If you have an engineering background,
you will recognize this as a typical means of depicting objects in 3D without having to calculate
true (human-type) perspective. It is also used in many world-building games, such as Blizzard’s
Warcraft 3 or StarCraft.

| Textured

o ¥ hin 'G"! =Bll['-- ".

Figure 1-21. The Iso, or isometric view

7. Return to a perspective view by clicking the iso label.

The viewport and label are returned to a perspective view (Figure 1-22).

# Scene
| Texzured sl :|| 20| ¢ | <) | Effects i~ | | Gizmos ~

Figure 1-22. The Scene
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Exploring the Views

Now that you are becoming more adept at manipulating the viewport, you can check out several of
the tools and features available to you with each of the main views.

Hierarchy View

The Hierarchy view is essentially a list tree of the objects currently in the loaded or active scene.
The key word here is “currently” because during run-time, objects can be “instantiated” (created
on the fly) or destroyed (deleted from the scene). This is an important concept in Unity, and

it is one of the reasons that most changes made during run-time are not permanent. On exiting
Play mode, the Hierarchy view will be returned to its former state.

During your experimenting with the viewport, you may have accidentally clicked on an object in the
Scene view. When selected that way, the hierarchy in the Hierarchy view will be expanded to show
the picked object. As you may have noticed, some of the objects are children of children of the
top-level objects in the scene. With this in mind, you can imagine how difficult it can be to locate
particular objects in either the Scene or Hierarchy view. As the book’s project comes together, you
will be importing and using several prefabs (Unity’s term for reference objects) and will want a quick
means of locating them in the current scene.

Fortunately, Unity has a nice search function for that very purpose. At the top of the Hierarchy view, to
the right of the Create drop-down arrow, you will see a small magnifying glass icon and its drop-down
arrow. The drop-down menu will let you filter for All, Name, or Type. Let’s start with Type (Figure 1-23).

= Hierarc | =
Create ~ | ‘ar|
[ Enernies ; q'] All
» Environn-—
¥ Environn Name
¥ Envirenn
¥ Environn Type
¥ Main Camera
» Misc
» MoodBoxes
P Player

Figure 1-23. The Search feature’s filters

1. Press the drop-down arrow next to the search icon, and select Type.
2. In the text file to the right, type camera.

Before you can finish typing, Unity lists the cameras in the scene. In this case, there is only one, Main
Camera. If you select it in the Hierarchy view, it is also selected in the Scene view, along with its view
in the Camera Preview window. Note how everything else in the scene has been grayed out.

3. Return to a normal Scene view by clicking the x to the right of the word you
typed in.
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The Scene view is returned to normal, but the selected object remains highlighted in the Hierarchy view.

4. Next, change the filter back to All and type confused.

5. Select the only object that comes up, ConfusedEnemyMech.
6. Double-click to see the view focus in on it.

7. Click the x to return the view to normal.

8. This time, type in something more generic, pipe.

Because there are several objects in the scene with the word pipe in their name, the list of possible
objects is quite long. In the Scene view, they are all “un-grayed,” helping you to find the one you
want fairly quickly (Figure 1-24).

%= Hierarchy

|

Figure 1-24. The options for a scene object with “pipe” in its name

9. Click the x to return the Scene view to normal.

Scene View

The Angry Bots scene provides you with plenty of variety to explore the Scene view’s tools and
features. Because there are lots of options, you will just take a look at some of the more commonly
used features.

1. Deselect any objects you’ve got selected by clicking in a blank area of either
the Hierarchy or Scene view.

2. Zoom back far enough to see about half of the scene.

3. On the far left, just under the Scene tab, click on Textured to see the other
viewport display options (Figure 1-25).
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Figure 1-25. The viewport display options

Of the five, the first three should be easy to understand, especially if you have had any background
in 3D modeling or have ever watched a “making of” video of any of the pioneers of the CG movie
industry’s 3D animated films.

4. Try selecting Wireframe and then Textured Wire.

You may have noticed that meshes automatically show as textured wire when selected. The
difference here is that the wire is black, not light blue, allowing you to continue to locate the selected
item in the Scene view. In Wireframe, you can see how 3D objects came to be called “meshes,”

as they resemble wire meshes.

The next option to the right shows RGB (Figure 1-26). This set of display options has to do mostly
with texture maps. RGB, the default, shows the red, green, blue part of an RGBA texture.

H:Scene
Textured

| < | Eﬁlct:'IiGizmas ¥

Overdraw
Mipmaps

Figure 1-26. The scene view options

5. Select the Alpha option.

If you are familiar with the alpha channel of a 32-bit texture or image, you may be thinking that Alpha
is about transparency, with 0 as fully transparent and 255 as fully opaque. In Unity, however, the
alpha channel can do duty as anything from a glossiness channel to self-illumination to height maps.
Each of Unity’s shaders is designed to make use of alpha channels of its textures to maximize effect
and minimize texture usage. With the Alpha option selected for the viewport texture display, you will
be able to see the alpha channel but not what it has been used for (Figure 1-27).
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Figure 1-27. Textures displaying alpha channels

6. Select the Overdraw option.

Overdraw, the third option, shows how many objects must be drawn on top of each other from
the current vantage point. The denser or brighter the display (Figure 1-28), the more objects there
are that must at least be sorted, if not actually drawn. In mobile games, regardless of device and
operating system, this type of sorting is very costly and should be kept to a minimum.

# Scene
Textured

Figure 1-28. Possible overdraw problem areas showing as bright areas in the Scene view

7. Select the Mipmaps option.
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The final option shows the MIP map distance, with no color being the full original-sized texture.

As the tint goes from blue to clear to gold through to red, the smaller, blurrier maps are substituted,
preventing the sparkly artifacting effect seen as the camera pulls back away from the object. Blue
uses a blurred version of the map when the camera is close enough to see pixilation in the texture.
You will learn more about MIP mapping when you work with imported images later on.

1.  Zoom in close enough to the compound floor by using the mouse roller or by

holding the Alt key, pressing the right mouse button, and moving the mouse
to see the floor tinted blue at close range.

Zoom out slowly, and watch as the tint goes to no tint then to red (Figure 1-29).
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Figure 1-29. Color tinting indicating which version of MIP map is shown according to the distance

An absence of tint is the native image. Blue is a blurry version of it you can use so that you won’t
see each and every pixel up close. Red is a blurred version of it you can use so that you won’t see

the sparkly artifacting common to low-resolution videos. To see the MIP maps generated from the
imported textures, you can select a texture and view it in the Inspector.

3. Inthe Project view, select the Textures folder from the Assets folder.
4. Locate and select the AngryBots texture in the second column.

5. At the bottom of the Inspector, in the Preview window, move the slider from
the far right, slowly over to the far left.

The images are shown in increasingly blurry versions. They appear pixilated as Unity zooms in closer
and closer and the versions are smaller and smaller.

6. Set the Scene view drop-down menu back to its default RGB.
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The next option for the Scene view is the 2D toggle. If you are creating a 2D game, it makes sense to
develop in the kind of view that matches the final output. A little experimentation shows that the 2D
option is a preset to the Back view, with the iso option turned on (Figure 1-30). The view points in the
positive Z direction. The Scene gizmo is hidden to prevent accidental viewport manipulation. Only
Pan and Zoom are available.

Figure 1-30. The 2D toggle compared with the Back/iso view

The next toggle in the Scene view turns scene lighting off and on. When the scene lights are off, the
scene is lit from the user’s viewpoint, straight into the scene, insuring the visible objects will be well
lit. In the Angry Bots scene, the lighting has already been “baked” into most of the textures—that is,
the textures themselves have been altered to appear as they are with the lighting on them. To see the
lights being toggled off and on in this scene, you will need to locate one of the objects that receives
dynamic lighting.

1. In the Hierarchy view, search for mine_bot.

2. Select one of the listed mine_bots, and double-click it to zoom in on it in the
Scene view.

3. Toggle the Scene Light button off and on to see the effect on the bot
(Figure 1-31).
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Figure 1-31. The Scene Lights toggle: lights on (left) and lights off (right)

Now that you’ve seen that the bots and not the building receive lighting, you can test the Render
Paths option in the first display drop-down menu.

4, Change the first Display option from Textured to Render Paths.
5. Zoom out until you can identify the various red tinted objects.

A closer inspection will show that they are all of the objects that are also receiving dynamic light
during run-time.

The next button to the right is the Play Sound Effects toggle (Figure 1-32). It toggles audio on or off.

Figure 1-32. The Sound Effects toggle

1. Toggle the Audio button on.
2. Search for and select polySurface5073 in the Hierarchy view.
3. Double-click on it to focus the Scene view to it.

The sound you hear is a 3D sound, and it can be heard only when you are close enough to the
object. It is also set to be a looping sound.

The Effects drop-down menu to its right allows you to select which effects will be shown in the
Scene view (Figure 1-33). The Angry Bots scene uses a Skybox for the environment and some
animated materials on some of the outside decks. You can toggle them all off or on by clicking the
Effects button, or you can selectively choose which you want to see from the drop-down menu.

Gizmos ~

Animated Material

Figure 1-33. The Effects drop-down menu
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4, With polySurface5073 selected, orbit the view until you have a good view of
the sky and deck, and can hear the rain sound effect (Figure 1-34).

| # Scene

:|| 2D | % | <) | Effects i~ | | Gizmos =| (CrA

Figure 1-34. A good view of the sky and outside deck

5. Toggle the Sky box on and off.

The hazy sky disappears and reappears. The skybox is a cubic map (a six-image collection) that is
added to the scene through the use of shaders. It has no actual “box” geometry, so you never have
to worry about the player getting too close to it.

6. Next, toggle on Animated Materials.

7. Look closely at the deck in the Scene view, and then check out its material in
the Inspector (Figure 1-35).

# Scene .
Textured i| 2D | %% | 9) | Effects i~ | | Gizmos ~ |
¥ Skybox
Fog
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v Animated Material

TN N\

i\
| \ 3

Figure 1-35. A close look at an animated material
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This distortion/reflection effect is achieved through the floor material’s shader. Many of the sample
projects contain code and shaders that you can commandeer for your own projects, so they are well
worth investigating, even if their functionality is past your current level of knowledge.

8. Turn off the Animated Material effect in the drop-down menu.

The next button is the Gizmos button/drop-down menu (Figure 1-36). This is where you can control
which specialty icons will show in the Scene view and how they will be presented. Several types of
gameObijects have standard gizmos already assigned and active in the scene. The most obvious
are lights and audio, and—if you remember the new, almost empty scene when you opened the
project—the camera. The gizmos help you to locate objects in the Scene view that have no mesh
associated with them. The light icons, by the way, show the tint set for the specific lights they represent.

| # scene ) C@mm
| | Textured ¢|  RGB

brns e mah fo=

Figure 1-36. Gizmos drop-down menu

1. Navigate the Scene view until you can see a nice selection of gizmos
(Figure 1-37).

Figure 1-37. A good view of some specialty icons in the scene

This view displays several spotlight icons showing the placement of lights in the wall’s can light
fixtures, a point light, the lightbulb icon, and a couple of audio icons associated with each of the two
mine bots guarding the area.

2. Open the Gizmos list, and try adjusting the 3D Gizmos slider.
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As the gizmos get larger, they start to fade out before they cover too much of the scene. As a
default, they are set as 3D gizmos. They are obviously 2D icons, but they are adjusted in size
depending on how close you are to them, giving you a better feel for where the actual gameObject
is in 3D space. They are also occluded by mesh objects, as can be seen with the golden can lights
on some of the walls. If you find the dynamic sizing distracting while working mostly in an overhead
view, you may prefer to switch them to 2D.

3. Uncheck 3D Gizmos.

All of the gizmos within view are shown at a standard size. While this is obviously not practical for a
first-person vantage point, it is useful for overhead editing. 2D icons are not affected by distance.

4. Switch the view to a top/iso view so you are looking down on the compound.

As you may remember, most of the lighting was baked into the textures, so most of the light gizmos
you see are no longer in use. Fortunately, you can opt to turn icons off and on by type.

5. Open the Gizmos list again, and click the Light icon from the icon column.
All of the light gizmos are turned off in the Scene view.
6. Now turn off the Audio Source icons.

An overhead search of the compound should now find the lone camera icon, but you will also see
several blue box outlines. Because the gizmos are associated with the components that dictate the
object’s features and functionality, you can also assign icons to custom scripts, because scripts are
also components. In Angry Bots, several of the scripts have gizmos assigned to them.

7. Open the Gizmos list again, and try unchecking the Rainbox gizmo check
box on the far right of the script name in the Scripts section.

The blue rectangle gizmos disappear from the scene.

In Unity, you have the option of assigning custom icons as well as generic gizmos to specialty scripts.
While it is beyond the scope of this book to cover that functionality, it should at least take the mystery
out of some of the gizmos you come across in other people’s scenes.

The last item on the Scene view bar is the now familiar search feature. While it may seem redundant
to have the search featureon both views, Unity allows you to fully customize which views are turned
on and where they are placed, so you could possibly find it very convenient if you are using two
monitors and have the Hierarchy view far removed from the Scene view.

Game View
Having dealt with the most complicated view, you can now take a look at the Game view.
1. Click the Game tab to the right of the Scene tab.

For the most part, the Game view is about the runtime functionality of your scene, and its tools and
options reflect that as well (Figure 1-38).
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Figure 1-38. The Game view options
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On the far left, the aspect drop-down menu allows you to specify an aspect ratio so you can make
sure you will be seeing what your player will see (Figure 1-39). You can also add custom, fixed sizes
by clicking the Add button (the plus sign) at the bottom (Figure 1-40).

Figure 1-39. The Free Aspect drop-down menu
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Figure 1-40. On the left, the Add icon, and on the right, the custom option popup for a fixed-size view

2. Click the Free Aspect drop-down menu.

3. Click the Add icon at the bottom of the Free Aspect list.

29
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The next option is “Maximize on Play” (Figure 1-41). When toggled on, this will hide all other views
and maximize the Game view on Play. If you have stipulated a fixed window size, Unity will do its
best to match it.

!Iis:una | € Game [ e .il

| Free Aspect = K: | Maximize on Plaxﬂtats , Gizmos

Figure 1-41. “Maximize on Play” toggle

1. Toggle the “Maximize on Play” option on.
2. Click Play.

The Game window is maximized, and the other views are toggled off.
3. Stop Play mode by clicking the Play button again.

The views return to their original layout.

Next to the “Maximize on Play” option is the Stats button. The Stats window will show you the
statistics for your game during run-time. The most familiar will be the frame rate at the upper right.
The various items in the list may be a bit more cryptic, but all affect frame rate in one way or the other.

1. Toggle on the Stats window, and click Play.

2. Observe the frame rate and other items as you take the character through the
compound (Figure 1-42).

Figure 1-42. The Stats window during run-time
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3. Stop Play mode, and turn off the Stats window.

The last item on the Game view bar is the Gizmos toggle. Like the Effects drop-down menu, this one
works as a toggle when clicked or can be set to selectively see the gizmos you prefer.

Project View

Next up is the Project view. You have already used it a few times, but it has some nice functionality
that you will want to be aware of. Before going any further, it is worth a reminder that the Assets
folder on your computer is the Assets folder you see in the Project view. The most important thing to
remember is that you can add to the folder through the Explorer (in Windows) or the Finder (on Mac),
but you should not remove or rearrange resources except from within Unity unless you also include
the object’s .meta file.

Besides the Create drop-down menu, which is another location from which you can access some
of the Assets menu’s functionality, one of the main features of the two-column Project view is the
Favorites options found above the Assets folder section (Figure 1-43). It allows you to see all assets
of the listed types.

83 Project 0 Cansole

Create g :

#” Favorites
LAl Materials
(L All Models
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&3 AngryBots
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Editor
¥ & Explosions
(& Fonts
&8 Gizmos

Figure 1-43. The Favorites options

1. Select each of the filters, and watch the results.

The materials are displayed on spheres as with most 3D applications. The models and prefabs are
shown with thumbnail images, and the scripts are shown as a simple list with their script type icon.

If you are an artist and have created most of your own models and textures, you will probably find it
quicker to locate them by name. Conversely, if you are working with assets created by someone else,
you may not know the names but will know the one you are looking for when you see it. To keep a
good workflow for either scenario, Unity has provided a slider at the bottom of the view that will size
the thumbnails up or down. More importantly, on the left end of the slider, it reverts to names with
type icons.

2. Select the All Models filter.

3. Inthe lower right of the view, adjust the slider from left to right to see the
changes in thumbnail size and presentation (Figure 1-44).
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Figure 1-44. Adjusting the thumbnail display for the models

4. Try selecting the folders from the Assets folder to see their presentation.

You’ve probably noticed the familiar Search field at the top of the Project view. With folders selected,
you can type in a name or use the small icons at the right of the field to filter by type or label. You
can also save the search if you find yourself repeatedly looking for the same item. When using the
filters, however, you get another option. You can search the Asset Store directly if you find you

need a particular asset. The store items are divided into Free or Paid assets, so you can search the
thumbnail previews for items of interest.

5. From Favorites, select All Models.
6. Click on the Asset Store option at the top of the second column.
7. Open the Free Assets section, and click on a model that looks interesting.

The information about the model is shown in the Inspector, and you have the option of importing
it directly to your scene or going out to the Asset Store for some serious shopping (Figure 1-45, left).
For the Paid Assets, you will see the price instead of the import option (Figure 1-45, right).
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Figure 1-45. Accessing the Asset Store assets directly from the Project view: a Free asset (left), and a Paid asset (right)

8. For fun, type in rabbit (or some other object of interest) in the search field.
The item or related items, if any can be found, appear in the project view.

The last bit of Project view functionality will allow you to switch from the default Two Columns Layout
to the original One Column Layout (Figure 1-46). These options can be located by right-clicking over
the Project tab. The One Column Layout can be more useful, depending on the overall layout of the
Ul or where in the development process your game happens to be. You will get a chance to give it a
try later in the book.
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Figure 1-46. Adjusting column layouts

The Inspector

The Inspector is the last of the main views or panels. As you may have noticed, its functionality and
options are directly related to the item that is selected elsewhere in the editor. As you become more
familiar with Unity, you will spend a lot of time in the Inspector. It is where you will gain access to
almost everything related to your game in Unity.

Layout

Now that you have spent a bit of time with the Unity views and panels, it’s time to see about
re-arranging them as your needs change. As you open various sample scenes, you will see many
different layout preferences. The current default layout shows the loaded scene and assets folder
off to nice advantage, so these are good choices for a first look. As you start developing your own
games, however, you may find it useful to try other preset layouts or even customize your own.

1. Locate the Layout drop-down menu at the upper right of the editor.

2. Open it, and check out some of the preset layout options (Figure 1-47).
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Figure 1-47. A few layout options
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3. Select the “2 by 3” option.

This layout is useful for changing and checking on objects during run-time, as you get to see both
views at the same time. Its tall vertical views or panels make it easier to access large numbers of
assets in the Hierarchy view without resorting to the Search feature. Its main drawback is that the
Project view’s Two Column Layout does not lend itself to a tall vertical column very well. This is when
the Single Column layout is useful.

4. Right-click over the Project tab, and select the Single Column Layout.

The Project view is now essentially the contents of the Assets folder, and the file structure has the
standard operating system hierarchy (Figure 1-48).
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Figure 1-48. The 2x3 Layout and Single Column Project view

Besides the preset layouts, you can also float and rearrange the views manually.
5. Click and drag the Hierarchy tab around the editor.

The view snaps into various locations, ready to be dropped. If you have multiple monitors, you can
even leave it floating outside the editor window. To get it back, you can choose one of the preset
layouts in the Layout drop-down menu.
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Project Structure

Because no job is done until the paperwork is finished, you ought to have a basic understanding of
how Unity projects are organized before you jump in and start creating a game. For the most part,
everything you create will reside in the Assets folder. It is up to you to keep things organized as you
develop your game. And as a gentle reminder, avoid re-arranging the contents of the project view

outside of the Unity editor.

File Structure

Let’s create another new project. This will give you a chance to see how Unity manages the folders
that you create or import into your project. The file structure in Unity’s Project view is drawn directly
from the Windows Explorer (or the Mac’s Finder). To be able to see the correlation, you will add some

common packages at the same time as you create the project.

1.
2.

From the File menu, select New Project.

Under Project Location, Browse to a location of your choice and create a
folder for your project.

Name the project/folder UnityTest, and choose Select Folder.
Under “Import the Following,” select:
CharacterController.unityPackage

Scripts.unityPackage

TerrainAsssets.unityPackage

Click the Create button.

At the dialog that asks if you want to save changes in the AngryBots scene,
select Don’t Save.

Unity re-opens, using the layout from the previous session. A new, untitled scene is loaded.

7.

Expand the Standard Assets in the Project view.

You will see folders for the three Unity packages you imported when the project was created
(Figure 1-49).
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Figure 1-49. The folders containing the imported assets in the Project view
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8. Now, go out to your browser (Windows) or finder (Mac), and locate the
project folder to see what was generated.

Beneath the folder you created for the project, you will find an Assets folder that contains the
contents of the three imported packages in a Standard Assets folder (Figure 1-50).

UnityTest
= Assets
Standard Assets
+ Character Controllers
1 Scripts
¥ Terrain Assets

+ Library

ProjectSettings

¥ Temp

Figure 1-50. The project, UnityTest, and its folders containing the imported assets in the Explorer

9. Expand the folders to assure yourself that they are the same folders as in the
Unity Project view.

Three other folders were generated besides the Assets folder: Library, where relationships between
assets are stored in the large number of Metadata subfolders; Project Settings, where game-related
data not contained in regular assets is stored; and Temp. You should not make any changes to these
folders. You may add assets directly to the Assets folder or subfolder, but you should not rearrange
the contents (and yes, that is the third time that has been mentioned!).

Project Management

As you are probably beginning to understand, Unity’s file structure is fairly rigid. This ensures that
assets will not go missing at crucial times.

Another important thing to know about Unity projects is that there is no quick way to back them up
unless you are using a version-control system such as SVN, GIT, Perforce, PlasticSCM, or Unity’s
own Asset Server. There is no option to “Save Project as...” To be able to copy a project, you must
first close it. You will find that as you refine scripts along the development process, earlier test
scenes may no longer work. Unity project files can get quite large, so it is well worth the time and
space to make occasional backup copies for emergencies, for referencing earlier functionality, or for
experimenting with alternative ideas in a nondestructive way. The finished projects for each chapter
of the book are included in the book’s asset file, which you can download from the Apress website,
Www.apress.com/9781430267799. They will provide you with a means of comparing your results with
a working copy at the end of each chapter. If you are already familiar with version control, you may
want to do a search for Unity metadata and how the .meta files can be managed.



38 CHAPTER 1: The Unity Editor
_

Load/Save

Also worth noting is the difference between saving a scene and saving a project. Changes made to the
Hierarchy view will always require the scene to be saved. Changes in the Project view, because

they are actually changes to the folders on the operating system, may not need to be saved. Assets
that are created directly in Unity, even though residing in the Assets folder will probably need to be
saved because of all of the path and relationship metadata they generate behind the scenes. Anything
scene or project related that does not involve assets directly requires a project save. The bottom line
is, paranoia runs deep; it is safest to get in the habit of saving both scene and project on a regular
basis. You won’t be reminded to do so very often in the book, but that doesn’t mean you shouldn’t

do so on your own!

Summary

In this chapter, you got a first look at Unity’s Ul. Besides getting a brief overview of the major areas,
you had a chance to investigate some of the functionality that will help you as the book’s project
progresses. The biggest takeaway was in scene management, where you learned that you could
add to the Assets folder from your operating system’s Finder or Explorer, but that you must not
re-arrange assets outside of the Unity editor once they have been added.

If you are feeling overwhelmed at the amount of new information to digest, don’t worry. Anything
that is critical to know and understand will be covered again later in the book. A few of the things
mentioned in this chapter are here just to give you an idea of what can be done as your knowledge
of Unity increases. Feel free to revisit this chapter at a later date.



