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M1. Conceitos Básicos. 
1. Instalação. 
 

 

 

 

 

 

1.1. Blender. 
O Blender é um programa open  source disponível para 
diversos sistemas operativos (Windows, Mac, Linux, etc.), 
que  permite  a  geração  de  modelos  tridimensionais  e 
posterior  texturização,  renderização  e  animação,  com 
uma  qualidade  similar  aos  produtos  comercias  (Maya, 
3ds  Max,  etc.).  Originalmente  criado  e  distribuído 
comercialmente pela empresa holandesa Not a Number 
Tecnologies,  é  actualmente  desenvolvido  pela  Blender 
Foundation. 

O Blender é já hoje em dia utilizado por profissionais das 
muitas  áreas  em  que  é  necessária  a  utilização  de 
modelos 3D: arquitectura, design  industrial, engenharia, 
animação,  produção  de  vídeo,  desenvolvimento  de 
jogos, etc., permitindo:  

• a geração de  imagens de qualidade  fotográfica 
(Figura 1.1 e 1.2);  

• animação:  veja  a  curta  metragem  "Elephants 
Dream" (Elephants Dream@ Youtube, Elephants 
Dream@Wiki),  
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• ou jogos 3D, incorporando o motor Bullet (Bullet 
Physics  Library,  Bullet@Wiki):  veja  o  jogo  de 
distribuição  livre  "  Yo  Fankie!",  (Yo 
Frankie!@Youtube),  permitindo  o  acesso  às 
mais  avançadas  técnicas  de  iluminação  em 
tempo  real,  (Bathroom  demo@Youtube),  por 
recuso à GLSL (GLSL@Wiki). 

Faça o download da última versão do Blender a partir da 
página  da  Blender  Foundation  e  instale‐o  no  seu 
computador. 

 

 

 

 

 

 

 

1.2. Python. 
Como  se  disse,  o  Blender  possui  um  motor  de  jogo 
integrado  que  permite  a  criação  de  aplicações 
interactivas  3D,  tais  como  jogos  e  passeios  virtuais. 
Embora não  indespensável nas aplicações mais  simples, 
sempre que for necessária uma interface sofisticada com 
o  utilizador,  ou  se  pretender  criar  jogos  com módulos 
lógicos  mais  complexos,  é  inevitável  a  utilização  de 
scripts em Python, possuindo o Blender, para esse efeito, 
um editor incorporado.  

O Python é uma linguagem de programação de alto nível, 
interpretada  (sendo  possível  a  compilação  para 
bytecode),  orientada  por  objectos  (sendo  no  entanto 
possível  uma  abordagem  imperativa),  criada  por Guido 
van Rossum em 1991, sendo actualmente um produto de 
distribuição  livre  de  desenvolvimento  comunitário  e 
aberto,  gerido  pela  organização  sem  fins  lucrativos 
Python  Software  Foundation.  Na  sua  criação  foi  dada 
ênfase à simplicidade e legibilidade do código, pelo que é 
de  muito  fácil  aprendizagem.  Simultaneamente,  a  sua 
biblioteca  padrão  e  os  módulos  e  frameworks 
desenvolvidos  por  terceiros  tornam‐na  uma  linguagem 
extremamente poderosa e eficiente, sendo hoje em dia a 
linguagem  preferida  de  uma  enorme  comunidade  de 
programadores (TIOBE Programming Community). 

Instale e corra o Blender. Numa das  janelas que surgem 
no ecrã, a consola, verifique qual a versão do Python que 
necessita  instalar.  Faça  o  download  dessa  versão  do 
Python a partir da Python Software Foundation e instale‐
o no seu computador. 
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Figura 1.1 

 

 

Figura 1.2   
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2. Janelas. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 
2.1. Janelas iniciais. 
Ao  abrir  o  Blender  estão  visíveis  diversas  Janelas, 
correspondentes  à  configuração  de  trabalho  Default, 
figura 1.5. 

Pode mudar o  tipo de  janela deslocando o  rato  até  ao 
símbolo  presente  à  esquerda  da  Barra  da  Janela  e 
seleccionando‐o, [MLB]. 

No menu que surge no ecrã, figura 1.3, pode seleccionar 
qualquer dos 16 possíveis tipos de janela.  

A configuração Default é uma de diversas configurações 
possíveis,  seleccionáveis  a  partir  do menu  existente  na 
Janela Info, figura 1.4 

   

   

Pode  também  comutar  entra  as  diversas  (7)  pré‐
configurações  de  janelas  pressionando  repetidamente 
[Ctrl]+[LA] ou [Ctrl]+[RA]. 

 

 

 

Figura 1.3 
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Na configuração Default, figura 1.5, estão presentes: 

• a Janela Info, no topo. Esta janela é constituída 
apenas por uma barra de menus. 

• a  Janela  3D  (3D  View),  ao  centro.  Na 
configuração padrão, à esquerda da janela está 
visível  uma  tabela  com  diversos  painéis  de 
botões  que,  como  veremos,  pode  ser 
escondida.  

• a Janela Tempo (Timeline), em baixo. 
• a Janela Esquemático (Outliner), à direita e em 

cima.  
• a  Janela Propriedades  (Properties), à direita e 

em baixo. 

 

 

 

Figura 1.4 

 

Figura 1.5  
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2.2. Redimensionamento. 
Qualquer das janelas é redimensionável: 

• desloque o rato até ao bordo da janela (até que 
o cursor do rato mude para dupla‐seta) 

• pressione e segure [MLB]  
• desloque o rato na direcção desejada. 

 

 

 

 

 

 

 

2.3. Partição. 
Podemos  criar  novas  janelas  subdividindo  o  espaço 
ocupado por uma delas. 

Leve o cursor do rato até ao canto superior esquerdo ou 
até  ao  canto  inferior  direito,  onde  se  encontram  duas 
pequenas zona triangulares tracejadas, figura 1.6.  

Depois do cursor se transformar num sinal + pressione e 
segure  [MLB]. Movendo  o  rato  para  a  direita,  para  a 
esquerda, para cima, ou para baixo, desloque a barra de 
separação  entre  janelas  e  posicione‐a  no  local  onde 
deseja fazer a divisão. A  janela subdivide‐se em duas do 
mesmo tipo. 

 

Figura 1.6 

 

 

2.4. Remoção. 
Para  remover  uma  das  janelas  leve  o  rato  até  à  zona 
triangular  superior  ou  inferior  da  janela  adjacente, 
conforme a mais próxima da janela a eliminar, pressione 
e  segure  [MLB], e  arraste o  rato para  cima da  janela a 
eliminar.  

Verá que a janela a eliminar fica num tom cinzento mais 
escuro  com uma  seta  representada em  tom mais  claro, 
figura 1.7. Libertando o botão do rato dar‐se‐á o colapso 
das duas janelas. 

 
 

Figura 1.7 
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2.5. Pré‐configurações. 
Como  se disse,  existem 7 pré‐configurações de  janelas, 
seleccionáveis  a  partir  do  menu  da  janela  Info,  ou 
pressionando [Ctrl]+[LA] / [Ctrl]+[RA]. 

Pode  gravar  uma  qualquer  configuração  de  janelas 
passando a ter uma nova opção no menu. 

Depois de definida a configuração desejada, pressione o 
botão  [+],  figura  1.8,  e  altere  o  nome  da  configuração 
conforme pretendido. Durante toda a sessão de trabalho 
a opção passará a estar disponível no menu. 

Para guardar a nova configuração de janelas para futuras 
sessões  de  trabalho  é  necessário  alterar  o  ficheiro 
default.blend. 

 

Para isso pressione [Ctrl]+[U] e confirme que quer salvar 
as  alterações  ao  ambiente  de  trabalho  que  tenha 
introduzido, figura 1.9. 

 

Figura 1.8 

 

Figura 1.9  

 

 

 

 

2.6. Barra de menus. 
Todas  as  janelas  têm uma barra de menus posicionada 
no seu topo inferior ou superior. 

Se  levar  o  rato  até  à  barra  de menus  de  qualquer  das 
janela  e  pressionar  [MRB]  verá  aparecer  o  menu  da 
figura 1.10.  

Aí  poderá  seleccionar  o  posicionamento  da  barra 
relativamente à janela. 

 

 

Figura 1.10 
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3. Modo Objecto.  
 

 

 

 

 

 

 

 

 

O  Modo  Objecto  é  um  dos  modos  básicos  de 
manipulação de objectos na janela 3D. 

Em modo objecto tem acesso ao objecto como um todo. 
É  por  isso  o  modo  conveniente  para  fazer 
transformações  globais  do  objecto,  como  seja  uma 
translação, um escalamento, etc. 

 

 

 

 

3.1. Barra da Janela 3D 
Na configuração padrão, a barra da  janela 3D apresenta 
as  opções  correspondentes  ao  modo  Objecto,  figura 
1.11. 

Faz‐se em seguida uma descrição breve do conjunto de 
menus  presentes  na  barra,  e  nas  secções  seguintes  a 
descrição de cada uma das opções presentes. 

 

 

 

Figura 1.11 

Como  pode  ver  nas  figuras    1.11    a    1.14  temos  os 
seguintes menus: 

• Menu  View,  onde  estão  disponíveis  as  opções 
de  configuração,  visualização  e  navegação  na 
janela 3D. 

• Menu  Select,  onde  estão  disponíveis  diversos 
tipos  de  selecção  dos  objectos  presentes  em 
cena. 

 

Figura 1.12 
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• Menu  Object,  onde  estão  disponíveis  diversas 
acções  de  manipulação/transformação  dos 
objectos presentes em cena. 

• Menu Mode, onde pode seleccionar o modo de 
trabalho da janela 3D. 

• Menu  Viewport  Shading  (Modos  de 
Sombreamento), onde pode  seleccionar o  tipo 
de representação gráfica dos objectos presentes 
na janela. 

• Menu  Pivot  Point,  onde  pode  seleccionar  o 
ponto  em  torno  do  qual  são  feitas  as 
manipulações dos objectos presentes na janela. 

• Menu de Transformadores, onde pode activar a 
representação gráfica de símbolos auxiliares de 
acções  de  transformação  sobre  os  objectos 
presentes na janela. 

• Menu  Layers,  onde  pode  seleccionar  qual,  ou 
quais, das 20 plataformas de trabalho é visível. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 1.13 

 

 

 

 

 

Figura 1.14 
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4. Menu View.   
   
 
No  menu  View  estão  disponíveis  as  opções  de 
configuração, visualização, e navegação na janela 3D: 

• Left, Right, Back, Front, Bottom, Top, Camera: 
representa  os  objectos  em  cena  segundo  a 
projecção nos planos coordenados e na vista de 
câmara. Ver Modos de Visualização Pricipais. • Toggle Full Screen: comuta qualquer das janelas 

(não  apenas  a  janela  3D)  entre  o  modo 
fullscreen e enquadrado. Ver Toggle Full Screen. 

• Toggle Quad View: Subdivide a  janela 3D em 4 
diferentes  modos  de  visualização  (Top,  Front, 
Right e Camera). Ver Toggle Quad View. 

• Duplicate  Area:  cria  uma  janela  independente 
na área de trabalho. Ver Duplicate Area.  

• View  All:  enquadra  na  janela  3D  todos  os 
objectos presentes em cena. Ver View All. 

• View  Selected:  enquadra  o  objecto 
seleccionado na janela 3D. Ver View Selected. 

• View  Global/Local:  faz  o  enquadramento  dos 
objectos  seleccionados  na  janela  3D. Ver View 
Global/Local. 

• Show  All  Layers:  torna  todos  os  layes  visíveis 
em simultâneo. Ver Show All Layers. 

• Zoom Border: enquadra na janela 3D uma zona 
seleccionável do viewport. Ver Zoom Border. 

• Clipping  Border:  elimina  a  representação  na 
janela 3D de todos os objectos fora de uma zona 
selecionável. Ver Clipping Border. 

• Align  View:  conjunto  de  acções  especiais  de 
alinhamento  com  os  objectos  em  cena.  Ver 
Align View. 

• Navigation:  comandos  de  navegação  3D  (que 
permitem  modificar  o  ponto  de  vista  do 
utilizador sobre os objectos presentes em cena). 
Ver Navegação 3D. 

• View  Perps/Ortho:  alterna  o  modo  de 
representação  entre  perspectiva  e  projecção 
ortográfica. Ver View Perps/Ortho. 

 

Figura 1.15 
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4.1. Full Screen. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[UA] 
[Ctrl]+[DA]     

Full Screen pode ser evocada a partir da barra da  janela 
3D, [View>Toggle Full Screen], figura 1.16. 

 

 

Em  qualquer  modo,  pressionando  [Ctrl]+[UA]  ou 
[Ctrl+DA] acciona a função Toggle Full Screen. 

Toggle  Full  Screen    permite‐lhe    comutar  qualquer  das 
janelas (não apenas a janela 3D) entre o modo fullscreen 
e enquadrado. 

 

Figura 1.16 

 

 

 

 

 

 

 

4.2. Duplicate Area. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

       

Duplicate  Area  pode  ser  evocada  a  partir  da  barra  da 
janela  3D,  [View>Duplicate  Area  into  New  Window], 
figura 1.17. 

A  função Duplicate Area  cria  uma  janela  independente 
na área de trabalho, sendo útil quando estão disponíveis 
diversos monitores.  

 

Figura 1.17 

 

 

4.3. Show All Layers. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

       

Show All  Layers pode  ser evocada  a partir da barra da 
janela 3D, [View>Show All Layers], figura 1.18. 

Show All Layers torna todos layes visíveis em simultâneo.   

Figura 1.18 
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4.4. Quad View. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[Alt]+[Q]     

Quad View pode ser evocada a partir da barra da janela 
3D, [View>Toggle Quad View], figura 1.19. 

     

Em  qualquer  modo,  pressionando  [Ctrl]+[Alt]+[Q], 
alterna  entre  o  modo  de  visualização  Quad  View  e  o 
modo de visualização simples  

Como se aperceberá mais tarde, esta é uma configuração 
do  ambiente  de  trabalho  especialmente  importante,  e 
consiste  na  subdivisão  da  janela  3D  em  4  diferentes 
modos de visualização do cenário 3D, figura 1.20. 

 

Figura 1.19 

 

 

 

 

 

 

 

 

 

Figura 1.20 
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4.5. View All. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Home]     

View All pode ser evocada a partir da barra da janela 3D, 
[View>View All], figura  1.21. 

 

Em qualquer modo, pode evocar View All pressionando 
[Home] .  

View  All  enquadra  na  janela  3D  todos  os  objectos 
presentes em cena. 

 

Figura 1.21 

 

 

 

 

4.6. View Selected. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Key.]     

View  Selected  pode  ser  evocada  a  partir  da  barra  da 
janela  3D,  via  [View>View  Selected]  ou  [View>Align 
View>View Selected], figura  1.22. 

 

Em  qualquer  modo,  pode  evocar  View  Selected 
pressionando [Key.] (com [Num Lock] activo.).  

View Selected enquadra o objecto seleccionado na janela 
3D. 

 

 

 

Figura 1.22 
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4.7. View Global/Local. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Key /]     

View Global/Local pode ser evocada a partir da barra da 
janela 3D, [View> View Global/Local], figura  1.23. 

 

Em  qualquer  modo,  pode  evocar  View  Global/Local 
pressionando  [Key  /].  Local/Global  View  alterna  entre 
visão global e visão local.  

A  visão  local  faz  o  enquadramento  dos  objectos 
seleccionados na  janela 3D,  fazendo desaparecer  todos 
os outros objectos. 

 

Figura 1.23 

 

 

 

 

 

4.8. Zoom Border. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Shift]+[B]     

Zoom  Border  pode  ser  evocada  a  partir  da  barra  da 
janela 3D, [View> Zoom Border], figura  1.24. 

 

Em  modo  edição,  pode  evocar  Zoom  Border 
pressionando [Shift]+[B]. 

Zoom Border enquadra na  janela 3D a zona do viewport 
contida dentro do rectângulo tracejado definido através 
do arrastamento do rato, figura 1.25. 

 

 

 

 

 

Figura 1.24 

 

Figura 1.25 
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4.9. Clipping Border. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[B]     

15 
 

Clipping Border  pode  ser  evocada  a  partir  da  barra  da 
janela 3D, [View> Clipping Border], figura  1.26. 

 

Em  qualquer  modo,  pode  evocar  Clipping  Border 
pressionando [Alt]+[B]. 

Clipping Border elimina a representação na janela 3D de 
todos os objectos que fiquem no exterior do rectângulo 
tracejado  definido  através  do  arrastamento  do  rato, 
figuras  1.27  e  1.28  (na  verdade,  no  exterior  de  uma 
pirâmide com vértice no ponto de observação e  secção 
no plano da janela 3D dada pelo contorno). 

Note que para restabelecer a representação de todos os 
objectos em cena tem de evocar novamente a função. 

Clipping Border é extremamente útil na manipulação de 
modelos com grande complexidade 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 1.26 

 

Figura 1.27 

 

Figura 1.28 
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4.10. View Persp/Ortho. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Key5]     

View Persp/Ortho pode ser evocada a partir da barra da 
janela 3D, [View> View Persp/Ortho], figura 1.29. 

 

Em qualquer modo, pressionando [Key5], activa a função 
View Perps/Ortho, comutando entre o modo perspectiva 
e projecção ortográfica 

Existem  2  Modos  de  Representação  dos  objectos  na 
janela 3D: 

• Perspectiva (Perspective). 
• Projecção Ortográfica (Orthographic). 

Na  representação  em  perspectiva  os  objectos  mais 
distantes  do  ponto  de  observação  parecem  mais 
pequenos,  dando  assim  a  ideia  de  profundidade,  com 
pontos de  fuga  a distância  finita na  linha de horizonte, 
figura 1.30. 

Na representação em projecção ortográfica as dimensões 
dos objectos não dependem da distância ao observador, 
como  se  pontos  de  fuga  estivessem  a  uma  distância 
infinitamente grande, 1.31. 

Embora  a  representação  em  perspectiva,  por  ser  a 
correspondente  ao  modo  como  percepcionamos  os 
objectos que nos rodeiam, seja a adoptada no processo 
de  renderização  (construção  da  matriz  (de  pixeis) 
correspondente à  imagem do modelo  (de vectores) 3D, 
figura  1.32),  a modulação/manipulação  dos  objectos  é 
bastante mais  intuitiva  quando  feita  sobre  a  projecção 
ortográfica da cena observada. 

Nos primeiros tempos de contacto vai certamente notar 
que por vezes lhe é extremamente difícil quer manipular 
os  objectos  em  cena  quer  mudar  o  seu  ponto  de 
observação  da  cena.  Tal  deve‐se  ao  facto  de  a 
representação estar a ser  feita em perspectiva. Mude o 
modo  de  representação  para  projecção  ortográfica  e 
verá que tudo passa a ser mais intuitivo. 

 

Figura 1.29 

 

Figura 1.30 

 

Figura 1.31 

 

Figura 1.32 

V 4.0  16 
 



  CGAV 1 ‐ CONCEITOS BÁSICOS 
 

4.11. Modos de Visualização Principais. 
Existem 4 modos principais pré‐definidos de visualização 
dos objectos na janela 3D:  

1. Frontal  (Front). Observação da cena segundo o 
sentido positivo do eixo dos yy, figura 1.37; 

2. Lateral  Direita  (Right).  Observação  da  cena 
segundo sentido negativo do eixo dos xx, figura 
1.40; 

3. Topo  (Top).  Observação  da  cena  segundo 
sentido negativo do eixo dos zz, figura 1.35; 

4. Visão da Câmara (Camera), figura 1.31. 

Acrescem  a  estes  as  três  visualizações  ortogonais  aos 
planos coordenados, complementares das acima citadas: 

1. Posterior (Back). Observação da cena segundo o 
sentido negativo do eixo dos yy, figura 1.38; 

2. Lateral  Esquerda  (Left).  Observação  da  cena 
segundo sentido positivo do eixo dos xx,  figura 
1.39; 

3. Inferior (Bottom). Observação da cena segundo 
sentido negativo do eixo dos zz, figura 1.36. 

Como se aperceberá, é extremamente difícil identificar a 
posição dos objectos no espaço 3D sem  ter acesso às 3 
vistas  ortogonais  ao  planos  coordenados  (Top,  Side  e 
Front). Recorde a configuração Quad View. 

Qualquer dos modos de visualização pode ser evocado a 
partir da barra da janela 3D, [View > ...], figura 1.34. 

Dada  a  frequência  de  utilização,  o  acesso  ao  teclado 
numérico  é  essencial  a  um  bom  ritmo  de  trabalho. 
Accione o [NumLock]. As teclas que permitem modificar 
o modo de visualização são: 

 

Figura 1.33 

 

 

 

Figura 1.34 

 

Figura 1.35 

 

Figura 1.36 
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 [Key3]  (Right) Visão lateral direita. 

[Crtl]+[Key3]  (Left) Visão Lateral Esquerda. 

[Key1]  (Front) Visão Frontal.  

[Crtl]+[Key1]  (Back) Visão Posterior.  

[Key7]  (Top) Visão Superior.  

[Crtl]+[Key7]  (Bottom) Visão Inferior.  

[Key0]  (Camera) Visão da Câmara. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 1.37 

 

Figura 1.38 

 

Figura 1.39 

 

Figura 1.40 
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4.12. Navegação 3D. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

 
[2],[4],[6],[8] 

[MMB] 
[Shift]+[MMB ] 

   

Os comandos de navegação 3D permitem‐nos modificar 
o  ponto  de  vista  do  utilizador  sobre  os  objectos 
presentes  na  Janela  3D,  ou  seja,  a  sua  posição  de 
observação da cena. 

Os comandos de navegação 3D estão acessíveis a partir 
da  barra  da  janelas  3D,  [View>Navigation>…],  figura 
1.41,  no  entanto,  por  serem  acções  constantemente 
utilizadas,  a  sua  selecção  a  partir  deste menu  é  pouco 
prática. 

O  ponto  de  observação  pode  ser  alterado  quer 
recorrendo ao teclado numérico, com [NumLock] activo, 
quer através do rato. 

Contrariamente  ao  accionamento  dos  modos  de 
visualização  segundo a perpendicular de um dos planos 
coordenados, Top, Right, etc., o teclado numérico não é 
aqui essencial, dado que as acções são possíveis através 
da utilização do rato. 

A tabela seguinte resume o conjunto de possíveis acções 

 

Figura 1.41. 

 

 

 

 

(Rotação)  Rotação  da  janela  de 
observação em  torno do eixo   horizontal 
do plano do ecrã. 

[8] 

[2] 
[MMB] 

Movendo  o  rato,  roda  a  janela  de 
observação  em  torno  de  um  eixo 
arbitrário. 

(Rotação)  Rotação  da  janela  de 
observação em torno do eixo dos zz. 

[4] 

[6] 

(Pan)  Move  a  janela  de  observação 
segundo  a  direcção  vertical  do  plano  do 
ecrã. 

[Ctrl]+[8] 

[Ctrl]+[2] 
[Shift]+[MW] 

[Shift]+[MMB] 

Movendo  o  rato, 
move  a  janela  de 
observação  sobre 
qualquer  direcção 
no plano do ecrã. 

(Pan)  Move  a  janela  de  observação 
segundo  a  direcção  horizontal  do  plano 
do ecrã. 

[Ctrl]+[4] 

[Ctrl]+[ 6] 
[Ctrl]+[MW] 
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O domínio : 

• da rotação da janela de observação em torno de 
um eixo arbitrário por movimento do rato com 
o botão central (roda) pressionado, [MMB], 

• do movimento  da  janela  de  observação  sobre 
qualquer  direcção  no  plano  do  ecrã  por 
movimento  do  rato  com  [Shift]+MMB] 
pressionado,  

• do zoom  in / zoom out por movimento da roda 
do rato, [MW],  

é essencial, e suficiente, para a manipulação de objectos 
na Janela 3D.  

 

 

4.13. Zoom in /Zoom out. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Key ‐], [Key +] 
[MW]     

Zoom in/Zoom out pode ser evocada a partir da barra da 
janela 3D, [View> Navigation>...], figura  1.42. 

 

Em  qualquer  modo,  pode  evocar  Zoom  in/Zoom  out 
pressionando  [Key ‐]/ [Key +].  

A acção pode  também, e  com vantagem,  ser efectuada 
através dor movimento da roda do rato, [MW].  

 

Figura 1.42 
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4.14. Align View. 
Align View pode ser evocada a partir da barra da  janela 
3D,  [View>Align  View],  dando  acesso  a  um menu  que 
agrupa um conjunto de acções de alinhamento do ponto 
de  observação  da  janela  3D  com  os  objectos  em  cena, 
figura 1.43. 

Entre  elas,  foi  já  analisado  View  Selected,  mais 
facilmente acessível via [View>View Selected]. 

 

Figura 1.43

4.14.1. Center View to Cursor. [bpy.ops.view3d.view_center_cursor()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[Key .]     

Center View to Cursor pode ser evocada a partir da barra 
da janela 3D, [View>Align View>Center View to Cursor], 
figura 1.44. 

 

Em qualquer modo, pressionando [Ctrl]+[Key.] acciona a 
função Center View to Cursor. 

Center View  to Cursor altera o ponto de observação da 
cena,  mudando  o  enquadramento  de  modo  a  que  o 
cursor 3D fique centrado na janela 3D. 

 

Figura 1.44 

 

 

 

 

 

 

4.14.2. Align Active Camera to View. [bpy.ops.view3d.camera_to_view()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Ctrl]+[Alt]+[Key0]     

Align Active Camera  to View pode ser evocada a partir 
da  barra  da  janela  3D,  [View>Align  View>Align  Active 
Camera to View], figura 1.27. 

 

Em  qualquer  modo,  pressionando  [Ctrl]+[Alt]+[Key0] 
acciona a função Align Active Camera to View. 

 

 

Figura 1.45 
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Align Active Camera to View altera a posição da câmara 
activa de modo a que o ponto de observação da câmara 
passa a corresponder ao ponto de observação da  janela 
3D a quando da activação da função. 

A  função é extremamente útil,  sendo o mais prático de 
enquadrar a cena a renderizar. Ver Módulo 4. 

 

 

 

 

4.14.3. Center Cursor and View All.  [bpy.ops.view3d.view_all(center=True)]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Shift]+[C]     

Center Cursor and View All pode ser evocada a partir da 
barra da janela 3D, [View>Align View>Center Cursor and 
View All], figura  1.46. 

 

Em qualquer modo, pode evocar Center Cursor and View 
All pressionando [Shift]+[C].  

Center  Cursor  and  View  coloca  o  curso  no  centro  do 
sistema de eixos global e enquadra todos os objectos em 
cena na janela 3D. 

4.14.4. Align View to Selected. 

Align  View  to  Selected  pode  ser  evocada  a  partir  da 
barra  da  janela  3D,  [View>Align  View>Align  View  to 
Selected],  figura    1.47,  permitindo  o  alinhamento  do 
ponto  de  observação  da  janela  3D  com  o  sistema  de 
eixos coordenados local ao objecto. 

Como  pode  ver  na  figura  1.47,  os  6  modos  de 
visualização  principais  no  sistema  de  eixos  local  são 
acessíveis  com  base  na mesma  configuração  de  teclas 
dos  6 modos  de  visualização  principais  no  sistema  de 
eixos global mas complementados pela tecla [Shift]. 

 

 

 

Figura 1.46 

 

 

 

 

 

 

 

Figura 1.47 

[Shift]+ [Key3] 
(Right)  Visão  lateral  direita
local. 

[Shift]+ [Crtl]+[Key3]
(Left)  Visão  lateral  esquerda 
local. 

[Shift]+ [Key1]  (Front) Visão frontal local. 

[Shift]+ [Crtl]+[Key1] (Back) Visão posterior local. 

[Shift]+ [Key7]  (Top) Visão superior local. 

[Shift]+ [Crtl]+[Key7] (Bottom) Visão inferior local. 
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5. Menu Select. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5.1. Menu Select. 
No menu Select da janela 3D estão reunidos os métodos 
de selecção dos objectos presentes em cena, figura 1.48. 

É prematuro analisar a maioria dos métodos de selecção 
aqui  presentes.  Tal  será  feito  num  dos  próximos 
módulos, quando for julgado pertinente. 

 

 

 

 

 

 

5.2. Selecção Elementar. 
Ao abrir o Blender,  já existem alguns objectos na  janela 
3D:  um  cubo  (centrado  no  sistema  de  eixos 
coordenados);  uma  fonte  de  luz;  e  uma  câmara,  figura 
1.49. 

Como  pode  observar,  o  cubo  tem  um  contorno  de 
coloração  laranja.  Isto  significa que o cubo é o objecto 
seleccionado, ou, mais exactamente, é o objecto activo. 

Note que no canto  inferior esquerdo é dada  informação 
sobre o posicionamento dos eixos coordenados e o nome 
do objecto activo, figura 1.49. 

 

Figura 1.48 

 

Figura 1.49 
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5.3. Select . [bpy.ops.view3d.select()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [MRB]     

 

Para  seleccionar um object  coloque  sobre  ele o  cursor 
do rato e pressione [MRB]. 

 

Para  fazer  selecção  múltipla  de  objectos  mantenha 
[Shift]  pressionada  e  pressione  [MRB]  sobre  cada  um 
deles. 

Se  pressionar  [Shift]+[MRB]  sobre  um  objecto 
seleccionado que não seja o objecto activo este passa a 
ser o objecto activo. 

Se  pressionar  [Shift]+[MRB]  sobre  o  objecto  activo 
desselecciona o objecto. 

Para desseleccionar um objecto seleccionado não activo 
terá  de  pressionar  [Shift]+[MRB]  sobre  o  objecto  duas 
vezes. 

   

No caso em que existam diversos objectos sobrepostos a 
selecção  poderá  ser  feita  nominalmente  a  partir  do 
menu  que  surge  sobre  a  Janela  3D  se  pressionar 
[Alt]+[MRB] sobre o aglomerado, figura 1.50. 

Existindo mais do que um objecto seleccionado, o último 
dos  objectos  a  ser  seleccionado,  o  objecto  activo,  tem 
uma coloração laranja claro, tendo todos os outros uma 
coloração laranja escuro, figura 1.51. 

Note ainda que a informação sobre os objectos em cena 
é dada na Janela Esquemático (Outliner), à direita e em 
cima, figura 1.52. 

Pode  usar  esta  janela  para  seleccionar  os  objectos, 
pressionando [LMB] sobre o respectivo nome. 

 

 

Figura 1.50 

 

Figura 1.51 

 

Figura 1.52 
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5.4. Border Select. [bpy.ops.view3d.select_border()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [B]     

Border  Select  pode  ser  evocada  a  partir  da  barra  da 
janela 3D, [Select>Border Select], figura 1.53. 

 

Em  modo  objecto,  pode  evocar  Border  Select 
pressionando [B]. 

Para seleccionar um número elevado de objectos active 
Border  Select  e  arraste o  rato  com  [MLB] pressionado. 
São  seleccionados  assim  todos  os  objectos  que  se 
encontrem, mesmo que parcialmente, dentro da  região 
rectangular definida, figuras 1.54 e 1.55. 

Para  desseleccionar  um  conjunto  de  elementos 
seleccionados  proceda  de  igual  modo  mas  mantendo 
agora [MMB] pressionando. 

 

Figura 1.53 

 

Figura 1.54 

 

Figura 1.55 

5.5. Circle Select. [bpy.ops.view3d.select_circle()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [C]     

Circle Select pode ser evocada a partir da barra da janela 
3D, [Select>Circle Select], figura 1.56. 

 

Em  modo  objecto,  pode  evocar  Circle  Select 
pressionando [C]. 

Com  Circle  Select  a  selecção múltipla  é  feita  de modo 
idêntico a Border Select, mas agora numa região circular, 
figura 1.57. Controle o diâmetro da  circunferência  com 
[MW].  Para  sair  da  selecção  circular  pressione  [Esc]. 
Enquanto  em  selecção  circular  pode  arrastar  a 
circunferência,  seleccionando  sucessivamente  mais 
elementos. 

 

Figura 1.56 

 

Figura 1.57 
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5.6. Select/Deselect All. [bpy.ops.object.select_all()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [A]     

Select/Deselect All pode ser evocada a partir da barra da 
janela 3D, [Select>Select/Deselect All], figura 1.58. 

 

Em  modo  objecto,  pode  invocar  Select/Deselect  All 
pressionando [A]. 

Select/Deselect  All  selecciona/desselecciona  todos  os 
objectos em cena. 

 

Figura 1.58 

 

 

5.7. Inverse. [bpy.ops.object.select_inverse()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[I]     

Inverse pode ser evocada a partir da barra da janela 3D, 
[Select>Inverse], figura 1.59. 

 

Em  modo  objecto,  pode  invocar  Inverse  pressionando 
[Ctrl]+[I]. 

Inverse  comuta o  conjunto de objectos  seleccionados e 
não seleccionados. 

 

Figura 1.59 
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6. Menu Object. 
 

 

 

 

 

 

 

 

 

 

 

 

 
O  Menu  Object  agrupa  diversas  acções  de 
manipulação/transformação  dos  objectos  presentes  em 
cena. 

É prematuro analisar aqui a maioria deles. Consideremos 
apenas  os  utilizáveis  a  curto  prazo  ou  associados  a 
conceitos de fácil compreensão: 

• Show/Hide: Esconde os objectos seleccionados, 
ou  revela os objectos previamente escondidos. 
Ver Show/Hide. 

• Move to Layer: Move os objectos seleccionados 
para um determinado layer. Ver Move to Layer. 

• Join:  unta  num  só  o  conjunto  de  objectos 
seleccionados. Ver Join. 

• Delete:  Elimina  os  objectos  seleccionados.  Ver 
Delete. 

• Duplicate  Linked:  Cria  uma  cópia  "forte"  dos 
elementos seleccionados. Ver Duplicate Linked. 

• Duplicate:  Cria  uma  cópia  dos  elementos 
seleccionados. Ver Duplicate. 

• Snap: Funções associadas ao  reposicionamento 
dos objectos seleccionados e do cursor 3D. Ver 
Snap. 

• Apply:  Atribui  definitivamente  as 
transformações  de  translação,  rotação,  e 
escalamento. Ver Apply. 

• Clear: Anular todas as transformações a que um 
objecto tenha sido sujeito, Ver Clear. 

• Mirror:  Funções  associadas  à  reflexão  de 
objectos. Ver Mirror. 

• Transform:  Funções  associadas  a 
transformações  sobre  os  objectos 
seleccionados. Ver Transform. 

 

 

Figura 1.60 
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6.1. Show/Hide. 
6.1.1. Hide Selected. [bpy.ops.object.restrictview_set()]. 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [H]     

Hide  pode  ser  evocada  a  partir  da  barra  da  janela  3D, 
[Object>Show/Hide>Hide Selected], figura 1.61. 

 

Em  modo  objecto,  pode  evocar  Hide  Selected 
pressionando [H]. 

Hide Selected esconde os objectos seleccionados.  

Após a operação pode comutar entre os objectos visíveis 
e  não  visíveis  (seleccionados  e  não  seleccionados)  na 
tabela  de  operadores,  activando/desactivando 
Unselected, figura 1.62. 

 

Em modo objecto, pressionando  [Shift]+[H] esconde os 
objectos ão seleccionados.  n

6.1.2. Show Hidden. [

 

Figura 1.61 

 

Figura 1.62 

 

 

 

 

bpy.ops.object.restrictview_clear()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[H]     

Show  Hidden  pode  ser  evocada  a  partir  da  barra  da 
janela  3D,  [Object>Show/Hide>Show  Hidden],  figura 
1.63. 

 

Em modo  objecto,  pode  evocar  a  função  Show Hidden 
pressionando [Alt]+[H]. 

Show  Hidden  expõe  os  objectos  que  previamente 
tenham sido escondidos com Hide Selected. 

 

Figura 1.63 
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6.2. Join. [bpy.ops.object.join()]. 

29 
 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[J]     

Join pode ser evocada a partir da tabela de operadores e 
a partir da barra da janela 3D, [Object>Join], figura 1.64. 

 

Em  modo  objecto,  pode  evocar  Join  pressionando 
[Ctrl]+[J]. 

Join junta num só o conjunto de objectos seleccionados. 

Os objectos a  juntar  têm de  ser do mesmo  tipo,  isto é, 
não  pode,  por  exemplo,  juntar  uma  malha  com  uma 
curva. 

Apesar  de  passarem  a  constituir  uma mesma malha,  e 
portanto  não  ser  trivial  separá‐los  à  posteriori,  os 
objectos  juntos  em  modo  objecto  preservam  algumas 
das suas características, como, por exemplo, os materiais 
associados.  Nas  figuras  1.65  e  1.66  pode  ver  a 
informação  constante  na  janela  Esquemático  quando 
dois  objectos  com  diferentes  materiais  atribuídos  são 
juntos na mesma malha. 

 

Figura 1.64 

 

Figura 1.65 

 

Figura 1.66 

 

 

 

6.3. Delete. [bpy.ops.object.delete()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [X]     

Delete  pode  ser  evocada  a  partir  da  tabela  de 
operadores  e  a  partir  da  barra  da  janela  3D, 
[Object>Delete], figura 1.67. 

 

Em modo objecto, pode evocar Delete pressionando [X]. 

Delete    elimina  o  conjunto  de  objectos  seleccionados. 
Verá  surgir  no  ecrã  o  menu  da  figura  1.68  a  pedir  a 
confirmação da acção. 

 

Figura 1.67 

 

Figura 1.68 
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6.4. Duplicate. [bpy.ops.object.duplicate_move()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Shift]+[D]     

Duplicate pode  ser evocada  a partir da barra da  janela 
3D,  [Object>Duplicate],  e  a  partir  da  tabela  de 
operadores, figura 1.69. 

 
Em modo objecto, pode evocar Duplicate pressionando 
[Shift]+[D]. 

Duplicate  cria uma  cópia dos objectos  seleccionados. A 
cópia, dita  cópia  com  ligação  fraca, é criada na mesma 
posição  do  objecto  original  ficando  em  modo  de 
translação (Grab). 

A cópia partilha os mesmos Materiais, Texturas e curvas 
IPO  do  objecto  original,  mas  é  independente 
relativamente  às  alterações  à  Malha  e  às 
Transformações. 

Na figura 1.70 pode ver a informação constante na janela 
Esquemático  num  exemplo  em  que  o  objecto  "Mesh2" 
foi  duplicado  com  ligação  fraca  a  partir  do  objecto 
"Mesh1".  Note  que  cada  um  dos  objectos  tem  uma 
malha diferente, respectivamente Mesh.008 e Mesh.010, 
mas  ficaram  a  partilhar  o mesmo material  e  a mesma 
textura. 

De  qualquer  modo,  as  ligações  existentes  podem  ser 
quebradas  nos  contextos  adequados,  pelo  que  a 
duplicação  é  uma  funcionalidade  a  considerar  mesmo 
quando a herança não é desejável. 

 

Figura 1.69 

 

Figura 1.70 
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6.5. Duplicate Linked. 
[bpy.ops.object.duplicate_move_linked()]. 

Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Alt]+[D]     

Duplicate Linked pode ser evocada a partir da barra da 
janela 3D, [Object>Duplicate Linked], figura 1.71. 

 

Em  modo  objecto,  pode  evocar  Duplicate  Linked 
pressionando [Alt]+[D]. 

Duplicate  Linked  cria  uma  cópia  dos  objectos 
seleccionados.  

A cópia, dita cópia com ligação forte, é criada na mesma 
posição  do  objecto  original  ficando  em  modo  de 
translação (Grab). 

A  cópia  partilha  todos  os  atributos  do  objecto  original 
com  excepção  das  Transformações,  ou  seja,  as  cópias 
podem  ser  movida,  rodadas  e  escaladas 
independentemente,  mas  qualquer  outra  alteração  é 
transmitida  a  todas  elas,  nomeadamente  todas  as 
modificações em modo edição. 

A  figura  1.72 mostra  um  exemplo  de  um  ambiente  de 
edição  de  dois  objectos  fortemente  ligados:  ao 
seleccionar  e  mover  alguns  dos  vértices  de  um  dos 
objectos  a  malha  da  sua  cópia  sofre  exactamente  as 
mesmas modificações. 

A  figura  1.73 mostra  a  informação  constante  na  janela 
Esquemático  num  exemplo  em  que  o  objecto  "Mesh2" 
foi  duplicado  com  ligação  forte  a  partir  do  objecto 
"Mesh1".  Note  que  qualquer  dos  objectos  partilha  a 
mesma malha, material e textura. 

 

 

 

 

 

Figura 1.71 

 

 Figura 1.72 

 

Figura 1.73 
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6.6. Snap. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Sift]+[S]     

Snap pode  ser  evocada  a partir  da  barra  da  janela  3D, 
[Object>Snap], figura 174. 

   

Em  modo  objecto,  pode  evocar  Snap  pressionando 
[Sift]+[S].  

Snap permite fazer o posicionamento de um objecto com 
precisão.  A  partir  deste  menu  podemos  transladar  o 
objecto seleccionado (o seu centro) para: 

1. O ponto visível  (conforme o nível de  zoom) da 
grelha que se encontre mais próximo do centro 
do objecto: [Selection to Grid]. 
[bpy.ops.view3d.snap_selected_to_grid()] 

2. O  ponto  em  que  se  encontra  o  cursor  3D: 
[Selection to Cursor]. 
[bpy.ops.view3d.snap_selected_to_cursor()] 

Na  maior  parte  das  situações  o  posicionamento  com 
precisão é feito com recurso ao cursor 3D e combinação 
do  posicionamento  do  cursor  3D  com  as  acções  acima 
referidas. Assim, no menu Snap, existem ainda as opções 
correspondentes à colocação do cursor 3D:  

1. No  ponto  correspondente  ao  centro  de  vários 
objectos seleccionados: [Cursor to Selected]. 
[bpy.ops.view3d.snap_cursor_to_selected()] 

2. Na  origem  dos  eixos  coordenados:  [Cursor  to 
Center]. 
[bpy.ops.view3d.snap_cursor_to_center()]. 

3. No ponto visível (dependente do nível de zoom) 
da  grelha  que  se  encontre  mais  próximo: 
[Cursor to Grid]. 
[bpy.ops.view3d.snap_cursor_to_grid()]. 

4. No centro do objecto activo: [Cursor to Active]. 
[bpy.ops.view3d.snap_cursor_to_active()]  

Para  posicionar  o  cursor  3D  com  exactidão  a  partir  da 
especificação  das  suas  coordenadas  recorra  ao  Painel 
View da Tabela de Propriedades, [N], figura 1.76.  

 

Figura 1.74 

 

Figura 1.75 

 

Figura 1.76 
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6.7. Transform. 
Na barra da janela 3D seleccione Object e, no menu que 
aparece, seleccione Transform, figura 1.77. 

A partir dos  submenus que aparecem pode executar as 
acções de Translação (Grab/Move), Rotação (Rotate) ou 
Escalamento (Scale). 

A  translação,  rotação  e  escalamento  de  objectos  é 
efectuado  por  utilização  simultânea  do  teclado  e  do 
movimento do rato. 

Depois  de  fazer  a  alteração  desejada,  quer  através  do 
rato  quer  do  teclado,  pressione  o  botão  esquerdo  do 
rato, [MLB], para confirmar a transformação.  

Pressione o botão direito do  rato,  [MRB], ou  [Esc] para 
anular a transformação. 

[G] Rato 
Translação  livre  do  objecto 
seleccionado,  proporcional  ao 
movimento do rato. 

[G] [Ctrl]+ Rato   Translação  em  incrementos  de 
unidade da malha. 

[G] [Shift]+ Rato   Translação com ajuste fino

[R] Rato  Rotação do objecto seleccionado.

[R] [Ctrl]+ Rato  Rotação com incrementos de 5º.

[R] [Shift]+ Rato   Rotação com ajuste fino. 

[S]  Rato  Escalamento  do  objecto 
seleccionado. 

[S] [Ctrl]+ Rato   Escalamento  com  incrementos de 
0.1. 

[S] [Shift]+ Rato   Escalamento com ajuste fino.

 

 

Figura 1.77 

 

 

 

 

 

 

 

 

 

6.7.1. Grab. [bpy.ops.transform.translate()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [G]     

 

Com  um  objecto  seleccionado,  pressione  [G]  para 
proceder a uma translação. 

 

Figura 1.78 
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6.7.2. Rotate. [bpy.ops.transform.rotate()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

   [R]     

 

Com  um  objecto  seleccionado,  pressione  [R]  para 
proceder a uma rotação. 

 

Figura 1.79 

 

6.7.3. Scale. [bpy.ops.transform.resize()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

   [S]     

 

Com  um  objecto  seleccionado,  pressione  [S]  para 
proceder a um escalamento. 

 

Figura1.80 

 

 

 

Os  resultados  da  operação  de  escalamento  podem 
parecer confusos. Todos os objectos em Blender têm um 
centro  (designado  por  origem  na  versão  2.5).  Note  o 
pequeno  circulo  assinalado  a  laranja  (figura  1.72).  A 
modificação  do  factor  de  escalamento  depende  da 
modificação da distância do cursor do rato ao centro do 
objecto. 

As acções de translação e rotação são independentes da 
distância  do  rato  ao  objecto,  sendo  proporcionais  ao 
movimento  do  rato.  Tendo  em  atenção  que,  numa 
transformação de  rotação, como o ângulo de  rotação é 
proporcional ao movimento do rato, quanto maior for a 
distância  do  rato  ao  centro  do  objecto  menor  será  o 
incremento angular, e, portanto, maior será precisão. 

Na verdade, as transformações de rotação e escalamento 
são  feitas  num  referencial  cuja  origem,  designado  por 
Pivot,  não  é  necessariamente  o  Centro  do  Objecto 
(Median Point).  
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6.7.4. Transformações segundo os eixos. 

Podemos restringir a translação de um objecto a uma das 
3  direcções  coordenadas  do  sistema  de  eixos  global 
pressionando a respectiva tecla, [X], [Y] ou [Z], ou a uma 
das 3 direcções coordenadas do sistema de eixos local do 
objecto  pressionando  [X][X],  [Y][Y]  ou  [Z][Z],  sendo  o 
eixo  de  referência  representado  na  Janela  3D,  figuras 
1.81 e 1.82 O mesmo  se aplica para a  selecção do eixo 
em torno do qual é feita a rotação, ou segundo o qual é 
feito o escalamento. 

A  restrição  aos  eixos  coordenados pode  ainda  ser  feita 
mantendo  [MMB] pressionado enquanto  se movimenta 
o  rato,  sendo  a  transformação  feita  relativamente  ao 
eixo mais próximo do cursor do rato. 

[G], [R], ou [S] 
[X] 

Translação ou escalamento segundo, 
ou  rotação em  torno de, o eixo dos 
xx do sistema de eixos global. 

[G],  [R],  ou  [S] 
[Y] 

Translação ou escalamento segundo, 
ou  rotação em  torno de, o eixo dos 
yy do sistema de eixos global. 

[G],  [R],  ou  [S] 
[Z] 

Translação ou escalamento segundo, 
ou  rotação em  torno de, o eixo dos 
zz do sistema de eixos global. 

[G],  [R],  ou  [S] 
[X]  [X] 

Translação ou escalamento segundo, 
ou  rotação em  torno de, o eixo dos 
xx  do  sistema  de  eixos  local  (do 
objecto seleccionado). 

[G],  [R],  ou  [S] 
[Y]  [Y] 

Translação ou escalamento segundo, 
ou  rotação em  torno de, o eixo dos 
yy  do  sistema  de  eixos  local  (do 
objecto seleccionado). 

[G],  [R],  ou  [S] 
[Z]  [Z] 

Translação ou escalamento segundo, 
ou  rotação em  torno de, o eixo dos 
zz  do  sistema  de  eixos  local  (do 
objecto seleccionado). 

 

6.7.5. Transformações num plano. 

Para executar uma translação ou um escalamento sobre 
um  plano  coordenado  do  sistema  de  eixos  global 
pressione  [Shift]+[X],  [Y],  ou  [Z],  respectivamente  para 
uma transformação sobre o plano yz, xz, ou xy  (no caso 
da rotação, pressionar [Shift] é obviamente irrelevante), 

 

 

Figura 1.81 

 

Figura 1.82 
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ou [Shift]+[X][X], [Y][Y], ou [Z][Z], respectivamente para 
uma  transformação  sobre  o  plano  yz,  xz,  ou  xy, 
relativamente ao  sistema de eixos  local,  sendo os eixos 
relativos ao plano de referência representados na Janela 
3D, figuras 1.83 e 1.84. 

 

[G] ou [S]   
[Shift]+[X] 

Translação  ou  escalamento  sobre  o 
plano dos yz do sistema de eixos global.

[G] ou [S]   
[Shift]+[Y] 

Translação  ou  escalamento  sobre  o 
plano dos xz do sistema de eixos global.

[G] ou [S]   
[Shift]+[Z] 

Translação  ou  escalamento  sobre  o 
plano  dos  xy  do  sistema  de  eixos 
global. 

[G] ou [S]   
[Shift]+[X]+[X] 

Translação  ou  escalamento  sobre  o 
plano dos yz do  sistema de eixos  local 
(do objecto seleccionado). 

[G] ou [S]   
[Shift]+[Y] [Y] 

Translação  ou  escalamento  sobre  o 
plano dos xz do  sistema de eixos  local 
(do objecto seleccionado). 

[G] ou [S]   
[Shift]+[Z] [Z] 

Translação  ou  escalamento  sobre  o 
plano dos xy do sistema de eixos  local 
(do objecto seleccionado). 

 

6.7.6. Transformações de precisão. 

Note  que  enquanto  efectua  qualquer  das  3  acções  de 
transformação, na barra  inferior da  janela 3D é  indicada 
a variação das coordenadas do centro do objecto sobre o 
qual está a actuar no caso de uma translação, figura 1.84, 
o ângulo, em graus, no caso de uma rotação, figura 1.85, 
e  o  factor  de  escalamento,  figura  1.86,  no  caso  de  um 
escalamento. 

Estes  valores  podem  ser  editados  directamente,  quer 
através  do  teclado,  quer  do  teclado  numérico, 
permitindo assim toda a precisão que se desejar. 

Utilize  [Tab]  para  mudar  de  eixo,  [Backspace]  para 
anular valores introduzidos e [Enter] para confirmar. 

Este é o modo mais expedito de executar transformações 
de  precisão,  requerendo  necessariamente  alguma 
prática.  Pode  também  proceder  a  transformações  de 
precisão  recorrendo  à  Tabela  de  Propriedades  e/ou  à 
Tabela de Operadores. 

 

Figura 1.83 

 

Figura 1.84 

 

Figura 1.85 

 

Figura1.86 

 

Figura 1.87
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6.7.7. Align to Transform Orientation. [bpy.ops.transform.transform()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

       

Align to Transform Orientation pode ser evocada a partir 
da  barra  da  janela  3D,  [Object>Transform>Align  to 
Transform Orientation], figura 1.88. 

Align to Transform Orientation   roda o objecto de modo 
a  alinhar  o  seu  sistema  de  eixos  local  com  os  eixos 
coordenados  globais  ou  definidos  pelo  utilizador, 
conform especificado no e 

6.7.8. To Sphere, Shear, Warp, Push/Pull. 

Menu de Transformadores. 

 

Figura 1.88 

 

 

 

Embora aqui disponíveis, figura 1..89, este é um conjunto 
de  transformações  bastante  mais  utilizado  em  modo 
edição do que em modo objecto, que analisaremos em 
detalhe no Módulo 2. 

• To  Shere:  Reposiciona  os  centros  do  conjunto 
de  objectos  seleccionados  sobre  uma  esfera, 
tomando  como  centro de  curvatura o pivot  tal 
como definido no menu Pivot Point. 

• Shear: Enviesa o posicionamento dos centro dos 
objectos  seleccionados  ao  longo  do  eixo 
horizontal do plano do ecrã. 

• Warp:  Distribui  os  centros  do  conjunto  de 
objectos seleccionados ao  longo de um círculo, 
que tem por centro o cursor 3D. 

• Push/Pull:  Afasta,  ou  aproxima,  todos  os 
centros  dos  objectos  seleccionados  de  igual 
istância relativamente ao pivot. d

6.7.9. Reposicionamento da origem. [

 

Figura 1.89 

 

 

 

 

 

bpy.ops.object.origin_set()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

       

O reposicionamento da origem pode ser evocado a partir 
da  barra  da  janela  3D,  [Object>Transform>...],  figura 
1.90. 

 

Figura 1.90 
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• Geometry  to  Origin:  A  malha  do  objecto  é 
deslocada de modo a que o seu baricentro fique 
coincidente  com  o  ponto  onde  se  encontra  a 
origem, figura 1.91. 

 

 

• Origin  to Geometry:  A  origem  é  deslocada  de 
modo  a  ficar  coincidente  com  o  baricentro  da 
malha do objecto, figura 1.92. 

 

 

 

• Origin  to  3D  Cursor:  A  origem  do  objecto  é 
deslocada  para  o  ponto  onde  se  encontra  o 
cursor 3D. Note que a malha não sofre qualquer 
deslocamento, figura 1.93. 

 

 

 

Figura 1.91 

 

Figura 1.92 

 

Figura 1.93 

6.7.10. Align Objects. [bpy.ops.object.align()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

       

Align  Objects  pode  ser  evocado  a  partir  da  barra  da 
janela  3D,  [Object>Transform>Align  Objects],  figura 
1.94. 

Align Objects faz o alinhamento do conjunto de objectos 
seleccionados. 

Após  a  evocação  da  função,  na  tabela  de  operadores, 
pode  ser  seleccionado  o  modo,  o  alvo,  e  os  eixos 
segundo os quais é feito o alinhamento, figura 1.95. 

 

 

 

 

 

Figura 1.94 

 

Figura 1.95 
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6.8. Apply. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Ctrl]+[A]     

Apply pode  ser evocado a partir da barra da  janela 3D, 
[Object>Apply], figura 1.96. 

  

Em  modo  objecto,  pode  evocar  Apply  pressionando 
[Ctrl]+[A]. 

Apply  atribui  definitivamente  as  transformações  de 
translação  [bpy.ops.object.location_apply()],  rotação 
[bpy.ops.object.rotation_apply()],  e  escalamento 
[bpy.ops.object.scale_apply()],  a  que  um  objecto  foi 
sujeito  à  sua  estrutura  interna.  Pressionando  [Ctrl]+[A] 
surge  no  ecrã  o  menu  da  figura  1.97,  em  que  pode 
escolher qual das transformações pretende atribuir. 

Como  em  qualquer  menu  accionado  por  uma 
combinação de teclas, pode activar cada uma das opções 
do menu pressionando o número correspondente à sua 
posição de  cima para baixo. Ou  seja, no presente  caso, 
por exemplo, pode accionar Apply Rotation pressionando 
[Ctrl]+[A], [2].   

É aqui prematura a discussão da estrutura de dados do 
Blender. No entanto, é relevante, pelas  implicações que 
posteriormente  poderá  ter  sobre  eventuais  acções  de 
Animação e Texturização do objecto,  fazer os  seguintes 
considerandos. 

A  figura  1.98 mostra  um  cubo  com  as  suas  dimensões 
padrão,  [2.0  2.0  2.0],  como  se  pode  ver  na  tabela  de 
propriedades  e  na  representação  da  sua  estrutura 
interna, em que ao  lado de cada aresta se mostra a sua 
dimensão. 

Na  figura 1.99 pode ver o mesmo cubo após ter sofrido 
um escalamento de um factor 2.0 segundo cada uma das 
direcções coordenadas, tal pode ser verificado através da 
tabela  de  propriedades.  Como  pode  ver  na 
representação  da  estrutura  interna  mantém‐se,  no 
entanto, o registo das dimensões originais. 

 

Figura 1.96 

 

Figura1.97 

 

Figura 1.98 

 

Figura 1.99 
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Atribuamos definitivamente o escalamento  sofrido pelo 
cubo, pressionando  [Ctrl]+[A]. Como pode ver na  figura 
1.100,  na  tabela  de  propriedades  consta  agora  a 
informação de que o  cubo  tem dimensões  [4.0 4.0 4.0] 
com um factor de escalamento 1.0, e a estrutura interna 
do  cubo  reflecte  a mesma  informação.  Tal  como  se  o 
cubo  tivesse  originalmente  sido  criado  com  estas 
dimensões. 

   

Figura 1.100 

6.9. Clear. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

 
[Alt]+[G] 
[Alt]+[R] 
[Alt]+[S] 

   

Clear pode  ser evocado  a partir da barra da  janela 3D, 
[Object>Clear], figura 1.101. 

Em  qualquer  altura,  é  possível  anular  todas  as 
transformações  a  que  um  objecto  tenha  sido  sujeito  e 
ainda não  tenham sido atribuídas definitivamente à sua 
estrutura interna. 

  

Pressionando  [Alt]+[G]  anula  todas  as  acções  de 
translação  a  que  o  objecto  activo  tenha  sido  sujeito. 
[bpy.ops.object.location_clear()].  

  

Pressionando [Alt]+[R] anula todas as acções de rotação 
a  que  o  objecto  activo  tenha  sido  sujeito.  
[bpy.ops.object.rotation_clear()]. 

  

Pressionando  [Alt]+[S]  anula  todas  as  acções  de 
escalamento  a que o objecto  activo  tenha  sido  sujeito. 
[bpy.ops.object.scale_clear()]. 

É  prematuro  analisar  aqui  a  opção  Clear  Origin, 
relacionada  com  as  relações  de  parentesco  que  é 
possível estabelecer entre objectos.  

 

Figura 1.101 
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6.10. Mirror. [bpy.ops.transform.mirror()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Ctrl]+[M]     

Mirror pode ser evocado a partir da barra da  janela 3D, 
[Object>Mirror], figura 6.33. 

 

Em  modo  objecto,  pode  evocar  Mirror  pressionando 
[Ctrl]+[M]. 

A funcionalidade pode ser utilizada quer, simplesmente, 
para  reflectir  a  posição  de um  objecto  relativamente  a 
um  eixo,  quer,  quando  acompanhada  de  duplicação  e 
junção,  utilizada  para  modelar  objectos  que  exibam 
simetrias. 

Na acção de reflexão é essencial a conveniente definição 
prévia do pivot no menu Pivot Point.  

Em  modo  objecto  a  reflexão  só  pode  ser  feita 
relativamente ao sistema de coordenadas global. 

Quando  activada  a  partir  da  combinação  de  teclas  a 
acção corresponde à opção Interactive Mirror do menu. 

A figura 1.103 mostra uma reflexão da cópia do objecto 
ao longo do eixo dos yy tendo como pivot o Cursor 3D: 

• Seleccione o objecto. 
• Crie  uma  cópia,  [Shift]+[D],  e  pressione  de 

imediato [LMB] para confirmar a acção e sair de 
modo translação sem a mover. 

• Seleccione  o  pivot  desejado  no  menu  Pivot 
Point, no caso o cursor 3D. 

• Pressione  [Ctrl]+[M]  seguido  do  eixo 
correspondente  à  translação,  no  caso  [Y]. 
Pressione [LMB] para confirmar a acção..  

 

 

 

Figura 1.102 

 

Figura 1.103 
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7. Menu Mode. 
 

 

 

 

 

 

 

 

No Menu Mode, figura 1.104,  pode seleccionar o modo 
de trabalho na janela 3D 

O Modo Objecto (Object Mode), em que a  janela 3D se 
encontra quando abre o Blender na configuração padrão, 
e o Modo Edição (Edit Mode) são os dois modos básicos 
de manipulação/modelação de objectos. 

Em modo objecto, de que  temos vindo a  falar até aqui, 
temos  acesso  ao  objecto  como  um  todo.  É  por  isso  o 
modo conveniente para fazer transformações globais do 
objecto, como seja uma translação, um escalamento, etc. 

Em modo edição temos acesso aos elementos da malha 
que constitui cada um dos objectos (tipo Mesh): os seus 
vértices, arestas e faces. É por isso o modo conveniente 
para fazer alterações à forma de cada objecto.  

Falaremos  do modo  edição  no  próximo Módulo,  e  dos 
restantes modos de  trabalho à medida que a utilização 
de cada um deles se revelar necessário. 

 

 

 

 

 

Figura 1.104 
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8. Menu Viewport Shading. 
 

 

 

 

 

 

 

 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Z] 
[Alt]+[Z]     

Viewport  Shading,  que  designaremos  por  Modos  de 
Sombreamentos pode  ser evocada a partir da barra da 
janela 3D, figura  1.105. 

Os  modos  de  sombreamento  aqui  referidos  dizem 
respeito aos tipos de representação gráfica dos objectos 
em ambiente de trabalho na janela 3D. 

O conceito não deve ser confundido com os métodos de 
sombreamento  a  abordar  quando  for  analisada  a 
caracterização de materiais. 

Como  pode  ver  existem  4  alternativas,  sendo  o Modo 
Solid a representação padrão, figura 1.106. 

Note que no modo Solid o sombreamento dos objectos 
não depende das fontes de luz presentes em cena, sendo 
cada uma das  faces dos objectos representada por uma 
cor sólida (única), figura 1.106. 

 

Figura 1.105 

 

Figura 1.106 

 

V 4.0  43 
 



  CGAV 1 ‐ CONCEITOS BÁSICOS 
 

Dependendo  da  complexidade  do  modelo,  poderá  ser 
conveniente,  para  uma  mais  fácil  manipulação,  a 
representação em Modo Wireframe, figura 1.107. 

 

Pressionando  [Z]  comuta  entre  os  modos  Solid  e 
Wireframe. 

Em  modo  Wireframe  os  objectos  são  representados 
pelas arestas que  lhe dão a forma externa reconhecível, 
figura 1.107.  

Não confunda com a reprentação dos objectos em modo 
edição,  figura 1.108,  também ela  sucestível de  ser  feita 
em modo Solid ou Wireframe. 

 

Pressionando [Alt]+[Z] comuta entre os modos Textured 
e Solid. 

O Modo Textured é  indicado para  verificar o  resultado 
do  mapeamento  de  imagens  sobre  o  objecto,  figura 
1.109 dando uma  ideia aproximada do aspecto da cena 
quando renderizada. 

Outro  tipo  de  texturas,  ditas  texturas  procedimentais 
não são visíveis neste modo de sombreamento. 

Note  que  quando  em modo  Textured  a  representação 
dos  objectos  em  cena  depende  das  fonte  de  luz 
presentes. 

Em  Modo  Bounding  Box  apenas  é  representado  o 
paralelepípedo envolvente de cada um dos objectos. 

 

 

 

 

 

Figura 1.107 

 

Figura 1.108 

 

Figura 1.109 
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9. Menu Pivot Point. 
 

 

 

 

 

As  transformações de  rotação e escalamento  são  feitas 
num referencial cuja origem, designado por Pivot, não é 
necessariamente o Origem do Objecto (Median Point).  

 

Pressionando  [Alt]+[.],  [,],  [Ctrl]+[,],  [.]  e  [Ctrl]+[.]  é 
seleccionado  um  diferente  pivot  de  rotação  ou 
escalamento. Quer através do  teclado, quer  recorrendo 
ao Menu  Pivot  Point  existente  na  barra  da  Janela  3D, 
figura 1.110, pode ser seleccionada uma das 5 opções: 

• Active  Element:  [Alt]+[.].  No  caso  de  vários 
objectos  seleccionados,  o  Pivot  corresponde  à 
origem  do  último  dos  objectos  a  ser 
seleccionado. 

• Median Point:  [Ctrl]+[,]. O Pivot corresponde à 
origem do conjunto dos objectos seleccionados 
(baricentro  de  todos  os  vértices  seleccionados 
quando em modo edição). 

• Individual Origins:  [Ctrl]+[.].  Cada  objecto  tem 
um  Pivot  diferente.  Cada  um  dos  objectos 
seleccionados  é  rodado  (ou  escalado) 
relativamente  à  sua  origem  (sendo  todos  os 
sistemas  de  eixos  alinhados  com  o  sistema 
global). 

• 3D  Cursor:  [.]:  O  pivot  corresponde  ao  cursor 
3D.  

• Bounding Box Center: [,]: O Pivot corresponde à 
origem  da  Bounding  Box  do  conjunto  de 
objectos seleccionados. 

 

Figura 1.110 
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10. Menu de Transformadores. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pode  proceder  a  uma  translação,  rotação  ou 
escalamento, acedendo, na barra da janela 3D, ao Menu 
de Transformadores, figura 1.111. 

  

Alternativamente  à  barra  da  Janela  3D  o  menu  de 
transformadores  pode  ser  activado  pressionando 
[Ctrl]+[Space]. 

Pressionando cada um dos  símbolos  fará  surgir  sobre o 
objecto  seleccionado  um  conjunto  de  3 manipuladores 
(eixo dos xx a vermelho; eixo dos yy a verde; e eixo dos 
zz  a  azul)  ,  figura  1.111,  que  pode  manipular 
pressionando  [MLB] sobre um deles e movimentando o 
rato. 

O  1º  símbolo  corresponde  aos  manipuladores  de 
translação,  figura  1.111,  o  2º  aos  manipuladores  de 
rotação,  figura  1.112,  e  o  3º  aos  manipuladores  de 
escalamento, figura 1.113.  

Se mantiver [Shift] pressionando enquanto selecciona os 
símbolos dos transformadores pode activar mais do que 
um conjunto de transformadores. 

Após  ter  pressionado  [MLB]  sobre  um  dos 
manipuladores,  se  mantiver  [Ctrl]  pressionado  a 
transformação  far‐se‐á  incrementalmente  (translações 
em unidades da malha, rotações em incrementos de 5º e 
escalamentos em incrementos de 0.1). 

 

Figura 1.111 

 

Figura 1.112 
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Se pressionar  [Shift] quando pressiona  [MLB]  sobre um 
dos manipuladores, a transformação será feita no plano 
definido pelos outros dois eixos. 

  

O  sistema  de  eixos  pelo  qual  os manipuladores  estão 
alinhados pode  ser  seleccionado quer a partir do menu 
de transformadores, quer a partir do menu que surge no 
ecrã quando se pressiona [Alt]+[Space], figura 1.116. 

A opção Global alinha os manipuladores  com o  sistema 
de eixos global, a  Local alinha os manipuladores  com o 
sistema de eixos local do objecto activo, e View com um 
sistema de eixos alinhado com a janela 3D. 

A opção Normal só é relevante quando os objectos estão 
a ser manipulados em Modo Edição.  

A  opção  Gimbal  não  é  de  momento  relevante.  Está 
relacionada  com  o  alinhamento  dos  eixos  de  rotação 
resultante do método de cálculo da transformação e será 
analisada apenas quando entrarmos na animação. 

 

Figura 1.113 

 

Figura 1.114

10.1. Definição de Orientações. 
Em  muitas  situações  é  desejável  proceder  a 
transformações  de  um  objecto  segundo  o  sistema  de 
eixos local de um outro. 

   

Seleccionando  um  objecto  e  pressionando 
[Ctrl]+[Alt]+[Space]  junta  aos  sistemas  de  orientação 
padrão  (Global,  Local,  etc.)  um  sistema  personalizado, 
correspondente  ao  sistema  de  eixos  local  do  objecto 
seleccionado, figuras 1.115. 

Posteriormente,  este  sistema  de  eixos  pode  ser 
seleccionado para orientar as transformações a efectuar 
sobre um qualquer outro objecto.  

A mesma acção pode ser desencadeada a partir do painel 
Transform Orientations da Tabela de Propriedades. 

 

 

Figura 1.115 

 

Figura 1.116 

V 4.0  47 
 



  CGAV 1 ‐ CONCEITOS BÁSICOS 
 

11. Menu Layers. 
 

 

 

 

 

 

 

 

 

 

 

 

 

No Menu Layers pode seleccionar qual, ou quais, das 20 
plataformas de  trabalho  é  visível na  janela 3D  (e  serão 
consideradas no processo de renderização), figura 1.117. 

Pressionando,  [LMB],  um  dos  pequenos  rectângulos 
activa o  layer que  lhe está associado, passando a cor do 
rectângulo  a  um  tom  cinzento mais  escuro. Mantendo 
[Shift]  pressionado  enquanto  selecciona  os  layers 
permite‐lhe  ter  em  simultâneo  mais  do  que  um  layer 
activo. 

Os layer que contêm objectos são representados com um 
pequeno círculo no  interior, tendo o círculo a coloração 
laranja  no  caso  em  que  o  objecto  activo  se  encontre 
nesse laye figura r, 

11.1. Move to Layer. [
1.117. 

 

Figura 1.117 

 

 

 

 

bpy.ops.object.move_to_layer()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [M]     

Move  to  Layer  pode  ser  evocada  a  partir  da  barra  da 
janela 3D, [Object>Move To Layer], figura  1.118. 

 

Em  modo  objecto,  pode  evocar  Move  to  Layer 
pressionando [M]. 

Surgirá  no  ecrã  o menu  da  figura  xxx  que  lhe  permite 
especificar  qual  o  layer  para  onde  deseja  transferir  os 
objectos  seleccionados,  pressionando  o  rectângulo  que 
lhe está associado, figura 1.119. 

 

 

Figura 1.118 

 

Figura 1.119
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12. Tabela de Operadores. 
 

 

 

 

 

 

 

Quando  abre  o  Blender,  na  configuração  padrão,  a 
Tabela de Operadores está aberta na  zona à direita da 
janela 3D, figura 1.120. 

 

Pressionando  [T]  mostra/esconde  a  tabela  de 
operadores. 

A tabela de operadores é composta por 3 painéis: 

• O painel Tool Shelf, onde pode  seleccionar um 
qualquer  operador  e  adicioná‐lo,  na  forma  de 
botão, à tabela. 

• O  painel  Object  Tools,  composto  por  um 
conjunto  de  botões  associados  a  operações 
possíveis  sobre o objecto activo. A  composição 
da  tabela depende do  tipo de objecto activo e 
do modo de trabalho seleccionado. 

• O painel Operator, em que é mostrada a última 
operação  efectuada  sobre  o  objecto  activo, 
com,  se  se  aplicar,  o  conjunto  de  caixas  de 
propriedades associadas a essa operação.  

Pressionando,  [MLB],  o  triângulo  a  negro  no  topo 
superior  de  cada  painel  pode  esconder/mostrar  o  seu 
conteúdo.  Pressionando,  [MLB],  a  zona  triangular 
tracejada  no  canto  superior  direito  de  cada  painel  e 

arrastando o rato pode mudar a posição relativa de cada 
painel. 

 

Figura1.120 
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12.1. Tools Shelf 
Pressionando os pequenos  triângulos na caixa Add Tool 
acciona um mecanismo de busca de operadores. 

A  figura  1.121  mostra  a  operação  de  procura  do 
operador Toggle Quad View. 

Após  a  selecção  do  operador  desejado  a  tabela  Tools 
Shelf passará a integrar o respectivo botão. 

A  figura  1.122  mostra  a  configuração  da  tabela  Tools 
Shelf após a  inserção do botão que acciona o operador 
Toggle Quad View.  

 

 

 

12.2. Object Tools. 
No  painel  Object  Tools,  figura  1.123,  constam  um 
conjunto de botões agrupados em   secções funcionais e 
associados  a  diversas  operações  que  poderá  efectuar 
sobre o objecto activo e que em seguida se descrevem. 

• Transform:  Aos  3  primeiros  botões 
correspondem as operações  translação, rotação 
e  escalamento.  Pode  activar  qualquer  das 
transformações  pressionando  o  respectivo 
botão.  Sendo acções básicas  com  combinações 
de teclas associadas facilmente memorizáveis, a 
sua  activação  a partir da  tabela  é de  interesse 
praticamente nulo. Ver Transform. 

• Object: A secção Object agrupa as  funções que 
lhe  permitem  duplicar,  eliminar  e  juntar  dois 
objectos. Mais  uma  vez,  sendo  acções  básicas 
com  combinações  de  teclas  associadas,  a  sua 
activação a partir da tabela é de pouco interesse 
para  além  dos  primeiros  tempos  de  contacto 
com o Blender. Ver Duplicate, Delete, e Join. 

• Shading:  A  secção  Shading  agrupa  os  botões 
que permitem activar as funções Shade Smooth 
e Shade Flat. Em modo objecto, este é o único 
menu  onde  estas  funções,  que  não  têm  teclas 
associadas, podem ser activadas. Ver Módulo 2. 

 

 

Figura 1.121 

 

Figura 1.122 

 

Figura 1.123 
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12.3. Operator. 
No  painel  operator  é  mostrada  a  última  operação 
efectuada sobre o objecto activo.  

A  figura  1.124  mostra  o  conteúdo  da  tabela  após  a 
realização de uma operação de translação. 

Posteriormente à realização da operação, o painel pode 
ser  utilizado  para  correcção  da  acção  efectuada, 
editando as caixas presentes. 

Note  que  qualquer  alteração  da  informação  presente 
não  se  traduz  numa  nova  operação  efectuada  sobre  o 
objecto  activo,  mas  sim  numa  alteração  das 
características da última operação efectuada. 

 

Figura 1.124 
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13. Tabela de Propriedades. 
 

 

 

 

 

 

 

 

 

 

 

 

 

Pressionando  [N]  mostra/esconde  a  tabela  de 
propriedades na zona à direita da janela 3D. 

A  tabela  de  propriedades  é  constituída  por  diversos 
painéis em que se expõem as propriedades dos diversos 
objectos  existentes  em  cena.  Analisaremos  em  detalhe 
cada um dos painéis quando for julgado pertinente. 

13.1. Item 
O painel Item mostra o nome do objecto activo, podendo 
a  respectiva  caixa  ser  editada,  alterando‐se  assim  o 
nome do objecto. 

Nota:  Na  actual  versão  (r29833)  o  painel  item  não  se 
encontra no topo da tabela de propriedades. Se desejar 
alterar  a  posição  de  um  qualquer  painel,  seleccione  a 
zona triangular tracejada no seu topo direito e arraste o 
painel para a posição pretendida. 

13.2. Transform 
No  painel  Transform  pode  proceder  a  uma  translação, 
incrementando  ou  decrementando  as  coordenadas  da 
posição da origem do objecto, pressionando os pequenos 
cursores  que  se  encontram  à  direita  e  à  esquerda  das 
caixas correspondentes a cada um dos eixos. 

 

 

 

 

Figura 1.125 
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Procedendo de modo  idêntico pode  fazer  a  rotação do 
objecto em torno de cada um dos eixos coordenados, ou 
fazer o seu escalamento. 

Pode  escrever  directamente  o  valor  da  translação, 
rotação, ou  factor de escalamento que deseja efectuar, 
editando a caixa conveniente. Para  isso pressione [MLB] 
com o cursor do rato sobre a célula desejada. 

Pressionando  o  botão  com  a  imagem  do  cadeado,  à 
esquerda  de  cada  caixa,  inibe  qualquer  alteração  da 
característica correspondente à caixa, feita por qualquer 
acção exterior a este painel. Ainda assim, a característica 
continua a poder ser alterada por acção directa sobre a 
caixa do painel. 

O  painel  inclui  ainda  um  conjunto  de  caixas  editáveis 
relativas às dimensões do objecto segundo cada um dos 
eixos coordenados. As alterações feitas nestas caixas têm 
correspondência  imediata  nas  caixas  relativas  ao 
escalamento e vice versa. 

13.3.Transf. Orientations. 
No  painel  Transform  Oientations,  figura  1.126,    pode 
definir  um  sistema  de  eixos  personalizado, 
correspondente  ao  sistema  de  eixos  local  do  objecto  
cujo nome é especificado. 

Posteriormente,  este  sistema  de  eixos  pode  ser 
seleccionado para orientar as transformações a efectuar 
sobre um qualquer outro objecto.  

13.4. View 
No painel View, figura 1.127, para além de algumas das 
características da câmara, de que falaremos mais tarde, é 
possível alterar o posicionamento do cursor 3D. 

13.5. Display 
No  painel  Display,  figura  1.128,  é  possível  alterar 
algumas  das  características  da  janela  3D, 
nomeadamente,  a  visibilidade  da  grelha,  dos  eixos 
coordenados,  o  número  de  linhas,  o  espaçamento  e  o 
número de subdivisões da grelha da janela 3D; o Método 
de  Sombreamento  utilizado  na  representação  dos 
objectos  na  janela  3D;  e  a  comutação  da  partição  da 
janela em Quad View.  

 

Figura 1.126 

 

Figura 1.127  

 

Figura 1.128 
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14. Inserção de Malhas 
Elementares. 
 

 

 

 

 

 

 

14.1. Malhas elementares. 
O  Blender  tem  10  objectos  elementares  associados  a 
Malhas  (Meshes),  isto é, descritos por um  conjunto de 
vértices e arestas, figura 1.129: 

• plano; 
• cubo;  
• círculo; 
• esfera  tipo UVsphere; 
• esfera tipo IcoSphere; 
• cilindro; 
• cone; 
• grelha; 
• cabeça de macaco (Suze); 
• toróide. 
 

 

Figura 1.129 
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14.2. Inserção de malhas elementares. 
Para  inserir  uma  das  malhas  elementares  seleccione 
(Add)  na  janela  Info,  e,  do  submenu  apresentado, 
seleccione  (Add  Mesh)  e  a  malha  pretendida,  figura 
1.130.  

   

Pode  também  ter  acesso  a  este  menu  pressionando 
[Shift]+[A]. 

O  objecto  (a  sua  origem)  é  inserido  no  ponto  onde  se 
encontra  o  Cursor  3D,  representado  pelo  pequeno 
círculo branco e vermelho, figura 1.133. 

Note que é completamente impossível perceber onde se 
encontra o curso no espaço 3D sem ter acesso às 3 vistas 
(Top, Side e Front). Para mudar a posição do cursor 3D, 
coloque o cursor do rato no ponto desejado e pressione 
[MLB]. 

Se pretender posicionar o curso 3D com precisão active a 
tabela  de  propriedades,  [N],  e  insira  as  coordenadas 
pretendidas nas respectivas caixas do painel View, figura 
1.131. 

Quando um novo objecto é inserido o Blender atribui‐lhe 
um  nome  padrão  (ex:  Cube,  Cube.001,  etc.).  É  boa 
prática  alterar  esse  nome  para  outro  com  maior 
significado na cena em desenvolvimento.  

Para  alterar  o  nome  de  um  objecto  active  a  tabela  de 
propriedades, [N], e edite a caixa correspondente, figura 
1.132. 

Para alguns dos objectos pode ser pertinente a alteração, 
a quando da criação, dos seus parâmetros característicos 
padrão. 

A  figura  1.133,  mostra  uma  UVSphere  com  os 
parâmetros padrão, nomeadamente, 32 segmentos e 16 
anéis, e uma UVSphere com 16 segmentos e 6 anéis. 

Para alterar as características da malha a quando da sua 
criação  active  a  tabela de operadores,  [T],  e, no painel 
operator, proceda às alterações desejadas. 

 

Figura 1.130 

 

Figura 1.131 

 

Figura 1.132 

 

Figura 1.133 
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14.2.1. Plane. [ bpy.ops.mesh.primitive_plane_add()]. 
Após a  inserção de uma malha tipo Plane pode alterar a 
posição do  seu  centro  (Location), e o alinhamento  com 
os  planos  coordenados  (Rotation)  ou  com  o  viewport 
(Align to View), figura 1.134. 

 

 

 

Figura 1.134 

14.2.2. Grid. [bpy.ops.mesh.primitive_grid_add()]. 
Após a  inserção de uma malha  tipo Grid pode alterar a 
posição do seu centro (Location), o alinhamento com os 
planos coordenados (Rotation) ou com o viewport (Align 
to  View),  o  número  de  vértices  em  cada  uma  das 
direcções  ortogonais  (X  Subdivisions  e  Y  Subdivisions),  
com valor padrão 10,  e o comprimento dos lados (Size), 
com valor padrão 1.0, figura 1.135. 

 

 

 

 

 

 

 

 

Figura 1.135 
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14.2.3. Cube. [bpy.ops.mesh.primitive_cube_add()]. 
Após a  inserção de uma malha tipo Cube pode alterar a 
posição do  seu  centro  (Location), e o alinhamento  com 
os  planos  coordenados  (Rotation)  ou  com  o  viewport 
(Align to View), figura 1.136. 

 

 

 

Figura 1.136 

14.2.4. Cylinder. [bpy.ops.mesh.primitive_cylinder_add()]. 
Após a inserção de uma malha tipo Cylinder pode alterar 
a posição do  seu  centro  (Location), o alinhamento  com 
os  planos  coordenados  (Rotation)  ou  com  o  viewport 
(Align to View), o número de vértices em cada uma das 
base  (Vertices),  com  valor  padrão  32,  o  raio  (Radius), 
com valor padrão 1.0, a altura do cilindro  (Depth), com 
valor  padrão  1.0,  e  a  existência  ou  não  de  um  vértice 
central em cada uma das bases (Cap Ends), seleccionado 
na configuração padrão, figura 1.137. 

Na  figura  figura  1.137,  em  cima,  pode  ver  a  malha 
Cylinder  padrão  e,  em  baixo,  a malha  gerada  com  um 
valor 6 de Vertices. 

 

 

 

 

 

 

 

 

 Figura 1.137 
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14.2.5. Circle. [bpy.ops.mesh.primitive_circle_add()]. 
Após a inserção de uma malha tipo Circle pode alterar a 
posição do  seu  centro  (Location), e o alinhamento  com 
os  planos  coordenados  (Rotation)  ou  com  o  viewport 
(Align  to  View),  o  número  de  vértices  contidos  na 
circunferência  (Vertices),  valor  padrão  32,  o  raio 
(Radius),  valor  padrão  1.0,  e  pode  ainda  preencher  o 
interior  da  circunferência  activando  o  parâmetro  Fill,  
figura 1.138. 

 

 

 

 

 

 

 

 
 

Figura 1.138 

14.2.6. UV Sphere. [bpy.ops.mesh.primitive_uv_sphere_add()]. 

Após  a  inserção  de  uma  malha  tipo  UV  Sphere  pode 
alterar a posição do seu centro (Location), o alinhamento 
com  os  planos  coordenados  (Rotation)  ou  com  o 
viewport  (Align  to  View),  o  número  de  segmentos 
(Segments),  com  valor  padrão  32,  o  número  de  anéis 
(Rings), com valor padrão 16, e o raio (Radius), com valor 
padrão 1.0, figura 1.139. 

 

 

 Figura 1.139 
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14.2.7. Icosphere. [bpy.ops.mesh.primitive_ico_sphere_add()]. 
Após  a  inserção  de  uma  malha  tipo  Icosphere  pode 
alterar a posição do seu centro (Location), o alinhamento 
com  os  planos  coordenados  (Rotation)  ou  com  o 
viewport  (Align  to  View),  o  número  de  subdivisões 
(Subdivisions), com valor padrão 2, e o "raio" (Size), com 
valor padrão 1.0, figura 1.140. 

Para  além  da  icoesfera  padrão,  em  cima,  pode  ver  na 
figura 1.140 uma icoesfera com 3 subdivisões. 

 

 

 

 

 

 Figura 1.140

14.2.8. Cone. [bpy.ops.mesh.primitive_cone_add()]. 

Após a  inserção de uma malha tipo Cone pode alterar a 
posição do seu centro (Location), o alinhamento com os 
planos coordenados (Rotation) ou com o viewport (Align 
to View), o número de vértices da base  (Vertices), com 
valor padrão 32, o raio (Radius), com valor padrão 1.0, a 
altura  do  cone  (Depth),  com  valor  padrão  1.0,  e  a 
existência  ou  não  de  um  vértice  central  na  base  (Cap 
Ends), não  seleccionado na  configuração padrão,  figura 
1.141. 

Na figura 1.141 em cima pode ver a malha Cube padrão e 
em baixo a malha gerada com um valor 6 de Vertices. 

 

 

 

 

 

 
 

Figura 1.141 
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14.2.9. Monkey. [bpy.ops.mesh.primitive_monkey_add()]. 
Após a inserção de uma malha tipo Monkey pode alterar 
a posição do seu centro (Location), e o alinhamento com 
os  planos  coordenados  (Rotation)  ou  com  o  viewport 
(Align to View), figura 1.142. 

 

 

 

 

 
 

 
Figura 1.142

14.2.10. Torus. [bpy.ops.mesh.primitive_torus_add()] 
Após a inserção de uma malha tipo Torus pode alterar a 
posição do seu centro (Location), o alinhamento com os 
planos  coordenados  (Rotation),  o  número  de  vértices 
numa  secção  transversal  do  toróide  (Major  Segments), 
com valor padrão 32, o número de vértices numa secção 
longitudibal  do  toróide  (Minor  Segments),  com  valor 
padrão 12, figura 1.144. 

Na figura 1.144 pode ver, em cima, o toróide padrão, e, 
em baixo, um toróide de secção  longitudinal pentagonal 
(Major  Segments  igual  a  5)  e  secção  transversal 
octogonal (Minor Segments igual a 8). 

As  dimensões  do  toróide  podem  ser  definidas  de  dois 
diferentes modos: 

   

Figura 1.143  Figura 1.144 
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1. Na  configuração  padrão  o  toróide  é  definido 
pelos  parâmetros  Minor  Radius,  com  valor 
padrão 0.25, e Major Radius, com valor padrão 
1,  representados  na  figura  1.145, 
respectivamente em cima e em baixo. 

2. Alternativamente,  activando  o  parâmetro  Use 
Int+Ext  Controls,  o  toróide  tem  dimensões 
dependentes  dos  parâmetros  Exterior  Radius, 
com valor padrão 1.0, e Inside Radius, com vlor 
padrão 0.5, representados na figura 1.143. 

 

 

 

 

 
 

  Figura 1.145 
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