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M2. Modelação 1. 
1. Modo Edição. 
 

 

 

 

 

 

 

 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Tab]     

O Modo Objecto  (Object Mode) e o Modo Edição  (Edit 
Mode)  são  os  dois modos  básicos  de manipulação  de 
objectos na janela 3D. 

Em modo  objecto  temos  acesso  ao  objecto  como  um 
todo.  É  por  isso  o  modo  conveniente  para  fazer 
transformações  globais  do  objecto,  como  seja  uma 
translação, um escalamento, etc. 

Em modo edição temos acesso aos elementos da malha 
que constitui cada um dos objectos (tipo Mesh): os seus 
vértices, arestas e faces. É por isso o modo conveniente 
para fazer alterações à forma de cada objecto.  

A figura 2.1 mostra a representação na janela 3D de uma 
Icoesfera  em modo  edição  em  que  apenas  alguns  dos 
seus vértices estão seleccionados. 

 

Figura 2.1 
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Para  sair do modo objecto e entrar  ao modo edição, e 
vice‐versa, pressione [Tab].  

Para mudar de modo, pode também seleccionar a opção 
disponível  na  barra  da  janela  3D,  figura  2.2.  Falaremos 
dos  restantes  modos  de  trabalho  à  medida  que  a 
utilização de cada um deles se revelar necessário. 

Na  barra  da  janela  3D,  em modo  edição,  figura  2.3,  o 
menu  View  mantém‐se,  com  as  mesmas  opções.  Ver 
Módulo 1.  

Embora o menu Select se mantenha passa a  ter opções 
diferentes. Ver Menu Select. 

O menu Object dá lugar ao menu Mesh, Ver Menu Mesh.  

Os menus  de Modo de  Sombreamento  (1), Pivot  (2)  e 
Transformadores  (3),  figura  2.4,  mantêm‐se  com  as 
mesmas características. Ver Módulo 1. 

O  menu  Selecção  de  Layers  é  substituído  pelo  menu 
Modo  de  Selecção  (1)  de  elementos,  figura  2.5,  ver 
Modo de Selecção, a que se seguem os menus de Edição 
Proporcional  de  Vértices  (2),  ver  Módulo  3,  e  Snap 
During Transform (3), ver Módulo 3. 

 

 

 

 

 

 

 

 

Figura 2.2 

 

Figura 2.3 

 

Figura 2.4 

 

Figura 2.5 
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2. Tabela de Propriedades. 
 

 

 

 

 

 

 

 

Caso a Tabela de Propriedades não esteja visível à direita 
da janela 3D pressione [N]. 

Em  modo  edição  a  tabela  de  propriedades  tem  uma 
configuração  semelhante  à  apresentada  em  modo 
objecto, com um conjunto de painéis que se descrevem 
em seguida.  

 

 

 

 

 

 

 

 

 

 

 

2.1. Transform. 
No  painel  Transform,  e  caso  exista  apenas  um  vértice 
seleccionado,  são  indicadas  as  suas  coordenadas.  Caso 
exista mais do que um vértice seleccionado é indicado o 
valor médio de todas as coordenadas, figura 2.6. 

Caso exista uma aresta seleccionada é apresentada uma 
caixa correspondente ao parâmetro Crease, indicativo da 
percentagem de vinco (ou enrugamento) provocado pelo 
vértice,  ver Módulo 3  ‐ Edge Crease.  Se existir mais do 
que uma aresta seleccionada é apresentado nesta caixa o 
valor médio deste parâmetro, caso da figura 2.6. 

Todas  as  caixas  são  editáveis  pelos métodos  habituais, 
podendo  este  painel  ser  utilizado  para  alterar  as 
coordenadas  dos  elementos  da  malha  em  edição  e  o 
factor de enrugamento de cada uma das arestas. 

 

Figura 2.6 
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2.2. Background Images. 
O painel Background Images, figura 2.7, é utilizado para 
mapear imagens na janela 3D. Ver Background Images. 

   

Figura 2.7 

2.3. Grease Pencil. 
O painel Grease Pencil,  figura 2.8, está  associado  a um 
conjunto de procedimentos descritos no Módulo ?. 

 

 
 

Figura 2.8 

2.4. Transform Orientations/ View / Display / Item. 
Os paineis Transform Orientations, View, Display e Item 
em  modo  edição  são  em  tudo  idênticos  aos 
apresentados em modo objecto. Ver Módulo 1. 

2.5. Mesh Display. 
No painel Mesh Display, que pode ver na figura 2.11 com 
as  opções  padrão,  é  possível  alterar  algumas  das 
características de representação dos elementos da malha 
em edição. 

Os  dois  primeiros  dizem  respeito  ao  modo  como  as 
arestas e as faces seleccionadas são representadas: 

• Edges:  Quando  em  modo  de  representação 
vértice,  comuta  a  representação  a  laranja  das 
arestas seleccionadas, figura 2.9. 

• Faces:  Comuta  a  representação  a  laranja  das 
faces seleccionadas, figura 2.10. 

As  quatro  seguintes  estão  associadas  à  alteração  da 
forma  de    representação  das  arestas  em  resultado  da 
associação  à  malha  de  Modificadores  diversos,  ver 
Módulo 3: 

 

 

Figura 2.9 

 

Figura 2.10 
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• Creases: Ver Módulo 3 ‐ modificador Subdivision 
Surface. 

• Bevel  Weights:  Ver  Módulo  3  ‐  modificador 
Bevel. 

• Seams: Ver Módulo ??‐Texturização UV. 
• Sharp: Ver Módulo 3 ‐ modificador EdgeSplit. 

A secção Normals permite comutar a representação das 
normais às superfícies e vértices.  Ver Normais. 

A secção Numerics permite comutar junto aos elementos 
da  malha,  quando  seleccionados,  a  indicação  do 
comprimento  das  arestas  (em  UB),  Edge  Length,  do 
ângulo entre arestas (em graus), Edge Angles, e da área 
das faces (em UB2), Face Area, figura 2.12. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figura 2.11 

 

Figura 2.12 
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3. Tabela de Operadores. 
 

 

 

 

 

 

 

 

 

 

Caso  a  Tabela  de  Operadores  não  esteja  visível  à 
esquerda da janela 3D pressione [T]. 

Em  modo  edição  a  tabela  de  opeardores  tem  uma 
configuração diferente da apresentada em modo objecto 
com  um  conjunto  de  painéis  que  se  descrevem  em 
seguida.  

Entre  os  painéis  Tools  Shelf  e  Operator,  com  funções 
idênticas às descritas no Módulo 1 para a  configuração 
da tabela em modo objecto, temos agora o painel Mesh 
Tools a substituir o painel Object Tools. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.1. Mesh Tools. 
No  painel  Mesh  Tools,  estão  presentes  algumas  das 
funções  mais  utilizadas  na  edição  da  malha  de  um 
objecto. 

O painel está dividido em várias secções  funcionais que 
em seguida se descrevem. 

• Tranform:  Na  secção  Tranform,  figura  2.13,  
estão  agrupadas  algumas  das  funções  de 
transformação  dos  elementos  da  malha  em 
edição. Ver Transformação. 

• Deform: Na  secção  Deform,  figura  2.13,  estão 
agrupadas algumas das  funções de deformação 
da malha em edição. Ver Modificação. 

 

Figura 2.13 
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• Add:  Na  secção  Add,  figura  2.14,  estão 
agrupadas  algumas  das  funções  de  criação  de 
novos  elementos  na  malha  em  edição.  Ver 
Criação. 

• Remove: Na secção Remove,  figura 2.13, estão 
agrupadas  algumas  das  funções  de  eliminação 
de  elementos  na  malha  em  edição.  Ver 
Remoção. 

• Normals: Na secção Normals, figura 2.13, estão 
agrupadas  as  funções  de  manipulação  do 
posicionamento  das  normais  às  superfícies  e 
vértices da malha em edição. Ver Normais. 

 

 

 

 

• UV  Mapping:  Na  secção  UV  Mapping,  figura 
2.14,  estão  agrupadas  algumas das  funções de 
alteração  das  características  dos  elementos  da 
malha  em  edição  com  relevância  no 
mapeamento  UV  de  texturas  sobre  o  objecto 
em edição. Ver Módulo ?? ‐ Texturização UV. 

• As secções Shading, Repeat e Grease Pencil são 
comuns  ao  painel  em  modo  objecto.  ver 
Shading, Repeat e Grease Pencil. 

 

 

 

 

 

 

 

 

Figura 2.14 

 

Figura 2.15 
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3.2. Normals. 
3.2.1. Flip Normals. [bpy.ops.mesh.flip_normals()]. 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [W]   
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Flip  Normals  pode  ser  evocada  a  partir  da  tabela  de 
operadores, do menu  Specials,  [W], e ainda a partir da 
barra  da  janela  3D,  [Mesh>Normals>Flip  Normals], 
figura 2.16. 

Flip Normals inverte o sentido das normais às superfícies 
seleccionadas, figura 2.17. 

Na  configuração  padrão  as  normais  às  superfícies  não 
estão visíveis. Para as tornais visíveis seleccione Face no 
painel Mesh  Display  da  tabela  de  propriedades,  figura 
2.18.  

Imediatamente  abaixo,  na  caixa  Normal  Size,  pode 
especificar  a  dimensão  dos  pequenos  segmentos  azuis 
que representam cada uma das normais. 

 

 

 

 

Figura 2.16 

 

Figura 2.17 

 

Figura 2.18 

3.2.2. Recalculate Normals. [bpy.ops.mesh.normals_make_consistent()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[N]     

Recalculate Normals pode ser evocada a partir da tabela 
de  operadores  e  a  partir  da  barra  da  janela  3D, 
[Mesh>Normals>Recalculate  Outside  (Inside)].  figura 
2.19. 

 

Em  modo  edição,  pressionando  [Ctrl]+[N]  acciona  a 
função Recalculate Normals (Outside). 

Recalculate  Normals  calcula  automaticamente  o 
posicionamento das normais a cada uma das superfícies. 

 

Figura 2.19 

 

Figura 2.20 
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O  posicionamento  relativo  da  normal  às  superfícies  é 
extremamente  importante no processo de renderização, 
já que desse posicionamento depende o modo  como  a 
forma do objecto é interpretada pelo renderizador. 

É comum durante o processo de criação de um modelo 
complexo que algumas das normais às superfícies fiquem 
dirigidas  no  sentido  errado,  levando  o  renderizador  a 
"errar"  quanto  à  decisão  de  se  determinada  superfície 
pertence ao interior ou ao exterior do objecto. 

Normalmente, é desejável que as normais apontem para 
o exterior da malha em edição. Caso seja desejável que 
elas  apontem  para  o  seu  interior,  deve  ser  evocada  a 
função Recalculate Inside (combinação [Shift]+[Ctrl]+[N]), 
ou activado o parâmetro Inside na tabela de operadores, 
figura 2.20, após a activação de Recalculate Outside. 

Observe  a  figura  2.21.  Em  cima  pode  ver  o  cubo  em 
modo edição. Note que as normais dos quatro quadrados 
centrais de cada uma das faces foram invertidas. 

Em baixo pode ver o resultado da renderização. Note, ao 
centro,  que  o  incorrecto  posicionamento  das  normais 
pode  ser  facilmente  detectado  em  modo  de 
sombreamento texturizado. 

 

 

 

Figura 2.21 
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3.3. Shading.   

 
Embora as funções sejam diferentes em modo objecto e 
modo edição, têm a mesma funcionalidade.   

 

3.3.1. Shade Smooth. [bpy.ops.mesh.faces_shade_ smooth()]. 

3.3.2. Shade Flat. [bpy.ops.mesh.faces_shade_flat()]. 

71 
 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [W] 
[Ctrl]+[F]   

 
Shade  Smooth  pode  ser  evocada  a  partir  da  tabela  de 
operadores,  do menu  Specials,  [W],  e  ainda  do menu 
Face Special, [Ctrl]+[F], figura 2.22 e figura 2.23. 

Figura 2.22 

Shade  Smooth  altera  o  modo  como  o  objecto,  ou 
conjunto  de  faces  seleccionado,  é  renderizado,  dando‐
lhe um aspecto mais suave, como se o número de faces 
do objecto fosse maior, figura  2.24. 

Note  que  não  é  feita  qualquer  alteração  à  malha  do 
objecto. Não confundir com a função Smooth Vertex.  

A função Shade Flat reverte a acção de Shade Smooth. 

 

 

 

 

 

 

 

 

 

 

 

Figura 2.23 

Figura 2.24     
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4. Menu Select. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
O menu Select, da barra da janela 3D, figura, figura 2.25, 
reúne  todas  as  opções  disponíveis  de  selecção  de 
elementos de uma malha.  

Na  secção  Selecção Elementar, descrevem‐se os modos 
de  selecção  mais  frequentemente  utilizados, 
correspondentes  às  funções  assinaladas  a  vermelho  na 
figura 2.25.  

Embora presentes no menu Select, e, portanto, podendo 
ser seleccionadas por essa via, a frequência de utilização 
destas  funções  torna  indispensável  a memorização  das 
suas teclas de atalho. 

Na  secção  Selecção  de  Contornos,  descrevem‐se  as 
funções assinaladas a verde na figura 2.25. 

São  todas  elas  funções  de  selecção  baseada  em 
Contornos, isto é, conjuntos contíguos de aresta ou faces 
(não  constituindo  necessariamente  um  percurso 
fechado). 

A  sua  utilização  também  é  bastante  frequente  e  o 
domínio  da  sua  utilização  é  imprescindível  a  um  bom 
ritmo de trabalho de modelação. 

Finalmente na secção Selecção Avançada são descritas as 
funções assinaladas a azul na figura 2.25. 

São  métodos  de  selecção  muito  específicos  de  muito 
menor  frequência  de  utilização.  O  domínio  da  sua 
utilização não é relevante mas, obviamente, a ignorância 
da  sua  existência  conduzirá  a  práticas  pontuais  de 
modelação  que  se  tornarão  desnecessariamente 
demoradas. 

 

 

 

Figura 2.25 
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5. Menu Mesh. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
O menu Mesh, figura 2.26, reúne o conjunto de funções 
de  criação,  remoção,  transformação  e  modificação  de 
elementos da malha de um objecto. 

• Show/Hide:  Esconde  os  elementos 
seleccionados,  ou  revela  os  elementos 
previamente escondidos. Ver Show/Hide. 

• Proportional  Editing  Falloff  e  Proportional 
Editing.  Funções  associadas  à  edição 
proporcional de vértices. Ver Módulo 3. 

• Automerge  Editing:  Quando  seleccionado, 
funde automaticamente num só os vértices que 
em  função de  transformações ou modificações 
tenham os mesmo valores de coordenadas. Ver 
Remoção.  

• Normal: Funções associadas à manipulação das 
normais às faces e vértices. Ver Normais. 

• Faces:  Funções  associadas  à  manipulação  de 
faces. Ver Menu Face Specials. 

• Edges:  Funções  associadas  à  manipulação  de 
arestas. Ver Menu Edges Specials. 

• Vertices: Funções associadas à manipulação de 
vértices. Ver Menu Vertex Specials. 

• Delete: Elimina os elementos seleccionados. Ver 
Remoção. 

• Add  Duplicate:  Cria  uma  cópia  dos  elementos 
seleccionados.  Extrude  Individual  e  Extrude 
Region: Cria elementos ligados. Ver Criação. 

• UV  Unwrap:  Funções  associadas  ao 
mapeamento de texturas. Ver Módulo ?.  

• Snap: Funções associadas ao  reposicionamento 
dos elementos selecionados e do cursor 3D. Ver 
Módulo 1. 

• Mirror:  Funções  associadas  à  reflexão  de 
elementos. Ver Mirror. 

• Transform:  Funções  associadas  a 
transformações  sobre  os  elementos  da malha. 
Ver Transformação. 

• Undo: e Redo: Desfaz a última acção executada 
e refaz uma acção previamente desfeita. 

 

Figura 2.26 
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5.1. Undo/Redo. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[Z] 
[Shif]+[Ctrl]+[Z]     

Undo/Redo pode ser evocada a partir da barra da janela 
3D, [Mesh>...], figura 2.27. 

 

Quer em modo edição quer em modo objecto, pressione 
[Ctrl]+[Z] para desfazer a última acção (Undo). 

 

Quer em modo edição quer em modo objecto, pressione 
[Shif]+[Ctrl]+[Z]  para  refazer  uma  acção  desfeita  com 
Undo.  

Tenha  em  atenção  que  o  registo  das  acções  realizadas 
durante  uma  sessão  de  trabalho  são  armazenadas  em 
memória, pelo que, para objectos muito complexos só a 
memória  necessária  para  estes  registo  pode  tomar 
proporções proibitivas. Em cada instante é dada na barra 
da  janela  info a  informação sobre a memória que está a 
ser utilizada, figura 2.28.  

O  valor  padrão  do  número  de  passos  Undo  é  32, 
podendo  variar  entre  1  e  64.  Para  alterar  o  seu  valor, 
seleccione  [File>User  Preferences]  na  janela  info  e,  no 
painel  Editing,  proceda  às  alterações  no  campo  Undo, 
figura 2.29. 

As  acções  em modo  edição  são  registadas  apenas para 
um  objecto  de  cada  vez,  isto  é,  para  um  dado  objecto 
pode entrar e  sair de modo edição  sem que  se perca o 
registos  das  acções  efectuadas.  No  entanto,  se  outro 
objecto  for  editado  é  eliminado  o  registo  referente  ao 
objecto anterior. 

 

 

 

 

 

Figura 2.27 

 

Figura 2.28 

 

Figura 2.29 

     



  CGAV 1 ‐ MODELAÇÃO 1 
 

6. Menu Specials. 
 

 

 

 

 

 

 

 

Em  modo  edição,  pressionando  [W]  é  apresentado  o 
menu Specials, figura 6.17. 

No  menu  Specials  encontram‐se  reunidas  muitas  das 
funcionalidades  mais  frequentemente  utilizadas  em 
modelação,  e que  se  encontram dispersas por diversos 
menus e painéis.  

Cada  uma  das  funções  pode  ser  activada  pressionando 
[W]>[#] em que #  corresponde à posição da  função no 
menu. 

1. Subdivide:  Dividide  em  duas  cada  uma  aresta 
seleccionada. Ver Criação. 

2. Subdivide Smooth: Idêntico a Subdivide, mas os 
novos  vértices  são  desviados  em  direcção  ao 
baricentro dos vértices ligados. Ver Criação. 

3. Merge:  Reduz  a  um  só  todos  os  vértices 
seleccionados. Ver Remoção. 

4. Remove  Doubles:  Funde  todos  os  vértices 
seleccionados cuja distância relativa seja inferior 
a um limiar. Ver Remoção. 

5. Hide: Esconde os elementos seleccionados. Ver 
Show/Hide. 

6. Reveal:  Revela  os  elementos  previamente 
escondidos. Ver Show/Hide. 

7. Select  Inverse:  Comuta  o  conjunto  de 
objectos/elementos  seleccionados  e  não 
seleccionados. Ver Selecção Elementar. 

8. Flip Normals:  Inverte o  sentido das normais às 
superfícies seleccionadas. Ver Normais. 

9. Smooth: Suaviza a malha, ou a parte da malha 
seleccionada, movendo os vértices em direcção 
ao  baricentro  das  vértices  ligados.  Ver 
Modificação. 

• Shade Smooth/Shade Flat: Altera o modo como 
o objecto, ou conjunto de faces seleccionado, é 
renderizado. Ver Shading. 

• Blend From Shape e Shape Propagate: Funções 
associadas à utilização de Shape Keys. Ver CGAV 
2 ‐ Modulo ?? ‐ Shape keys. 

• Select Vertex Path: Seleccionados dois vértices, 
procura  o  contorno mais  curto  entre  eles. Ver 
Selecção de Contornos. 

 

Figura 2.30 
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6.1. Hide. [bpy.ops.mesh.hide()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [H]  [W]   

Hide pode ser evocada a partir do menu Special, [W], e a 
partir  da  barra  da  Janela  3D,  [Mesh>Show/ Hide>Hide 
Selected], figura 2.31. 

 

Em modo edição, pode evocar Hide pressionando [H]. 

Hide  esconde  os  elementos  da  malha  seleccionados, 
figura  2.32.  Após  a  operação  pode  comutar  entre  os 
vértices  visíveis  e  não  visíveis  (seleccionados  e  não 
seleccionados)  na  tabela  de  operadores, 
activando/desactivando Unselected, figura 2.33. 

Esta  funcionalidade  é  extremamente  útil  em  modelos 
muito  complexos,  quando  se  pretende  ter  uma  visão 
desimpedida  de  zonas  onde  a  densidade  de  vértices  é 
muito elevada. 

 

Em modo  edição,  pressionando  [Shift]+[H]  esconde  os 
vértices não seleccionados. 

 

Figura 2.31 

 

Figura 2.32 

 

Figura 2.33 

 

 

6.2. Reveal. [bpy.ops.mesh.reveal()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[H]  [W]   

Revel pode ser evocada a partir do menu Special, [W], e 
a partir da barra da Janela 3D, [Mesh>Show/Hide>Show 
Hidden], figura 2.34. 

 

Em  modo  edição,  pode  evocar  a  função  Reveal 
pressionando [Alt]+[H]. 

Reveal expõe os vértices que previamente  tenham  sido 
escondidos com Hide. 

 

Figura 2.34 
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7. Menu Vertex Specials. 
 

 

 

 

 

 

 

 

 

 

 

 

Em modo edição, pressionando [Crtl]+[V] é apresentado 
no ecrã o menu Vertex Specials, figura 2.35. 

No menu Vertex Specials encontram‐se reunidas algumas 
das  operações  sobre  vértices  mais  frequentemente 
utilizadas. Muitas delas podem ser encontradas no menu 
Specials e na Tabela de Operadores. 

Os  operadores  aqui  disponíveis  correspondem 
exactamente  ao  que  podem  ser  acedidos  a  partir  da 
barra da janela 3D, [Mesh>Vertices]. 

Cada  uma  das  funções  pode  ser  activada  pressionando 
[Ctrl]+[V]>[#] em que # corresponde à posição da função 
no menu. 

1. Merge:  Reduz  a  um  só  todos  os  vértices 
seleccionados. Ver Remoção. 

2. Rip:  Rasga  a malha  ao  longo  das  arestas  que 
interligam  os  vértices  seleccionados.  Ver 
Modificação. 

3. Split:  Duplica  os  elementos  seleccionados  e 
separa‐os dos restantes. Ver Modificação. 

4. Separate:  Separa  a malha  em  duas  com  base 
nos elementos seleccionados. Ver Modificação. 

 

Figura 2.35 

 

 

 

 

 

V 4.0  77 
 



  CGAV 1 ‐ MODELAÇÃO 1 
 

5. Smooth: Suaviza a malha, ou a parte da malha 
seleccionada, movendo os vértices em direcção 
ao  baricentro  das  vértices  ligados.  Ver 
Modificação. 

6. Remove  Doubles:  Funde  todos  os  vértices 
seleccionados cuja distância relativa seja inferior 
a um limiar. Ver Remoção. 

7. Select Vertex Path: Seleccionados dois vértices, 
procura  o  contorno mais  curto  entre  eles. Ver 
Selecção de Contornos. 

• Blend From Shape e Shape Propagate: Funções 
associadas à utilização de Shape Keys. Ver CGAV 
2 ‐ Modulo ?? ‐ Shape keys. 

• Blend Vertex Group: Não  faz  nada  (Ainda  não 
existe a função ?). 

• Vertex Groups: Associa os vértice seleccionados 
num  novo  grupo.  Ver  Modulo  ??  ‐  Vertex 
Groups. 

• Hooks:  Funções  associadas  à  utilização  de 
Hooks. Ver CGAV 2 ‐ Modulo ?? ‐ Hooks. 

 

 

 

 

  Specials  Tabela de 
Operadores 

Merge    

Rip    

Split    

Separate    

Smooth Vertex    

Remove Doubles    

Select Vertex Path    

Blend From Shape    

Blend Vertex Group    

Shape Propagate    

Vertex Groups    

Hooks    
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8. Menu Edge Specials. 
 

 

 

 

 

 

 

 

  

Em modo edição, pressionando [Crtl]+[E] é apresentado 
no ecrã o menu Edge Specials, figura 2.36. 

No menu Edge Specials encontram‐se  reunidas algumas 
das  operações  sobre  arestas  mais  frequentemente 
utilizadas.  Muitas  delas  podem  ser  encontradas  na 
Tabela de Operadores. 

Os  operadores  aqui  disponíveis  correspondem 
exactamente  ao  que  podem  ser  acedidos  a  partir  da 
barra da janela 3D, [Mesh>Edges].  

Para além disso, os 4 últimos, Edge Loop, etc. são ainda 
acessíveis a partir da barra da janela 3D, [Select>...]. 

Cada  uma  das  funções  pode  ser  activada  pressionando 
[Ctrl]+[E]>[#] em que # corresponde à posição da função 
no menu. 

1. Make  Edge/Face:  Cria  uma  aresta  entre  dois 
vértice seleccionados, ou uma face entre três ou 
quatro vértice seleccionados. Ver Criação. 

2. Subdivide:  Dividide  em  duas  cada  uma  aresta 
seleccionada. Ver Criação. 

3. Mark Seam: Função associada ao mapeamento 
de texturas. Ver Módulo ??.  

4. Clear Seam: Função associada ao mapeamento 
de texturas. Ver Módulo ??.  

 

 

 Figura 2.36 
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5. Mark  Sharp:  Assinala  as  aresta  seleccionadas 
como constituindo arestas vivas entre faces. Ver 
Mark Sharp. 

6. Clear  Sharp:  Elimina  a  informação Mark  Sharp 
sobre a aresta selecconada. Ver Clear Sharp.  

7. Rotate  Edge  CW:  Roda  o  vértice  seleccionado 
no  sentido  dos  ponteiro  do  relógio.  Ver  Ver 
Modificação. 

8. Rotate Edge CCW: Roda o vértice  seleccionado 
no sentido directo. Ver Modificação. 

9. Edge  Slide:  Permite  deslocar  uma  aresta  ao 
longo das faces adjacentes. Ver Modificação. 

• Edge  Crease:  Permite  especificar  o  factor  de 
enrugamento da aresta  seleccionada. Ver Edge 
Crease. 

• Edge  Loop:  Dada  uma  ou  mais  arestas 
seleccionadas, selecciona um conjunto contíguo 
de arestas que contenha a aresta seleccionada. 
Ver Selecção de Contornos. 

• Edge  Ring:  Dada  uma  ou  mais  arestas 
seleccionadas, selecciona um conjunto contíguo 
de faces. Ver Selecção de Contornos. 

• Loop  to  Region:  Com  base  no  conjunto  de 
arestas seleccionadas, divide a malhas em duas 
partes  e  selecciona  as  faces  da  menor  das 
partes. Ver Selecção de Contornos.  

• Region  to  Loop:  Executa  a  operação  contrária 
de  Loop  to Region, deixando activas as arestas 
correspondentes ao contorno (ou contornos) de 
um  conjunto  de  faces  seleccionadas.  Selecção 
de Contornos. 

  Specials  Tabela de 
Operadores 

Make Edge/Face    

Subdivide    

Mark Seam    

Clear Seam    

Mark Sharp    

Clear Sharp    

Rotate Edge CW    

Rotate Edge CCW    

Edge Slide    

Edge Crease    

  3DWindow 
Select   

Edge Loop    

Edge Ring    

Loop to Region    

Region to Loop    
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9. Menu Face Specials. 
 

 

 

 

 

 

 

Em modo edição, pressionando [Crtl]+[F] é apresentado 
no ecrã o menu Face Specials, figura 2.37. 

No menu  Face  Specials encontram‐se  reunidas algumas 
das  operações  sobre  faces  mais  frequentemente 
utilizadas. 

Os  operadores  aqui  disponíveis  correspondem 
exactamente  ao  que  podem  ser  acedidos  a  partir  da 
barra da janela 3D, [Mesh>Faces]. 

Cada  uma  das  funções  pode  ser  activada  pressionando 
[Ctrl]+[F]>[#] em que # corresponde à posição da função 
no menu. 

1. Make  Edge/Face:  Cria  uma  aresta  entre  dois 
vértice seleccionados, ou uma face entre três ou 
quatro vértice seleccionados. Ver Criação. 

2. Fill: Dado um conjunto de vértices seleccionado, 
insere várias faces em simultâneo. Ver Criação. 

3. Beautify  Fill:  Converter  um  conjunto  de  faces 
seleccionadas num padrão mais ordenado. Ver 
Criação. 

4. Solidify: Dá espessura a objectos de superfícies 
finas. Ver Criação. 

5. Quads  to Tris: Converte as  faces  seleccionadas 
quadrangulares  em  faces  triangulares.  Ver 
Criação. 

6. Tris  to Quads: Converte as  faces  seleccionadas 
triangulares  em  faces  quadrangulares.  Ver 
Criação. 

7. Edge  Flip:  Alterar  a  posição  das  arestas 
seleccionadas. Ver Criação. 

8. Shade Smooth: Altera o modo como o objecto, 
ou  conjunto  de  faces  seleccionado,  é 
renderizado. Ver Shading. 

9. Shade Flat: Altera o modo  como o objecto, ou 
conjunto de  faces  seleccionado, é  renderizado. 
Ver Shading. 

• Rotate  Edge  CW:  Roda  o  vértice  seleccionado 
no  sentido  dos  ponteiro  do  relógio.  Ver  Ver 
Modificação. 

• Rotate  UVs;  Rotate  Colors; Mirror  Color:  Ver 
Módulo ?? ‐ Mapeamento UV. 

 

Figura 2.37 
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10. Background Images. 
 

 

 
 

 

 

 

Figura 2.38 

Tabela de 
Propriedades  Shortcut  Menu  Barra 3D 

       

É  comum  o  processo  de  modelação  recorrer  à 
observação  de  imagens  reais,  e,  nomeadamente  a 
esquemas ou projecções dos objectos 3D sobre os planos 
coordenados (vista frontal, de topo e lateral), designados 
comummente por Blueprints. 

Para  inserir uma  imagem de  fundo,  com o objectivo de 
criar  um  modelo  a  partir  da  sua  observação,  active 
Background  Images  no  respectivo  painel  da  tabela  de 
propriedades, figura 2.38, pressione o botão Add Image, 
e de seguida o pequeno triângulo à esquerda de Not Set, 
na nova configuração do painel, figura 2.39. 

Pressione  o  botão  Open,  figura  2.39,  e  seleccione  a 
imagem. Na configuração padrão a imagem é projectada 
em  todos  os  planos  coordenados.  Para  restringir  a  sua 
projecção  seleccione  o  plano  específico  no menu  Axis, 
figura 2.40. 

Note  que  as  imagens  só  são  visíveis  quando  em 
projecção ortográfica 

Na nova configuração do painel Background Images após 
a selecção da imagem, figura 2.41, pode controlar o grau 
de  transparência  da  imagem,  e  proceder  ao  seu 
escalamento e reposicionamento relativo da origem. 

Pressionando  o  botão  Add  Image  e  repetindo  os 
procedimentos pode colocar imagens diferentes em cada 
um dos planos, e ainda sobre a vista da câmara. 

 

Figura 2.39 

 

Figura 2.40 

 

Figura 2.41 
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11. Selecção Elementar. 
 

 

 

 

 

 

 

 

 

11.1. Modo de Selecção. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[Tab]     

Entre  em  modo  edição.  Note  que  surgiu  na  barra  da 
janela 3D o menu Modo de Selecção, figura 2.42.  

Neste pode seleccionar que  tipo de elemento da malha 
dos objectos deseja editar: vértices, arestas, ou faces. 

 

Em  modo  edição,  pressionado  [Ctrl]+[Tab],  pode 
modificar o modo de selecção de elementos a partir do 
menu que surge no ecrã, figura 2.43. 

Na  figura  2.44  pode  ver  um  cubo  representado,  da 
esquerda para a direita, em Modo Selecção Vertex, Edge 
e Face. 

Pressionando  [Shift]+[MLB]  sobre  os  botões  do  menu 
modo  de  selecção  pode  seleccionar  mais  do  que  um 
modo de selecção em simultâneo. 

 

 

 

Figura 2.42 

 

Figura 2.43 

 

Figura 2.44 

 

 

V 4.0  83 
 



  CGAV 1 ‐ MODELAÇÃO 1 
 

Pressionando  o  botão  imediatamente  a  seguir,  figura 
2.45,  o  objecto  em  edição  comuta  entre  uma 
representação  translúcida  e  uma  representação  opaca, 
figura 2.46. 

Quando  a  representação  é  opaca,  qualquer  selecção 
incide apenas sobre os elementos visíveis. 

Note que se inserir um objecto em modo edição, a malha 
inserida  é  fundida  na  já  existente  formando  um  só 
objecto, o que, normalmente, não é desejável. 

Os vértices e arestas seleccionados têm coloração laranja 
e  a  faces  seleccionadas  uma  coloração  laranja/ 
acastanhado.  Os  vértices  e  arestas  não  seleccionados 
têm coloração preta, e as faces coloração cinzenta, figura 
2.47. 

Das  funções  elementares  de  que  se  fala  nas  secções 
seguintes, 4 delas: 

• Select, 
• Select Lasso, 
• Border Select, 
• e Circle Select, 

são métodos do ViewPort 3D, isto é, as funções evocadas 
em modo edição e modo objecto são as mesmas. Outras 
4: 

• Select All, 
• Inverse, 
• More, 
• e Less, 

são métodos de objectos do tipo malha. 

 

Figura 2.45 

 

Figura 2.46 

 

Figura 2.47 
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11.2. Select . [bpy.ops.view3d.select()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [MRB]     

 

Para  seleccionar  um  elemento  coloque  sobre  ele  o 
cursor do rato e pressione [MRB]. 

 

Para  fazer  selecção  múltipla  de  elementos  mantenha 
[Shift]  pressionada  e  pressione  [MRB]  sobre  cada  um 
deles. 

   

Em  modo  de  selecção  vértice  pode  seleccionar  uma 
aresta  colocando  o  rato  sobre  ela  e  pressionando 
[Ctrl+MRB]. 

Em modo de selecção vértices pode seleccionar uma face 
seleccionando todos os seus vértices ou arestas. 
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11.3. Select Lasso. [bpy.ops.view3d.select_lasso()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[MLB]     

86 
 

Select  Lasso  (Selecção  Livre)  apenas  é  activável  pela 
tecla  de  atalho,  não  estando  disponível  em  nenhum 
menu. 

   

Quer  em  modo  edição  quer  em  modo  objecto,  pode 
evocar Select Lasso pressionando  [Ctrl]+[MLB]. 

Pressionando  [Ctrl]+[MLB]  e  arrastando  o  rato  faz  a 
Selecção  Livre  de  elementos  (ou  objectos).  A  função 
Select Lasso  selecciona  todos os objectos ou elementos 
que ficarem contidos, ou cujos centros ficarem contidos, 
dentro da região delimitada pela linha tracejada irregular 
definida pelo movimento do rato, figura 2.48. 

Os objectos/elementos assim seleccionados  juntam‐se a 
qualquer conjunto previamente seleccionado. 

 

Pressionando  [Shift]+[Ctrl]+[MLB]  desselecciona  todos 
os  objectos/elementos  incluídos  na  região  livre  que  se 
encontrem seleccionados. 

 

 

 

 

 

  

 

Figura 2.48 
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11.4. Border Select. [bpy.ops.view3d.select_border()]. 

87 
 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [B]     

Border  Select  pode  ser  evocada  a  partir  da  barra  da 
janela 3D, [Select>Border Select], figura 2.49. 

 

Em  modo  edição,  pode  evocar  Border  Select 
pressionando [B]  

Para  seleccionar  um  número  elevado  de  elementos 
active  Border  Select  e  arraste  o  rato  com  [MLB] 
pressionado.  São  seleccionados  assim  todos  os 
elementos  que  ficarem  no  interior  do  rectângulo  que 
surge no ecrã, figura 2.50. 

Note  que  a  função  é  a mesma  em modo  edição  e  em 
modo  objecto  (é  um  método  do  viewport  e  não  da 
malha). A selecção pode também ser evocada em modo 
objecto,  sendo  neste  caso  seleccionados  todos  os 
objectos  que  se  encontrem, mesmo  que  parcialmente, 
dentro das regiões. 

Para  desseleccionar  um  conjunto  de  elementos 
seleccionados  proceda  de  igual  modo  mas  mantendo 
agora [MMB] pressionando, figura 2.51. 

 

 

 

 

 

Figura 2.49 

 

Figura 2.50 

 

Figura 2.51 
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11.5. Circle Select. [bpy.ops.view3d.select_circle()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [C]     

Circle Select pode ser evocada a partir da barra da janela 
3D, [Select>Circle Select], figura 2.52. 

 

Em modo edição, pode evocar Circle Select pressionando 
[C]  

Com  Circle  Select  a  selecção múltipla  é  feita  de modo 
idêntico a border select, mas agora numa região circular, 
figura 2.53.  

Controle o diâmetro da  circunferência  com  [MW]. Para 
sair  da  selecção  circular  pressione  [Esc].  Enquanto  em 
selecção  circular  pode  arrastar  a  circunferência, 
seleccionando sucessivamente mais elementos. 

Tal   como para Border Select a  função é a mesma quer 
em modo edição quer em modo objecto. 

 

Figura 2.52 

 

Figura 2.53 
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11.6. Select/Deselect All. [bpy.ops.mesh.select_all()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [A]     

Select/Deselect All pode ser evocada a partir da barra da 
janela 3D, [Select>Select/Deselect All], figura 2.54. 

 

Em  modo  edição,  pode  invocar  Select/Deselect  All 
pressionando [A]. 

Select/Deselect All selecciona ou desseleccionar todos os 
elementos da malha em edição 

Note que apesar da  tecla de atalho em modo edição e 
modo  objecto  ser  a mesma,  as  funções  são  diferentes 
nos dois modos de trabalho. 

 

Figura 2.54 

 

 

 

 

 

 

 

 

11.7. Inverse. [bpy.ops.mesh.select_inverse()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[I]  [W]   

Inverse pode ser evocada a partir da barra da janela 3D, 
[Select>Inverse], figura 2.55, e a partir do menu Specials, 
[W]. 

 

Em  modo  edição,  pode  invocar  Inverse  pressionando 
[Ctrl]+[I]. 

Inverse  comuta  o  conjunto  de  elementos  da  malha 
seleccionados e não seleccionados, figura 2.56. 

Note que apesar da  tecla de atalho em modo edição e 
modo  objecto  ser  a mesma,  as  funções  são  diferentes 
nos dois modos de trabalho. 

 

Figura 2.55 

 

Figura 2.56 
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11.8. More. [bpy.ops.mesh.select_more()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[Key+]     

More pode  ser evocada a partir da barra da  janela 3D, 
[Select>More], figura 2.57. 

 

Em  modo  edição,  pode  invocar  More  pressionando 
[Ctrl]+[Key+]. 

More  estende  o  conjunto  de  elementos  seleccionados 
aos elementos ligados adjacentes. 

Dado o conjunto de elementos  seleccionados  conforme 
se mostra na figura 2.60, activando More, os elementos 
seleccionados  são  estendidos  ao  conjunto  adjacente, 
conforme se mostra na figura 2.58. 

 

Figura 2.57 

 

Figura 2.58 

 

 

 

11.9. Less. [bpy.ops.mesh. select_less()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[Key‐]     

Less  pode  ser  evocada  a  partir  da  barra  da  janela  3D, 
[Select>Less], figura 2.59. 

 

Em  modo  edição,  pode  evocar  Less  pressionando 
[Ctrl]+[Key‐]  

Less  desselecciona  os  elementos  fronteira  do  conjunto 
de elementos seleccionados. 

Dado o conjunto de elementos  seleccionados  conforme 
se mostra na  figura 2.58,  activando  Less, os  elementos 
fronteira  são  desseleccionados,  resultando  o  conjunto 
seleccionado conforme se mostra na figura 2.60. 

 

Figura 2.59 

 

Figura 2.60 

V 4.0  90 
 

http://www.blender.org/documentation/250PythonDoc/bpy.ops.mesh.html#bpy.ops.mesh.select_more
http://www.blender.org/documentation/250PythonDoc/bpy.ops.mesh.html#bpy.ops.mesh.select_less


  CGAV 1 ‐ MODELAÇÃO 1 
 

V 4.0  91 
 

12. Selecção de Contornos. 
 

 

 

 

 

 

 

 

Os  Contornos  de  Arestas  e  Faces  (Edge  Loops  e  Face 
Loops)  são  conjuntos  contíguos  de,  respectivamente, 
aresta  e  faces,  não  constituindo  necessariamente  um 
percurso fechado.  

A possibilidade de definição de Loops em modelos 3D é 
extremamente  importante no processo de animação de 
modelos articulados e na possibilidade de caracterização 
de  superfícies  de  transições  suaves  em  modelos  com 
relativamente poucos vértices. 

A  selecção  de  um  Contorno  pára  sempre  que  é 
encontrado  um  vértice  que  está  ligado  a  um  número 
impar  (>3)  de  arestas,  designado  por  Pólo,  dado  que, 
nesses casos, não existe solução única para a construção 
de um caminho  fechado. Não sendo encontrados pólos, 
os Contornos começam e acabam no mesmo elemento, 
vértice ou face, dividindo o modelo em duas partes. 

Todas as 5 funções de que se fala nas secções seguintes: 

• Vertex Path, 
• Edge Loop, 
• Edge Ring, 
• Loop to Region, 
• e Region to Loop 

são métodos de objectos do tipo malha. 
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12.1. Vertex Path. [bpy.ops.mesh.select_vertex_path()]. 

92 
 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    W 
[Ctrl]+[V]   

Vertex Path  é  evocável  a  partir  da  barra da  janela  3D, 
quer  via  [Mesh>Vertices>Select  Vertex  Path],  quer  via 
[Select>Vertex Path], a partir do menu Specials,  [W], e 
ainda a partir do menu, Vertex Special, [Ctrl]+[V], figura 
2.61.  

Seleccionados  dois  vértices,  Vertex  Path  procura  o 
Contorno mais curto entre eles, segundo dois diferentes 
algoritmos:  Edge  Length  ou  Topological,  figuras  2.62  e 
2.63. 

Após  a  activação  da  função  o  método  de  cálculo  da 
distância,  com  valor  padrão  Edge  Length,  pode  ser 
seleccionado na tabela de operadores, figura 2.64. 

 

 

 

 

 

 

 

 

 

 

Figura 2.61 

 

Figura 2.62: Edge Length. 

 

Figura 2.63: Topological. 

 

Figura 2.64 
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12.2. Edge Loop. [bpy.ops.mesh.loop_multi_select()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[MRB]  [Ctrl]+[E]   

Edge Loop pode ser evocada a partir da barra da  janela 
3D  via  [Mesh>Eges>Edge  Loop]  ou  via  [Select>Edge 
Loop], figura 2.65 

 

Em modo edição, pode evocar Edge  Loop pressionando 
[Alt]+[MRB] sobre uma aresta. 

Na  verdade,  a  tecla  de  atalho  activa  uma  função 
diferente  da  evocada  a  partir  dos  menus: 
[bpy.ops.mesh.loop_select()]. 

Dada  uma  ou  mais  arestas  seleccionadas,  Edge  Loop 
selecciona  um  conjunto  contíguo  de  arestas  que 
contenha a aresta seleccionada, figura 2.66. 

A  figura  2.66 mostra,  à  direita,  um  exemplo  em  que  é 
possível determinar um contorno fechado, e, à esquerda, 
um exemplo em que, por  ter sido encontrado um pólo, 
não  existe  solução  única  para  a  determinação  de  um 
contorno fechado. 

Com mais  de  uma  aresta  seleccionada  a  activação  de 
Edge  Loop  (loop_multi_select())  pode  resultar  na 
selecção  de mais  que  um  contorno  ou  de  uma  região 
(Edge Ring). Veja os exemplos da figuras 2.67 e 2.68.  

Em  Modo  de  Selecção  de  Faces  da  combinação 
[Alt]+[MRB]  sobre  uma  face  resulta  a  selecção  de  um 
conjunto contíguo de faces (Face Loop), figura 2.69. 

 

 

 

 

 

Figura 2.65 

 

Figura 2.66 

 

Figura 2.67 

 

Figura 2.68 

 

Figura 2.69 
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12.3. Edge Ring. [bpy.ops.mesh.loop_multi_ select(ring=True)]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Ctrl]+[Alt]+[MRB]  [Ctrl]+[E]   

Acessível  a  partir  da  barra  da  janela  3D  via  
[Mesh>Eges>Edge Ring] ou via [Select>Edge Ring], figura 
2.70. 

   

Em modo edição, pressionando [Ctrl]+[Alt]+[MRB] sobre 
uma aresta, activa a função Edge Ring. 

Dada  uma  ou  mais  arestas  seleccionadas,  Edge  Ring 
selecciona um  conjunto  contíguo de  faces  (Região, não 
necessariamente fechada), 2.71. 

Note  que  se  trata  da  mesma  função  de  Edge  Loop, 
apenas com um diferente valor de parâmetro. 

Na  verdade,  a  tecla  de  atalho  activa  uma  função 
diferente  da  anterior  [bpy.ops.mesh.loop_select(ring= 
True)].  Ou  seja,  a  mesma  activada  pela  combinação 
[Alt]+[MRB] mas com um diferente valor de parâmetro. 

A  figura  2.71 mostra,  à  direita,  um  exemplo  em  que  é 
possível determinar uma  região  fechada, e, à esquerda, 
um exemplo em que, por  ter sido encontrado um pólo, 
não  existe  solução  única  para  a  determinação  de  uma 
região fechada. 

Em  modo  de  selecção  de  aresta,  a  função  edge  ring 
permite‐lhe  seleccionar  um  conjunto  de  arestas  em 
oposição, figura 2.72. 

 

 

Figura 2.70 

 

Figura 2.71 

 

Figura 2.72 
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12.4. Loop to Region. [bpy.ops.mesh.loop_to_region()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [Ctrl]+[E]   

Loop to Region é acessível a partir da barra da janela 3D, 
quer via [Mesh>Eges>Loop to Region], quer via [Select> 
Loop  to  Region],  e  a  partir  do  menu  Edge  Specials, 
[Ctrl]+[E], figura 2.73. 

Com base no conjunto de arestas seleccionadas, Loop to 
Region divide a malhas em duas partes e  selecciona  as 
faces da menor das partes, figura 2.74.  

 

 

 

Figura 2.73 

 

Figura 2.74 

12.5. Region to Loop. [bpy.ops.mesh.region_to_loop()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[MRB]  [Ctrl]+[E]   

Region to Loop é acessível a partir da barra da janela 3D, 
quer via [Mesh>Eges>Region to Loop], quer via [Select> 
Region  to  Loop],  e  a  partir  do  menu  Edge  Specials, 
[Ctrl]+[E], figura 2.75. 

Region  to  Loop executa a operação contrária a  Loop  to 
Region, deixando activas as arestas  correspondentes ao 
contorno  (ou  contornos)  de  um  conjunto  de  faces 
seleccionadas, figura 2.76. 

 

 

 

 

 

 

 

Figura 2.75 

 

Figura 2.76 
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13. Transformação. 
 

 

 

 

 

 

 

Uma  vez  seleccionado,  pode  transformar  um  elemento 
recorrendo exactamente ao mesmo conjunto de acções 
descritas  a  propósito  da  translação,  rotação  e 
escalamento de um objecto como um todo descritas no 
Módulo 1 (teclas G, R, S). 

As funções são as mesmas em modo objecto e em modo 
edição:  Grab,  figura  2.77,  Rotate,  figura  2.78,  e  Scale, 
figura 2.79. 

Qualquer das  transformações é accionável quer a partir 
da  tabela  de  operadores,  figura  2.80,  quer  a  partir  da 
partir da barra da janela 3D, [Mesh>Transform> ...]. 

Para além das transformações elementares são descritas 
em  seguida  as  funções  To  Shere,  Shear, Warp,  e  Push 
Pull,  também  todas  elas  acessíveis  a partir da barra da 
janela 3D, [Mesh>Transform> ...]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13.1. Grab. [bpy.ops.transform.translate()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [G]     

 

 

Figura 2.77 
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13.2. Rotate. [bpy.ops.transform.rotate()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

   [R]     

 

 

Figura 2.78 

13.3. Scale. [bpy.ops.transform.resize()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

   [S]     

 
 

Figura 2.79

A figura 2.81 mostra a tabela de propriedades em modo 
edição,  estando  um  vértice  seleccionado,  em modo  de 
selecção  vértice.  No  painel  Transform  pode  ver  as 
coordenadas  do  vértice,  que  pode  editar,  alterando 
assim a sua posição com grande precisão.  

Caso esteja seleccionado mais que um vértice, é dado o 
valor médio de todas as coordenadas, figura 2.82. 

Note que ao entrar em modo edição todos os vértices da 
malha  se  encontram  activos  mas  não  o  seu  centro 
(designado por origem a partir da versão 2.5). Se mover 
(rodar,  escalar)  toda  a  malha  o  seu  centro  não 
acompanha a transformação. 

 

 

 

 

 

 

 

Figura 2.80 

 

Figura 2.81 

 

Figura 2.82 
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13.4. Shrink/Fatten. [bpy.ops.transform.shrink_fatten()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[S]     
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Shrink/Fatten  pode  ser  evocada  a  partir  da  tabela  de 
operadores, aí designada por (Transform) Along Normal, 
figura 2.83.  

 

Em  modo  edição,  pode  evocar  Shrink/Fatten  
pressionando [Alt]+[S]. 

Shrink/Fatten  desloca  o  conjunto  de  vértices 
seleccionados  ao  longo  das  normais  (de  cada  um  dos 
vértices). 

Na figura 2.84 pode ver uma malha com um conjunto de 
vértices seleccionados, e, à direita, o mesmo conjunto de 
vértices com a representação da normal a cada um deles. 
Na  figura  2.85  pode  ver  o  resultado  da  aplicação  de 
Shrink/Fatten  segundo  as  normais,  à  esquerda  e  em 
sentido contrário, à dreita. 

Nota: As normais  aos  vértices  são  calculadas  com base 
nas normais a cada uma das  faces adjacentes. Pode ver 
as  normais  a  cada  um  dos  vértices  activando  Vetex 
Normal  no  painel  Mesh  Display  da  tabela  de 
propriedades. 

 

 

 

 

 

 

 

 

Figura 2.83 

 

Figura 2.84 

 

Figura 2.85 
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13.5. To Sphere. [bpy.ops.transform.tosphere()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Shift]+[Alt]+[S]     

To Shere pode ser evocada a partir da barra da janela 3D, 
[Mesh>Transform>To Sphere], figura 2.86.  

 

Em modo edição, pode evocar To  Sphere pressionando 
[Shift]+[Alt]+[S]. 

To  Sphere dá  forma  esférica  a  uma malha,  tomando  o 
baricentro do  conjunto de  vértices  seleccionados  como 
centro de curvatura, figura 2.87. 

Durante a aplicação da função pode controlar o factor de 
esfericidade  através  da  distância  do  cursor  do  rato  ao 
cursor 3D.  

Após  a  aplicação  da  função,  entre  outros  parâmetros, 
pode  controlar  o  factor  de  esfericidade  no  painel  de 
operadores, figura 2.88. 

 

Figura 2.86 

 

Figura 2.87 

 

Figura 2.88   
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13.6. Shear. [bpy.ops.transform.shear()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Shift]+[Ctrl]+[Alt]+[S]     

Shear pode  ser evocada a partir da barra da  janela 3D, 
[Mesh>Transform>Shear], figura 2.89. 

 

Em  modo  edição,  pode  evocar  Shear  pressionando 
[Shift]+[Ctrl]+[Alt]+[S]. 

Shear é utilizada para distorcer a malha ao longo do eixo 
horizontal do plano do ecrã. figura 2.90. 

Durante a aplicação da função pode controlar o factor de 
cisalhamento através da distância do  cursor do  rato  ao 
cursor  3D.  Após  a  aplicação  da  função,  entre  outros 
parâmetros, pode controlar o factor de cisalhamento no 
painel de operadores, figura 2.91. 

 

Figura 2.89 

 

Figura 2.90 

 

Figura 2.91 
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13.7. Warp. [bpy.ops.transform.warp()]. 
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Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Shift]+[W]     

Warp pode  ser evocada a partir da barra da  janela 3D, 
[Mesh>Transform>Warp], figura 2.92. 

 

Em  modo  edição,  pode  evocar  Warp  pressionando 
[Shift]+[W]. 

Warp é indicada para distribuir a malha em edição longo 
de um círculo, que tem por centro o cursor 3D. 

Durante a aplicação da  função pode  controlar o ângulo 
de  torção  através  da  distância  do  cursor  do  rato  ao 
cursor  3D.  Após  a  aplicação  da  função,  entre  outros 
parâmetros, pode controlar o ângulo de torção no painel 
de operadores, figura 2.93. 

Note que é  conveniente que a  função  seja executada a 
partir  de  um  ponto  de  observação  da  janela  3D 
perpendicular ao plano de rotação. 

A  figura  2.95  mostra  o  resultado  do  enrolamento  em 
torno do eixo dos zz (o cursor 3D está situado na origem) 
do paralelepípedo que pode ver na figura 2.94. 

 

 

 

 

 

Figura 2.92 

 

Figura 2.93 

 

Figura 2.94 

 

Figura 2.95 
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13.8. Push Pull. [bpy.ops.transform.push_pull()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

       

Push  Pull pode  ser  evocada  a partir  da barra da  janela 
3D, [Mesh>Transform>Push Pull], figura 2.96. 

Push  Pull  afasta,  ou  aproxima,  todos  os  elementos 
seleccionados  de  igual  distância  relativamente  ao  seu 
baricentro, em função do movimento do rato. 

A  figura  2.97  mostra,  à  direita,  o  resultado  do 
afastamento  relativamente  ao  baricentro  de  todos  os 
vértices do paralelepípedo à esquerda.  

Se todos os elementos seleccionados estiverem à mesma 
distância do baricentro, por exemplo se se tratar de um 
cubo, a acção será equivalente a um escalamento. 

 

 

 

Figura 2.96 

 

Figura 2.97 
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14. Remoção. 
 

 

 

 

 

 

 

 

Descrevem‐se em seguida as funções: 

• Delete,  
• Merge, 
• e Remove Doubles,  

todas elas métodos de objectos da classe mesh. 

 

 

 

 

 

14.1. Delete. [bpy.ops.mesh.delete()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [X]     

Delete  pode  ser  evocada  a  partir  da  tabela  de 
operadores  e  a  partir  da  barra  da  janela  3D, 
[Mesh>Delete], figura 2.98. 

 

Em modo edição, pode evocar Delete pressionando [X]. 

Delete   elimina o conjunto de elementos seleccionados. 
Verá  surgir  no  ecrã  a  tabela  da  figura  2.99,  que  lhe 
permite especificar o tipo de elementos a remover. 

 

Figura 2.98 

 

Figura 2.99 

V 2.0  103 
 

http://www.blender.org/documentation/250PythonDoc/bpy.ops.mesh.html#bpy.ops.mesh.delete


  CGAV 1 ‐ MODELAÇÃO 1 
 

14.2. Merge. [bpy.ops.mesh.merge()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[M]  [Ctrl]+[V]   

Merge  pode  ser  evocada  a  partir  da  tabela  de 
operadores,  a  partir  da  barra  da  janela  3D, 
[Mesh>Vertices>  Merge],  e  a  partir  do  menu  Vertex 
Specials, figura 2.100. 

 

Em  modo  edição,  pode  evocar  Merge  pressionando 
[Alt]+[M]. 

Evocando  Merge,  todos  os  vértices  seleccionados  são 
reduzidos  a  um  só,  figura  2.101,  posicionado  na  opção 
seleccionada no menu que surge no ecrã, figura 2.102. 

Dependendo  da  topologia  do  conjunto  de  vertices 
seleccionado,  as opções At  First  e At  Last poderão não 
aparecer no menu (por não terem significado). 

 

Figura 2.100 

 

Figura 2.101 

 

Figura 2.102 
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14.3. Remove Doubles. [bpy.ops.mesh.remove_doubles()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [Ctrl]+[V]   

Remove Doubles pode ser evocada a partir no menu da 
janela 3D,  [Mesh>Vertices>Remove Doubles], do menu 
Vertex  Special,  [Ctrl]+[V],  e  ainda  a partir da  tabela de 
operadores, figura 2.103. 

Remove Doubles   funde todos os vértices seleccionados 
cuja distância  relativa  seja menor que um determinado 
limiar, figura 2.104. 

Remove Doubles tem como  limiar de eliminação padrão 
o  valor  0.0,  isto  é,  só  são  eliminados  os  vértices 
completamente sobrepostos. 

Após  a  aplicação  da  operação,  o  limiar  de  eliminação 
pode  ser especificado no painel que  surge na  tabela de 
operadores, figura 2.105. 

 

 

Figura 2.103 

 

Figura 2.104 

 

Figura 2.105 
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15. Criação. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

15.1. Extrude. 
A  técnica de Extrusão é  certamente a mais utilizada na 
criação de modelos 3D em que se adopte uma estratégia 
Bottom‐Up, isto é, se parta do particular para o geral, de 
um vértice para o modelo final.  

Em geral, da extrusão de um vértice resulta a criação de 
uma aresta, de uma aresta um  face, e de uma  face um 
volume. 

O  procedimento  de  modelação  por  extrusão  consiste 
simplesmente: 

•  na  selecção  de  um  elemento  (ou  conjunto 
deles),  

• activação do modo extrude, que, de imediato, 
cria uma  réplica do  elemento  seleccionado, na 
mesma posição, e entra em modo translação,  

•  e  no  arrastamento  do  rato  deslocando  as 
réplicas criadas para a posição desejada. 

A  figuras 2.106 a 2.108 mostram a aplicação duas vezes 
sucessivas da extrusão de uma região seleccionada numa 
malha,  segundo  a  direcção  da  normal  ao  conjunto  de 
elementos seleccionados, assinalada pela linha a branco. 

Em Tutorial 1 é exemplificada a utilização da  técnica de 
extrusão,  construindo  o  modelo  3D  de  um  peão  de 
xadrez. 

 

Figura 2.106 

 

Figura 2.107 

 

Figura 2.108 
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15.1.1. Extrude Region. [bpy.ops.mesh.extrude_region_move()] 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [E]     

Extrude Region pode  ser evocada a partir da  tabela de 
operadores  e  a  partir  da  barra  da  janela  3D,  [Mesh> 
Extrude Region], figuras 2.109 e 2.110. 

 

Em modo edição, para activar Extrude Region pressione 
[E]. 

Na  configuração  padrão,  extrude  region  é  executada 
segundo  a  normal  ao  conjunto  de  elementos 
selecionado. 

Como  habitual,  o  processo  de  translação  pode  ser 
restringido  a  apenas  um  dos  eixo  coordenados 
(relembre, pressionando [X], [X][X], [Y] etc.), e o valor do 
deslocamento pode ser inserido a partir do teclado. 

Se  tal  for  necessário,  a  extrusão  pode  ser  feita  com 
grande precisão recorrendo à tabela de operadores, após 
a execução da função, figura 2.111. 

Actuando  sobre  os  cursores  das  caixas  XYZ,  ou  por 
inserção  directa,  insira  os  valores  exactos  pretendidos. 
Note,  em  Constraint Axis,  que  na  configuração  padrão 
apenas  o  eixo  dos  zz  está  seleccionado.  Se  pretender 
extrudir livremente os elementos seleccionados active os 
3 eixos.   

Caso exista apenas um vértice seleccionado (ou conjunto 
de vértices não ligados) o processo de extrusão, activado 
Extrude Region], cria uma aresta entre os dois vértices. 
Figura  2.112 à esquerda. 

Caso seja seleccionada uma aresta (2 vértices ligados), ao 
activar  extrude  region,  são  criados  2  novos  vértices,  e, 
como pode observar movendo o rato, é criada uma face 
entre os 4 vértice, figura  2.112 ao centro.  

Se pretender extrudir dois, ou mais, vértices ligados sem 
criar faces entre eles, figura  2.112 à direita, deve activar 
Extrude Individual. 

 

Figura 2.109 

 

Figura 2.110 

 

Figura 2.111 

 

Figura 2.112 
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15.1.2. Extrude Individual. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

   [Shift]+[E]     

Extrude  individual pode  ser  evocada  a partir da  tabela 
de operadores e a partir da barra da  janela 3D,  [Mesh> 
Extrude Individual], figura 2.113. 

 

Em  modo  edição,  para  activar  extrude  individual 
pressione [Shift]+[E]. 

A  função  evocada  por  extrude  individual  depende  do 
modo de selecção activo.  

Em modo de  selecção  vértice,  extrude  individual  activa 
bpy.ops.mesh.extrude_vertices_move().  Cada  um  dos 
vértices  seleccionados é duplicado mas não  são  criadas 
arestas nem faces entre eles, figura 2.114. 

Em modo  de  selecção  aresta,  extrude  individual  activa 
bpy.ops.mesh.extrude_edges_move().  Cada  uma  das 
aresta  seleccionadas  é  duplicada  e  são  criadas  faces 
entre os duplicados e as arestas originais, figura 2.115. 

Em  modo  de  selecção  face,  extrude  individual  activa 
bpy.ops.mesh.extrude_faces_move()  ou  bpy.ops.mesh. 
extrude_region_move()  dependendo  da  topologia  do 
conjunto  de  faces  seleccionadas.  Cada  uma  das  faces 
seleccionadas  é  duplicada  e  são  criadas  faces  entre  os 
duplicados  e  as  arestas  seleccionadas  originais,  figura 
2.116. 

Note  que  no  caso  da  extrusão  individual  de  faces,  ao 
contrário  da  extrusão  de  uma  região  são  criadas  faces 
interiores na malha extrudida. 

 

 

 

 

 

 

 

Figura 2.113 

 

Figura 2.114 

 

Figura 2.115 

 

Figura 2.116 
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15.1.3. Criação elementar. [bpy.ops.mesh.dupli_extrude_cursor()]. 
 

 

Em modo edição, pressione [Ctrl]+[MLB] para inserir um 
vértice (isolado). 

Todos os vértices que se encontrem seleccionados serão 
ligados por uma aresta ao vértice inserido, figura 2.117. 

 

Figura 2.117 
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15.2. Tutorial 1 
1. Abra o Blender 

2. Elimine o cubo, [X]. Figura 2.118. 

 

 

 

 

3.  Passe  a  ToptView  em  projecção  ortográfica, 
[NumLock] > [7] > [5]. 

4. Insira um circulo, [Shift]+[A] > [Circle]. Figura 2.119. 

5. Passe a FrontView, [1]. 

 

 

 

 

 

 

 

6. Entre em modo edição, [Tab]. 

Na configuração padrão  todos os vértices se encontram 
seleccionados.  Deve  neste  momento  estar  a  observar 
uma imagem idêntica á figura 2.120. 

 

 

 

7. Proceda à extrusão do circulo segundo zz:  [E] >  [Z] > 
(desl. Rato) > [MLB]. Figura 2.121. 

 

 

Figura 2.118 

 

Figura 2.119 

 

Figura 2.120 

 

Figura 2.121 
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8.  Proceda  a  uma  extrusão  segundo  zz  seguida  de 
escalamento: [E] > [Z] > (desl. Rato) > [MLB] > [S] > (desl. 
Rato) > [MLB] , figura 2.122. 

 

 

 

9. Através de uma sequência de acções: 

• [E] > [Z] > (desl. Rato) > [MLB] 

•  [E] >  [Z] >  (desl. Rato) >  [MLB] >  [S] >  (desl. 
Rato) > [MLB] 

proceda a sucessivas extrusões, e extrusões seguidas de 
escalamento, criando o modelo da figura 2.123. 

Nas operações de escalamento, não esqueça que quanto 
mais afastado do pivot estiver o cursor do rato mais fácil 
será controlar o factor de escalamento. 

 

 

 

 

 

10. Chegado ao topo, pressione [Alt]+M] e seleccione At 
Center,  para  juntar  todos  os  vértices  num  só,  no 
baricentro  do  conjunto  seleccionado.  Proceda  de  igual 
modo na base do objecto, figura 2.124. 

 

 

 

 

 

11. Seleccione o vértice superior, e puxe‐o  ligeiramente 
para cima, [G] > [Z] > (desl. Rato), figura 2.125. 

 

 

 

Figura 2.122 

 

Figura 2.123 

 

Figura 2.124 

 

Figura 2.125 
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15.3. Make Edge/Face. [bpy.ops.mesh.edge_face_add()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [F]  [Ctrl]+[E] 
[Ctrl]+[F]   

Make Edge/Face pode ser evocada a partir da barra da 
janela  3D,  via    [Mesh>Edges>Make  Edge/Face]  ou  via 
[Mesh>Faces>Make Edge/Face], a partir do menu Edge 
Specials,  [Ctrl]+[E],  e  a  partir  do  menu  Face  Specials, 
[Ctrl]+[F], figura 2.126. 

 

Em modo edição para evocar Make Edge/Face pressione 
[F] 

Seleccionados dois vértices Make Edge/Face  insere uma 
aresta entre eles, figura 2.127. 

Uma área entre um grupo de vértice  ligados por arestas 
não constitui necessariamente uma face, figura 2.127, e, 
não constituindo uma face, será transparente na imagem 
renderizada do modelo 3D. 

Seleccione  três  ou  quatro  vértices  Make  Edge/Face 
insere uma face entre eles, figura 2.128. 

 

 

 

 

Figura 2.126 

 

Figura 2.127 

 

Figura 2.128 
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15.4. Fill. [bpy.ops.mesh.fill()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[F]  [Ctrl]+[F]   

Fill  pode  ser  evocada  a  partir  da  barra  da  janela  3D,  
[Mesh>Faces>Fill],  e  a  partir  do  menu  Face  Specials, 
[Ctrl]+[F], figura 2.129. 

 

Em modo edição, para evocar Fill pressione [Alt]+[F]  

Seleccionado  um  conjunto  de  vértices  Fill  insere  várias 
faces em simultâneo, figura 2.130. 

 

Figura 2.129 

 

Figura 2.130 

 

 

15.5. Edge Flip. [bpy.ops.mesh.edge_flip()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Shift]+[Ctrl]+[F]  [Ctrl]+[F]   

Edge  Flip pode  ser  evocada  a partir da barra da  janela 
3D,    [Mesh>Faces> Edge Flip], e a partir do menu Face 
Specials, [Ctrl]+[F], figura 2.131. 

 

Em modo  edição,  pode  evocar  Edge  Flip  pressionando 
[Ctrl]+[Shift]+[F]  

Dado  um  conjunto  de  faces  seleccionadas  Edge  Flip  
altera a posição das arestas, figura 2.132. 

A  alteração  da  posição  das  arestas,  tendo  como 
consequência a alteração do posicionamento das  faces, 
pode  ter  uma  influência muito  significativa  na  imagem 
resultante  da  renderização,  como  consequência  da 
alteração  do  posicionamento  das  normais  a  cada  uma 
das faces. 

 

Figura 2.131 

 

Figura 2.132 
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15.6. Beautify Fill. [bpy.ops.mesh.beautify_fill()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Shift]+[Alt]+[F]  [Ctrl]+[F]   

Beautify Fill pode ser evocada a partir da barra da janela 
3D,  [Mesh>Faces>Beautify Fill], e a partir do menu Face 
Specials, [Ctrl]+[F], figura 2.133. 

 

Em  modo  edição,  para  evocar  Beautify  Fill  pressione 
Shift]+[Alt]+[F]  

Beautify  Fill  converte  um  conjunto  de  faces 
seleccionadas  num  padrão  "mais  ordenado",  figura 
2.134. 

O comando Beautify Fill, ao alterar o posicionamento dos 
vértices,  pode  ser  extremamente  útil,  quer  por  daí 
resultar  uma  imagem  renderizada  diferente,  quer  na 
importância que possa ter na continuação da construção 
do  modelo  3D,  se  for  necessário,  por  exemplo, 
determinar  um  conjunto  de  vértices  que  constitua  um 
contorno (Edge Loop). 

Internamente,  todas  as  faces  limitadas  por  quatro 
arestas,  designadas  por  Quads,  são  divididas  em  duas 
faces triangulares. A menos que deseje a criação de faces 
perfeitamente  planas,  como  no  caso  do  cubo,  é 
preferível  a  criação  de  faces  triangulares.  Em  qualquer 
altura,  as  faces  quadrangulares  podem  ser  convertidas 
em faces triangulares e vice‐versa. 

 

Figura 2.133 

 

Figura 2.134 
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15.7. Quads to Tris. [bpy.ops.mesh.quads_convert_to_tris()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Ctrl]+[T]  [Ctrl]+[F]   

Quads  to  Tris  pode  ser  evocada  a  partir  da  barra  da 
janela  3D,    [Mesh>Faces>Quads  to  Tris],  e  a  partir  do 
menu Face Specials, [Ctrl]+[F], figura 2.135. 

 

Em modo  edição,  para  evocar Quads  to  Tris  pressione 
[Ctrl]+[T].  

Dado um conjunto de  faces seleccionadas Quads  to Tris 
converte as  faces quadrangulares em  faces triangulares, 
figura 2.136. 

 

 

Figura 2.135 

 

Figura 2.136 

 

 

 

 

15.8. Tris To Quads. [bpy.ops.mesh.tris_convert_to_quads()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[J]  [Ctrl]+[F]   

Tris  To  Quads  pode  ser  evocada  a  partir  da  barra  da 
janela  3D,    [Mesh>Faces>Tris  To Quads],  e  a  partir  do 
menu Face Specials, [Ctrl]+[F], figura 2.127. 

 

Em modo  edição,  para  evocar  Tris  To Quads  pressione 
[Alt]+[J]. 

Dado um conjunto de  faces seleccionadas Tris  to Quads 
converte as faces triangulares em faces quadrangulares. 

 

Figura 2.137 
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15.9. Subdivide. [bpy.ops.mesh.subdivide()].
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

    [W] 
[Ctrl]+[E]   

Subdivide pode  ser evocada a partir da barra da  janela 
3D,    [Mesh>Edges>Subdivide],  a  partir  do menu  Edge 
Special,  [Ctrl]+[E],  a  partir  do menu  Specials,  [W],  e  a 
partir da tabela de operadores, figura 2.138. 

Dado  um  conjunto  arestas  seleccionadas,  Subdivide  
divide cada uma delas em duas, no ponto médio, sendo 
aí criados novos vértices. 

A  figura  2.139  ilustra  a  aplicação  de  Subdivide  1  e  2 
vezes. 

Após  a  aplicação  de  subdivide,  pode,  na  janela  de 
operadores, figura 2.140, especificar 3 parâmetros: 

• Number of Cuts Número de cortes a efectuar 
em cada uma das aresta. 

A  figura  2.141  ilustra,  à  esquerda,    uma 
subdivisão  em  3  partes  (especificando  number 
of  cuts  2),  e,  à  direita,  uma  subdivisão  em  4 
partes (especificando number of cuts 3). 

 

 

 

 

 

• Smoothness: Os novos vértices são desviados 
em direcção ao baricentro dos vértices  ligados, 
com um deslocamento proporcional ao valor do 
parâmetro. 

O parâmetro tem valor padrão 0.0, significando 
desvio nulo. A segunda opção do menu specials, 
Subdivide  Smooth,  é  equivalente  à  operação 
subdivide  com parâmetros: numbers of  cuts 1; 
smoothness  1,  figura  2.142  à  esquerda.  Nesta 
figura,  à  direita,  pode  ver  o  resultado  da 
operação  subdivide  com   parâmetros: numbers 
of cuts 3; smoothness 1.5. 

 

Figura 2.138 

 

Figura 2.139 

 

Figura 2.140 

 

Figura 2.141 

 

 Figura 2.142 
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•  Fractal:  Os  novos  vértices  são  dispostos 
aleatoriamente.  A  figura  2.143  mostra  o 
resultado  da  operação  subdivide  com 
parâmetros: number of cuts 2; fractal 10. 

 

 

 

 

 

 

 

Figura 2.143 

15.10. Duplicate&Move. [bpy.ops.mesh.duplicate_move()].
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Shift]+[D]     

Duplicate&Move pode ser evocada a partir da barra da 
janela 3D,  [Mesh>Add Duplicate], e a partir da tabela de 
operadores, figura 2.144. 

 
Em  modo  edição  pode  evocar  Duplicate&Move 
pressionando [Shift]+[D]. 

Dado  um  conjunto  de  elementos  de  uma  malha 
seleccionados,  Duplicate&Move  cria  uma  cópia  dos 
elementos  na mesma  posição  dos  originais  e  passa  ao 
modo de translação. 

Embora  não  esteja  disponível  de momento  (R29442)  a 
partir  da  interface,  existe  ainda  o  método  Duplicate  
[bpy.ops.mesh.duplicate()],  com  funcionalidade  idêntica 
ao  acima  descrito,  mas  não  activando  o  modo  de 
translação. 

 

 

 

Figura 2.144 
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15.11. Spin. [bpy.ops.mesh.spin()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Alt]+[R]     

Spin pode ser evocada a partir da tabela de operadores, 
figura 2.145. 

 

Em modo edição, para evocar Spin pressione [Alt]+[R]. 

A função Spin é especialmente indicada para criar sólidos 
de revolução e secções circulares, e consiste na extrusão 
automática  do  conjunto  de  vértices  seleccionados  ao 
longo de um circulo no plano da janela 3D e cujo centro é 
o cursor 3D. 

A  técnica  é  extremamente  simples  de  aplicar:  uma  vez 
definido o perfil do objecto a modelar e feito o correcto 
posicionamento do pivot, basta activar a função. 

Após executar a  função pode, na  tabela de operadores, 
figura 2.146, especificar o número de  réplicas, Steps, o 
ângulo total da rotação, Degrees, e ainda alterar o centro 
e o eixo em torno do qual é feita a rotação. 

A figura 2.147 mostra o resultado da aplicação de spin  , 
com  valores  padrão,  ao  conjunto  de  vértices 
seleccionados: são extrudidas 9 réplicas ao  longo de um 
quadrante (90o). 

Em Tutorial 2 é exemplificada a aplicação da técnica Spin 
construindo de novo o modelo 3D de um peão de xadrez. 
Sendo  um  sólido  de  revolução  esta  técnica  é 
especialmente indicada. 

15.11.1. Spin Duplicate. 

Como pode ver, figura 2.146, imediatamente a seguir ao 
parâmetro Steps, a função Spin tem um parâmetro, Dupli 
(abreviatura  de  Duplicate),  que  está  desactivado  na 
configuração padrão. 

Activando o parâmetro Dupli  a  função  Spin passa  a  ter 
uma  diferente  funcionalidade,  que  designaremos  por 
função Spin Duplicate. 

 

Figura 2.145 

 

Figura 2.146 

 

Figura 2.147 
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A função Spin Duplicate é  indicada para criar réplicas da 
malha  de  um  objecto,  ou  parte  dela,  ao  longo  de  um 
círculo ou de uma secção circular, figura 2.148. 

Note que é muito importante o correcto posicionamento 
do cursor 3D  , em  torno do qual será  feita a  rotação, e 
que  a  rotação  é  feita  no  plano  da  Janela  3D,  embora 
qualquer  destes  destes  parâmetros,  Center  e  Axis, 
possam  ser  alterados  à  posteriori  na  janela  de 
operadores, figura 2.148. 

Note ainda que se proceder a uma revolução completa, 
resulta uma sobreposição de elementos na posição inicial 
(que deverá eliminar). 

Em Tutorial 3 é exemplificada a aplicação da técnica Spin 
Duplicate na construção de uma jante de automóvel. 

 

Figura 2.148 
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15.12. Tutorial 2 
1. Abra o Blender.Deixe estar o cubo. 

2. Passe a TopView, [7].  

3. Entre em modo edição, [Tab].  

4.  Na  configuração  padrão  todos  os  vértices  estão 
selecionados]. Elimine todos vértices, [X]. 

5.  Note  que  o  centro  do  objecto  não  foi  eliminado,  e 
encontra‐se  em  xyz:[0  0  0],  como  pode  confirmar  na 
tabela  de  propriedades,  caso  esta  não  esteja  visível  à 
direita da janela 3D presssione [N]. 

6. Coloque o  rato  sobre a origem  (aproximadamente) e 
pressione  [Ctrl]+[MLB],  criando  assim  um  vértice. 
Recorra à  tabela de propriedades para colocar o vértice 
rigorosamente sobre a origem, figura 2.149. 

7. Arraste o  rato para  a direita e  crie um novo  vértice, 
[Ctrl]+[MLB]. Note que, automaticamente, é criada uma 
aresta ente os dois vértices, figura 2.150. 

8.  Repita  o  procedimento  sobre  o  plano  xy,  criando 
novos  vértices  que  definem  o  perfil  de  um  peão  de 
xadez, figura 2.151. 

9. Recorrendo à tabela de propiedades, corrija a posição 
do  último  ponto,  assegurado  que  se  encontra  sobre  o 
eixo dos yy, figura 2.152. 

 

 

 

 

10.  Caso  cursor  3D  não  esteja  na  origem,  corrija  a  sua 
posição,  recorrendo  à  tabela  de  propriedades,  ou 
seeleccionando o ponto do perfil que está na origem e 
fazendo, [Shift]+[S]>[Cursor to Selected]. 

 

11. Mude para FrontView, [1]. Pode verificar que o perfil 
se encontra sobre o eixo dos xx, figura 2.153. 

 

 

 

Figura 2.149 

 

Figura 2.150 

 

Figura 2.151 

 

Figura 2.152 

 

Figura 2.153 
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12.  Accione  a  função  Spin,  [Alt]+[R],  e,  na  tabela  de 
operadores, modifique o valor de Degrees para 360.0 e o 
valor de Steps, por exemplo. para 12. Figura 2.154.  

 

 

 

 

 

Note que é  importante que a rotação seja de 360º para 
que  se  definam  as  últimas  faces  de modo  a  fechar  o 
objecto,  figura  2.155.  No  entanto,  resultou  daqui  a 
criação  de  um  conjunto  de  vértices  sobrepostos  (o 
primeiro e o último perfil ficaram sobrepostos). 

 

 

 

13. Seleccione todos os vértices, [A], e execute [Remove 
Doubles] a partir da tabela de operadores. 

 

 

 

 

 

 

 

 

 

Figura 2.154 

 

Figura 2.155 

 

Figura 2.156 
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15.13. Screw. [bpy.ops.mesh.screw()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

       

Screw  pode  ser  evocada  a  partir  da  tabela  de 
operadores, figura 2.157. 

A função Screw é indicada para criar objectos helicoidais 
(molas, roscas, parafusos, etc.). 

Para além do perfil da hélice, a  função Screw necessita 
de  uma  linha  aberta  de  vértices  (basta  uma  aresta), 
pertencente à mesma malha do perfil, que é  indicadora 
da  translação a efectuar em cada passo da hélice  figura 
2.158. 

Embora  se  possam  adoptar  perspectivas  propícias  à 
definição de modelos mais complexos, para um modelo 
de hélice  simples  seleccione, por exemplo FrontView, e 
represente o perfil e a linha aberta no plano zx. A hélice 
desenvolver‐se‐á segundo zz, em direcção ao cursor 3D. 

Após  a  execução  da  função  pode,  na  tabela  de 
operadores,  figura  2.160,  alterar  os  parâmetros  Steps, 
correspondente  ao número de  réplicas por  cada passo, 
isto  é,  por  cada  rotação  de  360º,  e  Turns 
corrrespondente ao número total de passos da hélice. 

Em cada passo a linha aberta sofre uma translação sobre 
o seu próprio eixo de valor igual ao seu comprimento. 

Se a linha aberta não for paralela ao eixo dos zz afastar‐
se‐á progressivamente do eixo de  rotação, mantendo o 
perfil da hélice sempre a mesma distância relativa à linha 
aberta. 

 

 

 

 

 

Figura 2.157 

 

Figura 2.158 

 

Figura 2.159 

 

Figura 2.160 
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15.14. Solidify. [bpy.ops.mesh.solidify()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

    [Ctrl]+[F]   

Solidify pode ser evocada a partir da barra da janela 3D,  
[Mesh>Faces>Solidify], e a partir do menu Faces Special,  
[Ctrl]+[F], figura 2.161. 

Solidify  faz  a  extrusão  e  translação  do  conjunto  de 
vértices  seleccionados, dando  espessura,  com um  valor 
padrão de 0.01, à malha em modelação, figura 2.162. 

Após a execução da  função é possível alterar o valor da 
translação  dos  novos  vértices  (espessura:  parâmetro 
Thickness),  a  partir  da  tabela  de  operadores,  figura 
2.163. 

 

 

 

 

 

Figura 2.161 

 

igura 2.162 

 

Figura 2.163 

15.15. Mirror. [bpy.ops.transform.mirror()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Ctrl]+[M]     

Mirror pode ser evocado a partir da barra da  janela 3D, 
[Object>Mirror], figura 2.164. 

 

Em  modo  edição,  pode  evocar  Mirror  pressionando 
[Ctrl]+[M]. 

A  função é a mesma em modo objecto e modo edição, 
mas  existe  agora  a  opção  de  reflectir  o  objecto 
relativamente ao sistema de eixos local. 

A  figura 2.165   mostra uma  reflexão  feita em  torno do 
cursor  3D,  segundo  o  eixo  dos  yy  do  sistema  de 
coordenadas local. 

 

Figura 2.164 

 

Figura 2.165 
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15.16. Loop Cut. [bpy.ops.mesh.loopcut_slide()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 

3D 

  [Ctrl]+[R]     

Loop  Cut  pode  ser  evocado  a  partir  da  tabela  de 
operadores, figura 2.166. 

 

Em modo  edição,  pode  evocar  Loop  Cut  pressionando 
[Ctrl]+[R]. 

A  partir  de uma  aresta  seleccionada,  Loop  Cut  cria  um 
Contorno  (edge  loop)  que  subdivide  um  conjunto 
contíguo de faces (face loop). 

Numa  1ª  fase  são  apresentados  Contornos  possíveis, 
coloridos a magenta, seleccionáveis pelo movimento do 
rato, figura 2.167.  

Nesta  fase,  pode  seleccionar  através  da  roda  do  rato, 
[MW], o número de contornos que deseja inserir, 2.168. 

Numa 2ª fase, uma vez seleccionado o Contorno, [MLB], 
o  seu  posicionamento  final  é  especificado  através  do 
movimento  do  rato  a  longo  de  uma  aresta  colorida  a 
verde, figura 2.169.  

Nesta  fase,  pressionando  [MMB]  força  o  corte 
exactamente a meio.  

 

 

 

 

 

 

 

 

 

 

 

Figura 2.166 

 

Figura 2.167 

 

Figura 2.168 

 

Figura 2.169 
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15.17. Tutorial 3 
Vamos  ilustrar  a  utilização  da  função  Loop  Cut 
mostrando um método alternativo de modular o peão de 
xadrez.  

A modelação Top‐Down, que  consiste em partir de um 
modelo  geométrico  simples, um  cubo, um  cilindro etc., 
fazendo  progressivamente  a  adaptação  da  topologia 
inicial ao objecto a modelar, é uma técnica alternativa às 
estratégias de modelação vistas anteriormente, em que 
se evoluiu do particular para o geral. 

1. Abra o ficheiro Blender do tutorial 1 ou 2 e salve uma 
imagem  (faça uma  captura de ecrã) do peão de  xadrez 
numa projecção ortogonal (por exemplo frontview). 

2. Abra um novo Blender. Seleccione, [RMB], e elimine o 
cubo, [X].  

3. Abra a tabela de propriedades, [N].  

4.  Seleccione  a  tabela  Background  Images.  Active 
Background  Images.  Pressione  Add  Image,  Not  Set  e 
Open. Seleccione o ficheiro com a imagem do peão. 

5. Caso a imagem não esteja centrada, utilize a caixa X do 
painel Background Images para a centrar. 

6. Passe a frontview, [1]. 

7.  Coloque  o  cursor  na  origem,  [Shif]+[S]  >  Cursor  to 
Center. 

8. Insira um cilindro, [Shift]+[A] > Mesh > Tube. 

9.  Entre  em  modo  edição,  [Tab],  e  escale  o  cilindro 
segundo zz, [S] > [Z] > (Desloc. Rato), à altura do peão de 
xadrez.  Caso  seja  necessário  desloque  a  imagem  na 
vertical utilizando a caixa Y do painel Background Images. 

10. Desseleccione todos o vértices, [A]. 

11. Seleccione o vértices da base,  [B] >  (Desloc. Rato)  , 
figura 2.170. 

12. Faça um escalamento até ao perímetro exterior, [S] > 
(Desloc. Rato), figura 2.171 

13.  Acrive  Loop  Cut  e  desloque  o  contorno  até  ao  1º 
patamar do peão de xadrez, [Ctrl]+[R] > [LMB] > (Desloc. 
Rato), 

 

Figura 2.170 

 

Figura 2.171 
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14. Faça um escalamento até ao perímetro exterior, [S] > 
(Desloc. Rato),  figura 2.172 

15. Active novamente Loop Cut, desloque o contorno até 
patamar seguinte do peão de xadrez, [Ctrl]+[R] > [LMB] > 
(Desloc.  Rato),  e  faça  um  escalamento,  [S]  >  (Desloc. 
Rato), até ao perímetro exterior. 

16.  Vá  repetindo  o  procedimento  16,  figura  2.173,  até 
chegar ao topo, completando assim a forma do peão de 
xadrez. 

 

 

 

 

 

 

 

Figura 2.172

 

Figura 2.173 

 

 

 

 

 

Figura 2.174 
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16. Modificação. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16.1. Smooth Vertex. [bpy.ops.mesh.vertices_smooth()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [W] 
[Ctrl]+[V]   

Smooth Vertex  pode  ser  evocada  a partir  do menu  da 
barra da janela 3D, [Mesh>Vertices>Smooth Vertex], do 
menu  vertex  Specials, do menu  Special  (em que  tem  a 
designação Smooth), e a partir de tabela de operadores, 
figura 2.175. 

Suaviza a malha, ou a parte da malha seleccionada (torna 
as  arestas  menos  vivas  em  resultado  da  alteração  do 
ângulo entra as faces), movendo os vértices em direcção 
ao baricentro das vértices ligados. Não confundir com Set 
Smooth.  

Após  a  aplicação  da  função  pode  definir  o  número  de 
vezes  que  a  deseja  aplicar,  especificando  o  parâmetro 
Smooth iteration a partir da tabela de operadores, figura 
2.176.  

A  figura  2.177  mostra  o  resultado  da  aplicação  de 
Smooth 10 vezes. 

 

 

 

Figura 2.175 

 

Figura 2.176 

 

Figura 2.177 
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A  função  é  útil  quer  como  ferramenta  de  modulação 
quer  como  instrumento  de  regularização de  superfícies 
que,  inadvertidamente,  tenham  ficado  irregulares 
durante o processo de modelação figura 2.178. 

 

 
 

Figura 2.178 

16.2. Rip. [bpy.ops.mesh.rip()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [Ctrl]+[V]   

Rip   pode ser evocada a partir do menu, Vertex Special, 
[Ctrl]+[V],  e  a  partir  da  barra  da  janela  3D, 
[Mesh>Vertices>Rip], figura 2.179. 

Dado  um  conjunto  seleccionado  de  vértices,  não 
constituindo  necessariamente  um  contorno  fechado, 
nem  sequer  ligado,  a  Rip  rasga  a malha  ao  longo  das 
arestas que interligam os vértices seleccionados, criando 
uma cópia, na mesma posição, e ligada à malha original, 
de cada uma das arestas e vértices seleccionados. 

Na figura 2.180 pode ver, à direita, o cubo "rasgado" ao 
longo do contorno seleccionado conforme se mostra no 
cubo da esquerda. 

 

Figura 2.179 

 

Figura 2.180 

16.3. Rip&Move. [bpy.ops.mesh.rip_move()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [V]     

Rip&Move é evocável a partir da tabela de operadores. 

 

Em  modo  edição,  pode  activar  a  função  Rip&Move 
pressionando [V]. 

Rip&Move é idêntica à função Rip, mas o novo conjunto 
de vérices fica seleccionado e em modo translação. 

 

Figura 2.181 
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16.4. Split. [bpy.ops.mesh.split()]. 

 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [Y]  [Ctrl]+[V]   

Split  é  evocável  a  partir  da  barra  da  janela  3D, 
[Mesh]>[Vertices]>[Spit],  e  do  menu,  Vertex  Special, 
[Ctrl]+[V], figura 2.182. 

 

Em modo edição, pode evocar Split pressionando [Y]. 

Com a função Split pode separar uma ou várias faces da 
malha  a  que  pertencem.  Embora  separada 
geometricamente, a face, ou conjunto de faces, continua 
a pertencer à mesma malha, figura 2.183. 

 

 

 

Figura 2.182 

 

Figura 2.183 

V 2.0 

http://www.blender.org/documentation/250PythonDoc/bpy.ops.mesh.html#bpy.ops.mesh.split


  CGAV 1 ‐ MODELAÇÃO 1 
 

16.5. Separate. [bpy.ops.mesh.separate()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [P]  [Ctrl]+[V]   

Acessível  a  partir  da  barra  da  janela  3D, 
[Mesh]>[Vertices]>[Separate],  e  do  menu,  Vertex 
Special, [Ctrl]+[V], figura 2.184. 

 

Em  modo  edição,  pode  evocar  Separate  pressionando 
[P]. 

Activando  Separate  é  apresentado  no  ecrã  o menu  da 
figura 2.185, que permite  seleccionar 3  tipos diferentes 
de separação: 

• Selection: O conjunto de vértices seleccionados 
passam a constituir um novo objecto. 

• By Material:  Cria  objectos  separados  por  cada 
um  dos  diferentes materiais  (se  existirem)  do 
objecto em edição. 

• By Loose Parts: Todos  (se existirem) elementos 
não ligados (por arestas) à malha activa, passam 
a constituir um novo objecto. 

 

 

 

 

Figura 2.184 

 

Figura 2.185 
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16.6. Rotate Edge CW / CCW. [bpy.ops.mesh.edge_rotate()]. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [Ctrl]+[E]   

Rotate Edge CW  / CCW é evocável a partir da barra da 
janela 3D,  [Mesh>Eges> Rotate Edge CW  / CCW], e do 
menu Edge Special, [Ctrl]+[E], figura 2.186. 

Rotate Edge CW  / CCW  roda o  vértice  seleccionado no 
sentido  dos  ponteiro  do  relógio  (CW),  ou  no  sentido 
directo (CCW), figura XXX.  

O  vértice  pode  estar  explicitamente  seleccionado,  ou 
implicitamente entre dois vértices seleccionados ou duas 
faces seleccionadas. 

A  função é utilizada  fundamentalmente na simplificação 
de  malhas  visando  minorar  o  número  de  vértices 
presentes. 

Após a aplicação da função o sentido de rotação pode ser 
alterado no painel de operadores, figura 2.188. 

 

 

 

 

 

 

Figura 2.186 

 

Figura 2.187 

 

Figura 2.188 
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16.7. Edge Slide. [bpy.ops.transform.edge_slide()]. 

132 
 

Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

    [Ctrl]+[E]   

Edge  Slide    é  evocável  a  partir  da  barra  da  janela  3D, 
[Mesh>Eges], a partir do menu Edge Special, [Ctrl]+[E], e 
a partir da tabela de operadores, figura 2.189. 

Edge  Slide    permite  deslocar  uma  aresta  ao  longo  das 
faces  adjacentes,  figura  2.190,  sendo  o  valor  do 
deslocamento proporcional ao deslocamento do rato, ou 
introduzido  via  teclado,  especificado  em  percentagem 
relativamente à distância às arestas mais próximas. 

Poderá ser seleccionada mais do que uma aresta desde 
que  pertença  ao  mesmo  Contorno  (Vertex  Path/Edge 
Loop). 

Após a aplicação da função, a percentagem de translação 
pode ser alterado no painel de operadores, figura 2.191. 

 

 

 

Figura 2.189 

 

Figura 2.190 

 

Figura 2.191 
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16.8. Posicionamento da origem. 
Uma vez  juntos, os objectos passam a constituir um só, 
com  a  topologia  daí  resultante,  sendo  o  centro  o  do 
último objecto seleccionado.  

Para  reposicionar a origem  faça a  respectiva  selecção a 
partir  da  barra  da  janela  3D,  quer  em  modo  edição, 
[Mesh>Transform>Geometry  to  Origin],  figura  2.192, 
quer  em modo  objecto,  [Object>Transform> Geometry 
to Origin]. 

 

Em modo objecto ou em modo edição, para reposicionar 
a origem pode ainda pressionar [Shift]+[Ctrl]+[Alt]+[C] e 
fazer  a  selecção  a  partir  da  tabela  que  surge  no  ecrã, 
figura 2.193. 

 

 

 

 

 

 

 

Figura 2.192 

 

Figura 2.193 
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16.9. Edição Proporcional de Vértices. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

  [O] 
[Alt]+[O]     

Proporcional Editing pode ser evocada a partir da barra 
da  janela  3D,  [Mesh>Proporcional  Editing],  figura   
2.194,  ou,  de modo mais  imediato,  a  partir  do Menu 
Proporcional  Editing  existente  na mesma  barra,  figura  
2.195. 

 

Em  modo  edição,  pode  evocar  Proporcional  Editing 
pressionando [O]. 

 

Em  modo  edição  [Alt]+[O]  comuta  entre  edição 
proporcional de vértices ligados e não ligados. 

 

Em  modo  edição  [Shift]+[O]  comuta  entre  o  tipo  de 
curva de influência da edição proporcional. 

Proportional  Edit  é  indicada  para  produzir 
transformações  suaves  na  malha  de  um  objecto, 
propagando  as  acções  efectuadas  sobre  os  vértices 
seleccionados a  todos aqueles que  se encontrem numa 
região circular de raio controlado por [MW]. 

Para não  influenciar os vértices que, embora dentro da 
área da circunferência, não se encontrem imediatamente 
ligados  à  malha  em  edição  pressione  [Alt]+[O],  ou 
seleccione  o  respectivo  menu  disponível  na  barra  da 
janela 3D, figura 2.196 e figura 2.197. 

 

 

 

Figura 2.194 

 

Figura 2.195 

 

Figura 2.196 

 

Figura 2.197 
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Existem 7 diferentes modos de a edição proporcional se 
propagar  na  zona  de  influência,  seleccionáveis  com 
[Shift]+[O],  a  partir  da  barra  da  janela  3D, 
[Mesh>Proporcional  Editing  Falloff],  ou  através  do 
respectivo na mesma barra, figura 2.198: Random, figura 
2.199; Constant, figura 2.200; Linear, figura 2.201; Sharp, 
figura 2.202; Root,  figura 2.203; Sphere,  figura 2.204; e 
Smooth, figura 2.205. 

 

 

Figura 2.198

 

Figura 2.199 

 

Figura 2.202 

   

Figura 2 Figura 2.200  .203 

   

Figura 2 Figura 2.201  .204 

 

 

 

Figura 2.205 
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16.10. Snap During Transform. 
Tabela de 
Operadores  Shortcut  Menu  Barra 3D 

 

   [Shift]+[Tab]   

Snap  During  Transform  pode  ser  evocada  a  partir  do 
menu  dedicado  existente  na  barra  da  janela  3D,  figura    
2.206. 

 

Em modo objecto ou em modo edição, pode evocar Snap 
During Transform pressionando [Shift]+ [Tab]. 

Snap During  Transform  pode  ser  usado  em  simultâneo 
com uma operação de  translação, rotação, escalamento 
ou  extrusão,  permitindo  alinhar  ou  fazer  coincidir  os 
elementos  (ou  objectos)  seleccionados  com  um 
elemento (objecto) alvo. 

Por  exemplo,  admita  que  quer  deslocar  os  vértices 
seleccionados  na  figura  2.207.  de modo  a  que  fiquem 
sobrepostos aos vértices imediatamente abaixo. Basta: 

1. Activar Snap During Transform, [Shift]+[Tab]. 
2. Activar Grab, [G]. 
3. Deslocar  o  rato  para  a  proximidade  do  alvo  e 

pressionar [MLB] para confirmar a operação. 

Note na figura 2.208 a pequena circunferência a branco, 
indicativa da posição do alvo. 

O  tipo  de  alvo  é  especificável  no menu  Snap  Element, 
figura  2.209,  e  o  tipo  de  alinhamento  (no  que  diz 
respeito  ao  conjunto  de  elementos  seleccionados)  é 
especificável no menu Snap Target, figura 2.210. 

 

 

 

 

 

 

Figura 2.206 

 

Figura 2.207 

 

Figura 2.208 

 

Figura 2.209 

 

Figura 2.210 
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