O’Hailey: Appendix Bonus Materials

Ink and Paint
Animation by Shani Varo, Cleanup by Jason Walling, 2009, SCAD group project.

Lecture Notes

Figure AIP.1

Rough lined animation inked in Flash (left) and Toon Boom (right).

On the group project Jaguar McGuire, the time came to test an ink-and-paint pipeline. While
shots were still moving through their 2D and 3D animation stages, the rough animation stage had
been completed for a few 2D shots that did not have 3D animation. We had many shots in which
just the cat character was shown on screen. The animations that we will work with in this
appendix are in a rough animation stage. There are more inbetweens to be added and, of course,
cleanup still needs to take place.

All of the cat images in this appendix have been animated by the ever talented and hard-working
Shani Vargo during the SCAD 2009 BFA Animation course.

While working out what software would be best to use for ink and paint, we also wanted to test
how rough of a line quality could be used? The art director and director looked at John Henry,
101 Dalmatians, and other rough-lined animation examples as inspiration. We then took the
rough animation and decided to test ink and paint with it as is, without cleanup. We didn’t expect
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the final line to stay as rough as it was in the rough animation stage; it would be cleaned up
somewhat. However, pushing this extremely rough line through for pipeline testing would give
us a worst-case scenario.

The following is what we uncovered in these tests.

Toon Boom

The first test was to try and use Toon Boom. This software has wonderful tools that help speed
up the ink-and-paint process. Because we were dealing with a fast-approaching deadline and had
an extremely small staff by the time we reached the back end of the process, we wanted to see if
the software would work for our look so that we could use these advanced tools.

This is the process we went through. You can test it out for yourselves. The files for this process
can be found in the companion data for this appendix.

Test 1: Bringing Rough-Lined Raster Animation into Toon Boom

The rough animation was completed using Flash and a Cintiq tablet. Inside of Flash, however,
there is not a way to export raster images that are not compressed. Because most of our other
pipeline included exporting movie files (without compression), this wasn’t that large of a
setback.

Figure AIP.2
File name: Untitled-1 j Save I
Save as type: PNG (*.png) _VJ Cancel

ﬁ Flash Movie [*.swf)

Enhanced Metafile (*.emf)
Windows Metafile [*.wmf]
EPS 3.0 (*.eps)

Adabe lllustrator [*.a1)
AutoCAD DXF (*.dxf)
Bitmap (*.bmp)
JPEG Image [*.jpg)
GIF Imaae [*.aif

Flash does not export tga or tiff sequences.

1. You can start with the file JM_ani_shot_06_v4.swf. Import this swf into a new Flash
document if you want to click along.
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2. First, export a movie file from Flash by selecting File > Export Movie. Then in After
Effects bring the movie in and export a tga image sequence under File > Export > Image
Sequence. You can see in Figure AIP.3 that the alpha channel is present. (It is always
good to check now before getting into the ink-and-paint package.)

Figure AIP.3
Fle Edt Yew lnsert Bodfy Text | Ble Edt ComposSon Layer Effect Anmaton
[ Culeh e 3
Open... (=] Cpen Project. . crlo
Brovese... Crlalt+ 0
[Brovese Template Projects...
Chose el
Clase Project
gave crl+s
Saype AS... Crl+Shift45
Save & Copi...
Increment and Save [
[mport: [
Import Recent Footage: »
| egon ¢
= Cormaigate Al Footage
Brit... = Riepove Unused Footage
Flash Reduce Froject
sengl...
BRShGe, Watch Folder...
Egt Cul+Q oot

Getting a sequence of tgas from a movie file.

3. Next, start a new scene in Toon Boom, making sure to match the correct frame rate and
image size (Figure AIP.4).
Figure AIP.4

“STUDIO,

MNew Project- —Open Recant
Mo file is available
[ Browse...
Name: |§'r_lt39| Create... |
|
Format: |Custom ;I

} Frame Rate: |2-1
. Camera Size: I 1280 X |?20

r—Open Tutorials

| @ Quick Start
| @& Cut-Out Video
) Crananlanninn

A new scene in Toon Boom.
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4. Locate the Exposure Sheet tab at the bottom of the screen. By default it has a drawing
level there. We’ll see the difference between drawing levels and image levels in this
tutorial. Right-click on the drawing level and choose Import and Vectorize > From
File.... (For my students, usually a “...” in a name means that another window is going to
be opened—not all the time, but usually that is the meaning.)

Figure AIP.5
| Timeline [Scene-1] - [Frame 1] X | Exposure Sheet [Scene-1] x|
smig/rads

4 Drawing |

b lwim -

'o‘oa‘q @

Drawing level in the Exposure Sheet tab.

Figure AIP.6 "
Remove Exposure E
Set Exposure fo 1 Cirl+1
Set Exposure to 2 Cirl+2
Ch
Set Exposure... Ctr
Extend Exposure...
Insert Cell...
Insert Blank Cel shift+R
Delete Blank Cell Shift+£
Create Cyde...
Create Advanced Cyde...
Duplicate Drawing
Clezr Drawing
Lock Drawing
Import Hustrator... |
C 1+ From TWAIN...
Select TWAIN Source...
CREEImE]
Timeline [Scene-1] X | FunctionEditor X
| B4
£ Drawi

Importing and vectorizing raster images.
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5. The file browser opens up. Toon Boom does not autorecognize an image sequence. You
will have to shift-select all of the images to import. Click Open.

Figure AIP.7
open 21 x|
Lookin: [ &5 Shot_6_IP ~| & @ ckER-
C600001.tga C600016.tga C600031.tga C600046.tga
L ]c600002.tga -] C600017.tga i ] C600032.tga C600047.tga
- 1c600003.tga -] c600015. tga -] c600033.tga
L] c500004. tga -] C600019. tga -] C500034. tga
000 L] cs00020.t0a -] 6
L ]c600021.tga -] c60
CEESe B e
1] C600023. tga -] C600038. toa
. 600024. tga L-]c600039.tga
L s L] c600040.tga
Eﬁ;"me ale L-]cs00041.tga
ory
2.tga -] c600 ] ce00042.tga
?; CoOODlS‘ tga [l c600028. th [-]c600043.tga
toI;_Ie); i L] c500014.tga -] C600029. tga -] C500044. tga
AtLz74.10-Ts WL.]cs00015. toa -1 C600030.tga - C500045. tga

-
My Network File name: I"CEDDDEZtga" "Ce00001tga" "Ce00002 tga" j Open

Places

Files of type: ]Suppurted Image Formats (" fpix ~fpx ~.gf ~jp2 j Cancel

Shift-select all images.

6. A preview window opens where you can see what exactly the vectorization is going to
look like. You have the ability to smooth or sharpen your image. Toon Boom works great
for drawn cleanup lines. However, it generalized the rough animation line into what one
would expect from a vector algorithm. You might be able to get an interesting look from
this by-product of vectorization.
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Figure AIP.8

<& Import And Vectorize Settings

Preview I

Vectorization preview.

7. In Figure AIP.9, you can see that the cat animation is visible on the disk and in the
exposure sheet. Remember that the image you see on the disk is a preview and at render
time it will appear smoother. To see a render, you would select Play > Preview Movie.

Figure AIP.9
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Cat images vectorized and in exposure sheet.
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Stepping back for a moment, we tested some of the other settings in step 4, Import and
Vectorize. What would happen if you had selected Vectorization Type: With Texture? Glad
you asked. We wondered too.

Figure AIP.10

& Import And Vectorize Settings lli'

:] —Files

| catd0050. toa, cat00051.tga, catD0052.taa, J

—Vectorization Type

" Black and White
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" Smoothing + Greater Loss Of Sharpness
" Edge Enhancement

" Sharpening With Clearness
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Preview |

0K Cancel

Testing vectorization with texture.

You will notice right away that the clumpy vectorization does not happen. Instead the rough line
is maintained. However, in our testing we were unable to ink and paint an image brought in this
way. Perhaps more testing is needed.

We will now continue to paint the vectorized cat that looks simplified. We will use the autopaint
feature in Toon Boom to see if it will speed up our painting process:

1. First we will turn on the Onion Skinning feature to allow us to work with multiple
images. Click View > Onion Skin > Turn Onion Skin On.
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Figure AIP.11
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Turning on the Onion Skinning feature.

2. Next, locate the color palette and add colors for your scene. The nice thing about Toon
Boom is that these colors can be changed even after everything is painted, and all of the
painted cels will be updated—an absolutely necessary feature when working with art

directors.
Figure AIP.12
Color Palette X | Properties X | Library X |
Name IBiu'nap Import ~| B
Style IDefau!t LI
Q *+ = @
ink

The color palette.
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3. To paint, select the correct color and the painting tool. They can be found in the toolbox
on the left of the screen or under Tools > Drawing Tools > Paint.

Figure AIP.13
Ge Edt View Play Element | Tools Window Help
”UC’JEl- ll % select ! JJ% Q”fru/fr
e s p Sceneplanning Tools ' B Contour Editor 2 % A a
'Q - | K Zoom % £ Perspective
ﬁ’ & Grabber il ‘¥ Reposition All Drawings
4 Brush -]
8- — .
# = O Rectangle
O Elipse
Q- - £ Polyine
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b S — |
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& Eraser s
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Selecting the paint tool.

4. While using the paint tool, hold down the Shift + Alt buttons on the keyboard. This will
cause the paint tool to do its best to autopaint the rest of the animation! It tries to track the
vector areas and paint them the color you have selected. It works for many frames; for
other frames, it becomes confused. You will have to go through each frame to double-
check. You were going to go through each frame anyway. Autopaint has reduced the
amount of clicking you were going to have to do. The image in Figure AIP.13 was
completely autopainted. Many frames afterward looked perfect as well. Some needed to
be touched up (Figure AIP.14).

Figure AIP.14

Holding Shift and Alt to autopaint the animation can give good results on the first frame.
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Figure AIP.15
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Autopaint can miss some areas but ultimately saves clicks.

5. A useful method for inking and painting is to be able to drag a box around small areas so
that you can fill them in. In Toon Boom this tool is called Paint Unpainted, and it is
found under the Paint tool option in the toolbox.

Figure AIP.16
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Paint Unpainted for small areas.
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Toon Boom has many timesaving features in its ink-and-paint portion. New versions continue to
work on compositing and production-driven features. You can see the rough animation with its
ink and paint from Toon Boom in the file cat_6_IP_TB.swf. Just to prove this is the rough
version, you can see the final version in the companion data titled catHighres.mp4.

Figure AIP.17

# Adobe Flash Player 9

Eie Yiew Control Help

1 T T
E(S|SR 8 88Y Y GEeE R e Ry ®RRE

Final painted image and test render.
Figure AIP.AA

Animation by Shani Varo, Cleanup by Jason Walling, 2009, SCAD group project.
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Test 2: Keeping Animation in Flash for Ink and Paint

For this test we stayed completely inside of Flash for rough animation and ink and paint. This let
us keep our rough line, and we stayed completely within the vector. We made sure to keep our
ink and paint on separate layers in case any compositing tricks need to be done later on.

1. Inside of Flash, duplicate the ink layer and rename it paint. Lock and hide the original

ink layer.
2. Select the paint bucket tool and create the color needed.
Figure AIP.18
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Selecting paint bucket and color in Flash.

3. In the options area for the paint bucket, select Close Large Gaps. This will allow us to

fill in areas of our cat that have sketchy lines. There are still some areas that have gaps
that are too large to fill.
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Figure AIP.19

Setting for Close Large Gaps.

4. To fill the gaps that are too large for the paint bucket tool, select the brush tool and
choose the option Paint Behind.

5. Paint in the areas of the ink line (with the paint color) where there are large gaps (Figure
AIP.20).

Figure AIP.20
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Copyright © 2010 Elsevier Inc. All rights reserved.



Using the paintbrush to close the gaps.

6. With this paint in place, you can now use the paint bucket tool once again to fill the
unpainted areas.

Figure AIP.21 {r

LY
=

The completely painted tail.

7. Use the paintbrush with the Paint Behind option to continue to paint in small areas.
Figure AIP.22

Use the paintbrush with the Paint Behind option to touch up small areas.

In the companion data for this appendix, you can see the rough animation with ink and paint
from Flash in the file cat_6_IP_Flash.swf.
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