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Chapter 2: 3D Character Leads 2D 
Character 

Printing and Pegging Process for 3D leads 
If you can plan on drawing your 2D with pencil and paper you will need to export 3D images to use as 

reference. The following is a method to print and peg up, or register, your images for the 2D animator. 

There are many methods. We’ll come up with one together here that uses software you might already 

have, versus using a batch, python script or C++ utility.  

Crosshairs and Frame Number 
Whether you prepare your reference images to print through a 3D package or as a post-process script 

that runs over the rendered images, you will need to do the following to your images: 

 Create crosshairs in each corner of the image. 

 Create the image name and number in the bottom of the image. 

 Print each image with the crosshairs and image number. 

 Put the first image on the animation disk and tape a pegstrip (or header strip) to the bottom of it. 

 Each image after that should be placed so that the registration marks match the first image’s 
registration marks, and tape a pegstrip to the bottom of them. 

 Roll through the images as you go to ensure proper registration 

 Shoot a pencil test of the pegged prints to make sure you have done a good job. 

 If there is too much wiggle in the reference images when shot, isolate the issue (printing or 
pegging problems) and re-do. 

It is possible to have wonderful 2D animation registered to 3D animation; however, the above process 

must be near perfect in order for that to be accomplished.  This is the process that separates the 

perfectionists from others (or displays how much budget you have to do re-dos). 

You could try printing directly onto pegged paper. You might be lucky enough to have a printer that 

does not shift during the printing process. I had one printer that had perfect registration, but it finally 

died. It was an Epson. There are a few issues that might come up with printing directly onto punched 

paper:   

1. image shift caused by punched holes or the printer itself 

2. paper jams caused by punched paper  

It is worth a test to see if your printer will do a good job. Print directly onto punched paper and shoot a 

pencil test to see how well it registered the images.  If you have a great printer, let us know on the 

forum because you just saved yourself a lot of time.  Don’t trust it though, always shoot a pencil test to 

make sure the images are not moving or popping throughout the animation. Longer printing runs might 

cause heating and thus expansion of the printer’s components.  Over time, the printer with perfect 

registration can start to go astray. Be vigilant in your watch. 

What is a pegstrip or header strip?  They come in a few varieties and can be found at any animation 

supply store (online).  It is a strip of paper or polyester that has peg holes punched in it.  The strip is 

usually only an inch high.  This strip sometimes comes with adhesive tape on it so that it can be taped 

to your un-punched drawing or print.  The reusable polyester strips do not have adhesive. You have to 

use your own tape.  Personally, I am cheap.  I take strips of paper, cut them to size with a paper cutter, 
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and punch them.  I use my own tape to tape them onto the un-punched prints. I would rather spend the 

money on peg reinforcers. You can’t do without those. 

How Can We Use the Tools We Have to Let Us Print Reference Images? 
I will bet there are many ways to approach this problem.  You could make crosshairs in Maya and then 

render and print out the images.  You could probably use After Effects or any other software on your 

desk. 

Personally, I have been wanting to try something out. This is an excuse to do so and I’ll show you a 

little bit of my learning process along the way.  I used to learn so much just watching people solve 

problems.  The end solution was nice, but watching them think taught me a bundle. 

I would like to use Photoshop for creating registration marks and putting image names on our reference 

renders. I don’t know JavaScript and only have a clue that Photoshop can be scripted. I saw a class at 

EA where they had absolutely automated Photoshop. It was an amazing time saver.  I’ve never had a 

reason to try it, until now. So, I have set out to make a script to do what we need.  Join me on this 

learning journey.  (Those not caring, skip ahead to the hands-on portion. Us geeks will meet you there.) 

Learning to Automate Photoshop 
First, I wrote some pseudo-code of what it was I wanted to do.  I’d be lying to you if I didn’t admit I do 

know how to code a bit. 

 

set endFrame    //set how many frames I have 

set variable for frameNum   //set start frame 

 

for i <= endVariable, i++   //a for loop that will do the following for each frame 

set text layer to frameNum  //create a text layer with the frame number on it 

save image seqeuence for frameNum  //save that image 

frameNum++   //up the frame number count 
 

Knowing what I wanted to do helped me look at code snippets to piece together the syntax of 

JavaScript. This is an easy enough script, I could cut and paste lines from various scripts for my needs. 

I looked at these sites to help me learn the syntax of JavaScript: 

 http://www.outbackphoto.com/workflow/wf_a102/essay.html 

 http://www.kirupa.com 

 http://www.ps-scripts.com/bb/  

Within a few minutes I was able to write the first bit of code: 

 
var AD = activeDocument;   //refers to the open document 

var endFrame = 10;    //end frame 

var frameNum = 1;    //beginning frame number 

 

var TextLayer = AD.artLayers.add();  //Add a layer 

 TextLayer.kind = LayerKind.TEXT;//Make it a text layer 

 

var txtRef = TextLayer.textItem;  //Set that text layers attributes 

 txtRef.font = "Impact"; 

 txtRef.size = "14"; 

 txtRef.position = [.1, .5];   

 

for ( i=0; i <= endFrame; i++)  //A loop that will do the following for each image 

{ 
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 txtRef.contents = frameNum; //Change the text to say the frame number 

 

 //save image sequence for frameNum 

  

 frameNum++;   //Up the frame number by One. 

} 
 

This little script does the numbering but does not save the image. I could find how to save a normal 

image, but not a video layer, using Export > Render Video.  Hmm.  I turned toward the 

documentation. Documentation can seem scary at first, especially for scripting languages.  Honestly, 

after the first language, you will find that the second language and others will start to seem similar. 

I looked at the Photoshop CS3 JavaScript Reference that was installed with Photoshop. I was dismayed 

to not find all of the features of Photoshop included, but not surprised. 

I could post a request out on a forum to see if anyone knows that answer. That would take a bit of time, 

but worth the effort. 

However, there isn’t only one solution, or one way to look at the problem. So, in the meantime, I 

decided to look for another way to solve this problem. 

I looked at it another way.  Here is the new pseudo-code:  

 View the image as a video layer in Photoshop 

 Create Registration Marks  

 Save image sequence 

 Run batch on images 

 Batch opens each file and calls Action 

 Action runs script that adds image name  

 Batch saves the image 

 Job done 
This actually makes the script much smaller and only handles the updating of the file name on the 

image. It uses functionality that already exists in Photoshop. 

With just a little research (and some understanding of what objects are, but that is beyond the scope of 

this book) I came up with the following simpler script to use in combination with batch processes: 

 

//You set these variables 

 

var myFont = "Impact";   //font to use 

var myFontSize = "10";   //font size 

var myXPosition = .1;    //X position 

var myYPosition = .5;    //Y Position 

 

 

////////////// 

 

 

var AD = activeDocument;   //Active Document 

 

var imageName = AD.fullName;  //returns the file object 
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var TextLayer = AD.artLayers.add(); //Adds Layer 

 

TextLayer.kind = LayerKind.TEXT;  //Makes it a text layer 

 

var txtRef = TextLayer.textItem;  //Sets font, size and position 

txtRef.font = myFont; 

txtRef.size = myFontSize; 

txtRef.position = [myXPosition, myYPosition];  

 

  

txtRef.contents = imageName.name;  //Sets file name 

  

Hands On 
Everyone back together now? Now to test out our new creation: 

Load in the reference images as video layer(s)  
 

 
Figure3.IN.1 Video Layers in Photoshop 
 

Using the Text tool create registration Marks.  In Figure3IN.1 we used Webdings font and used “r” to 

get the X marks. Create Registration Marks in the four corners of your reference image. 
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Figure3.IN.2 Duplicate Text to create X registration marks 
 

Save out an image sequence by clicking on File > Export > Render Video…  No alpha channel is 

needed for this print. 
 

  
Figure3.IN.3 Save an image sequence 

 

Now you could go ahead and print these images and begin pegging them up, or you could opt to do the 

next few steps to put the image name on them. This next step could be done many ways. I wanted to 

show off scripting in Photoshop. 

First let’s make an action that runs our script: 

 Locate or open the Actions panel by clicking on Window > Actions. 

 Create a New Action by clicking on the new icon. 

 Give the Action a name. We called ours “RunScript” 
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Figure3.IN.4 Creating an Action 

 

Click on File > Scripts > Browse.  The new action that you created is recording all of your steps 

automatically, indicated by the red circle at the bottom of the Actions Panel. 
 

 
Figure3.IN.5 Opening a Script 

 

Locate the JavaScript (remember to change the File type to .js, else you will not find what you are 

looking for!) imageName.js. Click on Load. 

 

 
Figure3.IN.6 Our imageName.js script. 

 

This will run the script. The script will create a text layer with the name of the image. See Figure 
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3IN7.tiff 

Click on the stop button in the Actions panel (see Figure 3IN7.tiff). 
 

  
Figure3.IN.7 After the Script has run 

 

Where do you want that text to go? 

Use the Move Tool to position the text. 

Look in the Info panel to see the position of the text. Mine is: X = 2.222 Y = 3.174.  The position is 

based on where your cursor is. Pick the left hand bottom of the text. 

 

  
Figure3.IN.8 Getting position of text 
 

Write that down. We’ll adjust the script to put the text in the correct spot on our image sequence. 

Open the imageName.js in Wordpad or Notepad or a text editor of your choice.  Change the X and Y 

variables to the position you found in step two above (see Figure 3IN.9.tiff). 
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 Figure3.IN.9 Customizing script with text position 
 

Save the script. 

After all of that, you are ready to batch call this script. For just 18 images, it doesn’t seem that magical.  

If you had, 300 images times 25 shots: this workflow of batch running a custom script is mystically 

magical fun. 

The last section of this will not use Adobe Bridge as we have before for renaming. Though its batch 

function seems to be the same as Photoshop’s, it will not work with this script. It does not suppress 

command pop-ups. Odd and sad. Instead we will use Photoshop itself.  That works just as well. 

In Photoshop: 

 Click on File > Automate > Batch 

 In the window that opens, select the following: 
o Action > RunScript  (the action that we created before) 

o Source > Folder and select the image sequence with crosshairs that we saved. Mine is in 

a folder titled: Image_Sequence_Reg_Marks 

 Click on “Suppress File Open Option Dialogs” 

 Click on “Suppress Color Profile Warnings” 

 Set the Destination Folder 

 Starting Serial # does not matter in this case 

 Click on OK  
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Figure3.IN.10  Batch running script on image sequence 
 

The batch process will open each image from the image sequence and run the custom script.  The 

custom script adds the image name.  The batch file saves the image into the destination folder. The only 

thing that pops up to annoy one is the TIFF save option box.  You will have to click on OK for each 

image.  

 

 
Figure3.IN.11  Tiff save option box 

 

As an exercise you can come up with a way to streamline that even further.  What is it about that first 

image that kept us from being able to save a jpg sequence?  A trick to problem solving is always asking 

why, and give yourself time to figure it out, instead of giving up and saying “I don’t know why it did x, 

y, or z.”   

I took a moment to look at another automating function in Photoshop. You can create a droplet that is 

an executable file.  Then you are able to drag and drop an image or a folder on top of the executable 

and it will run automatically. 

In Figure 3IN12.tiff I created a droplet to call the script. This created an executable.  To run, I simply 

drag the folder of images onto the executable.  I still get save option pop-ups, but it was a few less 

clicks.   

 
Figure3.IN.12 Creating a droplet 

 

At this point I will live with the option boxes that pop up.  Another trick to problem solving is knowing 

when you are spending more time to fix a problem than simply moving ahead and completing the task 

at hand.  (I say this, like I am some wise, old problem solver. I just have rules and tips I live by, and tell 

them to anyone who will listen. I can’t wait until I’m 60 . . . I’ll be incorrigible then.) 

The crosshairs and image names could have been achieved many different of ways. I would much 

rather have a Python script or use Shake, but I chose to use something that was more accessible to 
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students. After Effects might be a good choice to see if it can auto-update names or frame numbers and 

save an image sequence. In fact, I’ll bet that would work great.   

Now you can print the images and begin the pegging process. You will need some supplies: 

 Printed images 

 Blank punched paper or header strips 

 Tape 

 Disk with peg strip and back light 

 

Figure3.IN.13 Your supplies. 
 

Pegging is easy, but take your time to make sure the registration is near perfect. Place the first image on 

the disk with the header strip 

 Tape it into place 

 Place the second image and header strip onto the disk 

 Line up the registration marks with the previous image 

 Tape down. 
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Figure3.IN.14 First image pegged. Preparing to peg second drawing 
 

Make sure to flip between the two images to make sure the registration marks are aligned. 
 

 
Figure3.IN.15 Flipping between images to see registration marks line up. 
 

You can turn on the backlight to help see the registration marks. 

Continue with the third image. 

Remove the stack of images from the pegbar when it gets full. Keep a pegged-up image on the pegbar 

and continue with the next set of images. 

Repeat until done. 
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Shoot a pencil test to make sure that the registration was done well. 


