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Compiling and Linking CVIPlab with Visual Studio

1. Install CVIPtools and CVIPIlab

2. Choose the desired location for the installation — in this guide, we use
C:\CVIPtools\CVIPlab as the working folder.

3. Run Microsoft Visual Studio.

4. Open the CVIPIlab solution file, CVIPlab_Project.sIn, in C:\CVIPtools\CVIPlab as

shown:
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(a) Select Open->Project/Solution
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(b) Select the file CVIPlab_Project.sin.

5. Build the project by selecting Build = Build Solution as shown:

Building the project.

X
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6. Activate the output window by selecting Output from the View menu, or press Ctrl+W, O

(if it is not shown). CVIPlab_Project should be compiled with O errors as shown below in
(a), and the executable file is located in C:\CVIPtools\CVIPlab\Debug. It should be noted



that it is not unusual to get warning messages during compilation

. These warning

messages should be investigated as they may indicate poor programming practices that

can cause problems. In this case, the last few warning messages are due to variables that

are not referenced, meaning they are not currently used in the program. Here, these

variables are included for future use so we will not be concerned with these warnings.
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(b) Screen after running CVIPlab and performing a threshold operation on cam.bmp. Note that
CVIPlab requires a complete path name for the image files; or the images can be put in the same
directory from which CVIPlab is running.

7. Press F5 to run the program. Select ‘2’ and enter the file name for an image in the
directory, or enter the full path name for an image elsewhere — here we used cam.pgm
from the C:\CVIPtools\images directory. Enter a threshold value to perform the threshold
operation, as shown in (b) above. If you see this, CVIPIlab has complied and run
successfully!

8. If the computer being used has video capture capability, add this to your CVIPlab as
follows: Open file cviplab.c, go to the #define VIDEO_APP line directly after the include
header section, modify the video/image capture string to the executable you plan to use,

as show below:
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9. Run CVIPlab project by pressing F5. Select 1, and your video/image capture application

will run.



The Mechanics of Adding a Function with Visual Studio

The following guide provides a step-by-step process for those unfamiliar with Visual

C++. For those familiar with Visual C++, or those planning to use another compiler, skip to the

next section, which provides details for adding a CVIP function to the CVIPlab menu.

To add a function using Visual C++:

1. First add a new file by right clicking on the Source Files folder in the Solution Explorer

window on the left. Then select Add->New Item as shown in (a) below.

2. From the upcoming window select C++ File (.cpp) and input test_new_file.c as the name, as

shown in (b) below. Even though the C++ File option is selected, be sure to keep the extension

“.c” for the new functions or files. Otherwise, compilation errors will occur.
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a) From the Solution Explorer menu, right click on Source Files and select Add->New Item,
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b) Select C++ File (.cpp), ais shown with an arrow, and name the new file “test new _file.c” and
press Add button
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c) Select test_new_file.c from Solution Explorer menu and type in your function body.

3. Click Add button and enter the text below in test_new_file.c, as show in (c) above.

int test function (int 1)



return i+1;

}
4. Right click on test_new_file.c (located under CVIPlab_Project\Source Files) and select

Properties. From the upcoming window expand the C/C++ selection on the left and select

Precompiled Headers as shown below. Check the text box Create/Use Precompiled Header to

make sure that Not Using Precompiled Headers is chosen. If it is chosen click OK, if not, click

on the text box to change the selection.
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a) Right click on test_new_file.c and select Properties. From the upcoming window, expand
Configuration Properties, then expand C/C++ and select Precompiled Headers
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b) From the Precompiled Headers section, click the combo button next to the Create/Use
Precompiled Header, and select Not Using Precompiled Headers

5. Select Build->Build Solution from the menu bar above, to compile the project again. There
should be no errors in the output box.

6. Double click on CVIPlab.h and CVIPlab.c to open them.

7. Find this line in the CVIPlab.h file:

extern Image *threshold lab(Image *imageP, unsigned int level)
And directly after it add a new line (see screenshots below):

extern int test function(int 1i);
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(a) Declare the new function in the header file CVIPlab.h
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(b) Call the new function in CVIPlab.c.

8. Build the project again. It should pass the build without any error (Warning messages are OK).



9. Call this function in the main function of CVIPIab.c by inserting the following line:

print CVIP("test new function, return value is %d\n",test function(5));
after the function declarations; as shown in (b) above.
10. Select Build->Build Solution to build the project. There should be no errors (again, you can
ignore warnings)
11. Run the project by pressing F5. You should see:

test new function, return value is 6
in the second line of the console window as shown below. If you see this, you have successfully

added a new function to the CVIPIab project.
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Using CVIPIlab in the Programming Exercises

The previous section outlines the mechanics of adding a function with Visual C++. To follow the

existing file organization and program format using any compiler, do the following:

1. Create a file similar to threshold_lab.c for the new_function. The easiest method is to select

the threshold.c file and perform a Save As the new_function.c. Next, edit the header to change

the file name, description, modify the date, add your name, and change the old comments and the

function name. The last step is to modify the code inside the band, row and column for loop to

perform the new function, as shown:
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P @ threshold_lab.c | byte **image; /* 2-d matrix data pointer */ 1
35 ' unsigned int r, /* row index */ 1
s e InTe T T M = mm e e e e e =
4 b 85% -~
Ready Ln 22 Col 21 Ch21 INS

(a) Create your new function by using the threshold function as a prototype. Edit the header to
change the file name, description, modify the date, add your name, and change the old comments

and the function name.

]

saladold  Xoqjoo|
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M CVIPlab_Project - Microsoft Visual Studio (Administrator) Quick Launch (Ctrl+Q) P = =2 X
FILE EDIT VIEW PROJECT BUILD DEBUG TEAM SQL TOOLS TEST ARCHITECTURE MATLAB SQL PROMPT ANALYZE WINDOW HELP

Q- a < I P Local Windows Debugger ~ Auto - Debug__ - = =R R I
Solution Explorer * I X cviPlabh CVIPlab.c threshold_lab.c + X EESEEY - §
G} -9 " (Global Scope) threshold_lab(Image * inp age, unsigned int threshval) v E
: . : ) e 59 ** Compares the pixel value at the location (r,c) %= ‘\2
SealthiSouHonlExpiored(El 60 ** with the threshold value. If it is greater than Be sure to update -~ 3
& Solution 'CVIPlab_Project’ (1 pro 61 ** the threshold value it writes 255 at the location i
4 5 CVIPlab_Project 62 ** else it writes @. Note thta this assumes the input comments here and E,i
i 63 *k i f data t BYTE. g
P & cvip header . image 1s or data type everywhere ]
P & External Dependencies 64 / -
P ® Header Files 65 for(bands=8; bands < no_of_bands; bands++) { ]
o
b s library 66 O /* g
€ R 67 ** peference each band of image data in 2-d matrix form; o
esource Files 68 ** which i d f di d writing the pixel val i
4 & Source Files - 5 which is used for reading and writing the pixel values
P - CVIPlabc . 70 image = getData_Image(inputImage, bands);
P+ CVIPlab_Project.cop . - n
- 71 for(r=0; r < no_of_rows; r++) {
Eo [Tl ZEEE 72 far (er0im . 20_af colse Gt H
N FP——— A —
S 7o ifCmsgelr)[c] > (byte) threshval) | Modify code to
P~ test new file.c 74 image[r][c] = WHITE_LAB; 1 perform the new
P+ threshold lab.c 75 1 else
76 1 image[r][c] = BLACK_LAB;| 1 function
77 I I
78 } -
100% ~ 4 »
’ Output s ; 2 2 R : 2 : 2 2 B 2 . e X
Ready Ln 76 Col 41 Ch 36 INS

(b) The last step is to modify the code inside the band, row and column for loop to perform the
new function.

2. Add the new function to the CVIPlab menu as shown in (a) below. Next, add a case statement
for the function as shown in (b) below. The case statement code for case 2 can be copied and

used by modifying threshold_Setup to new_function_Setup.
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M CVIPlab_Project - Microsoft Visual Studio (Administrator) Quick Launch (Ctrl+Q) P = a X
FILE  EDIT  VIEW  PROJECT BUILD DEBUG  TEAM SQL TOOLS TEST  ARCHITECTURE  MATLAB  SQL PROMPT  ANALYZE ~ WINDOW  HELP
- (TR~ = " E P Local Windows Debugger = Auto ~ Debug ~ Win32 - A | h=I R | .
v
Solution Explorer v B X CVIPlabh mlﬁam threshold_lab.c test_new_file.c - 3
@ ®-a2@ =~ (GlobalScope) « & main_cviplab() - ;
53 lvoid main_cviplab(){ + 2
Search Solution Explorer (Ct £ ~ 54 IMAGE_FORMAT format; /* the input image format */ . 9
@ . - 55 Image *cvipImage; /* pointer to the CVIP Image structure */ g
Solution 'CVIPlab_Project’ (1 pr: 56 Image *cvipImagel; /* pointer to the CVIP Image structure */ =
4 % CVIPlab_Project 57 char *outputfile; /* output file name */ a
P& cvip header 58 int choice; g
b W E 1D dl . 59 CVIP_BOOLEAN done = CVIP_NO; £
@ External Dependencies o -
4 & Header Files 61 print_CVIP("test new function, return value is %d\n", test_function(5)); TOJ
b & CVIPlab.h 62 =Y
X 63 PILAE_CVIP (" AN\ NN\ R * 5 5 KK 5 KKK R KK R KRR ) =3
P B CVIPlab_Projecth P PILE_QVIP( " K Kxkod i 65 S KKK KRARKERHHAK 1Y 3 A
> © Resourceh 65 print_CVIP("\n*\t\t Computer Vision and Image Processing Lab\t *");
B resource.h 66 print_CVIP("\n*\t\t\t <Your Name Here> \t\t *");
> 0 e 67 PIPLITE_CVIL "\ % 556 3 5 K K KK 65 ¢
b ) . 68 PRANt_CVIP( /= #*=msssssmmssnnnnmnsns e\ n\n\n Y
i |ibrary 69
# Resource Files 70 while(!done) {
4 & Source Files 71 print_CVIP("\t\t@.\tExit \n");
b« CVIPlab 72 print_CVIP("\t\tl.\tGrab and Sna Image \n");
abe 73 [ = P CWIP (o 2 MaThiss shal dadpaaation \n")
b = CVIPlab_Project.cpp 74 print _CVIP("\E\t3.\thew Function \n")y Add here
0 CVIPlab_Project.rc 75 = TRrTe TVIFT M TUIFTL T T T
- e
StdAfx.cpp. 78 .
P+ test_new_file.c 78 ** obtain an integer between @ and CASE_MAX from the user
P+ threshold lab.c 79 */
80 choice = getInt_CVIP(1@, @, CASE_MAX);
81 i
4 P 8% -

(a) Add the case statement for the new function to CVIPIlab. a) Add your new function to the

menu.

M CVIPlab_Project - Microsoft Visual Studio (Administrator) Quick Launch (Ctrl+Q) Iy & B e
FILE EDIT VIEW PROJECT BUILD DEBUG TEAM SQL TOOLS TEST ARCHITECTURE MATLAB SQLPROMPT ANALYZE WINDOW  HELP
~ a1 = I < - P Local Windows Debugger ~ Auto ~ Debug ~ Win32 - y-| =’ = p= R | -
s
Solution Explorer v I X CVIPlab.h m!ﬂﬁm threshold_lab.c test_new file.c - g
@& eo-aa " (Global Scope) ~ @ main_cviplab() v i
: o e e e il | =
Search Solution Explorer (Ct £~ o o4 I /*Get the input image */ | N %
. - 95 | cvipImage = input(); =
&1 Solution 'CVIPlab_Project’ (1 pr % I if(cvipImage == NULL) I _
4 % CVIPlab_Project 97 { 3
b = cvip header 28 1 error_CVIP("main", “could not read input image"); I g
. =
> = . 99 break; |
External [I)ependenmes 100 1 } =
4 & Header Files 1e1 1 /* calls the threshold function */ I g
P & CVIPlab.h 102 | cvipImage = threshold_Setup(cvipImage); 1 g
b = CVIPlab Project.h 13 if (lcvipImage) o
3 - 104 | ] { |
© Resource h 105 error_CVIP("main", "threshold fails"); 1
B resource.h 106 | break;
b o Stdafich 7 ) P , !
b s b 108 /* display the resultant image */ 1
iorany 109 | view_Image(cvipImage, "threshold");
& Resource Files 110 1 delete_Image (cvipImage); 1
4 & Source Files B e e A e e e e e e ===
112 case 3:
b+ CVIPlab.c . 113 /*Get the input image */
b+ CVIPlab_Project.cpp 114 cvipImage = input();
O CVIPlab_Project.rc 115 if(cvipImage == NULL)
. 116 {
StdAfx'ch. 117 error_CVIP("main", "could not read input image");
P+ test new file.c 118 break; Copy Here
b+ threshold_lab.c 119 ¥
120 /* calls the threshold function */
121 int x = test_function(8); b
4 b 8% -

Col 13

(b) Simply copy the statement from Case 2, and change the function name and update the
comment.
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3. Add the new_function_Setup to CVIPIab.c, similar to threshold_Setup.
4. Add the function prototype to the CVIPlab.h header file:

extern Image *new function(new function parameters...)
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