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� You may 
already have a 
hard drive full of 
Flash animations 
and applications 
that, with a little 
optimizing, could 
be repurposed 
for the mobile 
platform. From 
Flash to Adobe 
Device Central, 
you already have 
the necessary 
tools available for 
preparing your 
content for this 
exciting and fast-
growing platform.
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Bonus Chapter 1
THERE ARE CURRENTLY OVER TWO BILLION mobile device 
subscribers worldwide, the mobile thus surpassing the 
personal computer as the work and communication 
tool of choice. It is predicted by the year 2010 that the 
number of global mobile phone subscribers will increase 
to over 3 billion. If you are having difficulty deciding 
what platform to author content for, you may want to 
consider going mobile.

Mobile devices do have their limitations, however, 
processing power being the most significant, followed 
closely by lack of memory, small screen sizes and 
bandwith limitations as well. We’ll look at how to create 
an animated screensaver for a mobile device and how to 
test its performance across all supported devices, even if 
you don’t own one. 

3
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Creating a dynamic screensaver

FLASH LITE™ is the mobile 

version of Flash Player 

which is currently available in 

three versions: Flash Lite 1.1, 

which is based on Flash 4 

technology, Flash Lite™ 2.0, 

which is based on Flash 7 

technology and the current 

version Flash Lite™ 3.0, which 

is based on Flash 8 technology. 

From interactive applications, 

games, browser, screensavers, 

to wallpapers and more, Flash 

CS4 will continue to play 

a huge role on the mobile 

platform, providing creative 

opportunities to develop and 

design content for a variety of 

devices.

1Create a new Flash document and click on 
Flash File (Mobile) and click “OK”. This will 

launch Adobe Device Central where you can then 
browse and select the mobile device you wish to 
author your content to.

2Device Central provides detailed information 
of over 450 mobile devices. Browse the Online 

Library panel and select your target device. Then 
click “Create” in the lower right corner. This will 
create a new Flash mobile document.

9 Locate the FPS-Meter extension from the “Chapter 11” folder on the 
source CD. Copy it to your hard drive and double-click it. The Adobe 

Extension Manager will launch automatically and prompt you to install the 
extension. Restart Flash (if necessary), and go to Window > Common Libraries 
> FPS-Meter Lite. FPS-Meter Lite is for Flash Lite 1.1 and FPS Meter Lite 2 is 
for Flash lite 2.x. Drag the FPS-Meter Movie Clip to a separate layer in your 
Flash Lite document and publish your movie. The FPS Meter provides accurate 
feedback when played inside the actual mobile device you are testing on. 
Based on your movie’s performance, you may need to optimize your graphics, 
which is discussed in the next topic.

6 Next create a new layer above the grass 
layer and drag the heart movie clip from the 

Library to the stage. Double-click this symbol to 
see the animation already created. There’s also 
a layer containing some ActionScript in frame 1 

BBoonnuus CChhaappptteerrr 11

that randomizes the animation of this movie clip 
by varying its size and rotation. In the last frame 
there’s some ActionScript that returns the heart 
symbol to the “0” position.

Contributed by Vivek
www.i2fly.com
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3 Next, create a background with 
the Rectangle tool r and a color 

fill. Make sure the shape extends just 
beyond the actual size of the stage.

4 Open luv_i2fly.fla from the source 
CD, and you will find a few movie 

clips and graphics in the Library for 
creating this screensaver.

5 Drag the grass movie clip to 
the stage and align it along the 

bottom edge, making sure it extends 
beyond the stage itself.

7 Return to the stage and drag the 
bg_bar movie clip from the Library 

to the stage on a new layer. This movie 
clip contains some graphics to help 
add interest to our otherwise plain red 
background. 

HOT TIP
Do not leave 
unnecessary 
blank key 
frames or 
layers on your 
timeline. Empty 
frames and 
keyframes 
contain bytes, 
so it’s always 
good to keep 
your timeline 
as clean as 
possible. While 
using vector 
graphics for 
mobile devices, 
it’s always best 
to use the built-
in optimization 
tool which you 
can find under 
Modify > Shapes 
> Optimize. 
Use the slider 
to adjust the 
amount of 
optimization 
based on your 
needs and the 
integrity of the 
shape(s).

Actual stage size

8 Double-click the bg_bar movie clip and you will find some frame actions that 
move the graphics randomly. Of course you also have the option to create 

timeline animations with keyframes. The result of using ActionScript to generate 
randomized motion is a smaller file size than if you created long timelines filled 
with keyframes and motion tweens. 

10 Before you publish your Flash 
content for final deployment, 

remove the FPS-Meter extension from 
the timeline. With Flash CS4 you can 
simply turn off the visibility of this 
layer if you have Include hidden layers
deselected in your Publish Settings. 
For all other versions of Flash, turn 
the layer into a guide layer or delete it 
entirely.
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Optimization
BBoonnuus CChhaappptteeerrr  11

GAME DESIGNERS who understand the 

limitations of the medium used to 

deploy the game, and, especially, those who 

have a programming background are able 

to creatively solve performance issues at the 

highest level, that of the style and gameplay 

design. If you don’t have the horsepower 

to make a compelling simulated 3D game, 

it is necessary to focus on a game design 

that perhaps can provide the same exciting 

gameplay that can still allow for a higher frame 

rate that delivers an exciting arcade experience. 

The best way to become proficient at this is to 

build a wide range of games for a variety of 

platforms with varying system requirements. 

Flash Lite enabled devices, due to their limited 

processor speeds, require the game designer 

and programmer to think outside the box, or 

in this case the desktop PC. From a production 

standpoint it could save days, if not weeks, 

of code and graphical optimization if the 

developer simply focuses on a game mechanic 

and concept that is more “Flash Lite friendly”.

Frame rate
Identifying optimal frame rates that map most 

effectively for both desired gameplay and 

limitations of the target platform is always a 

focus of the serious Flash game programmer. 

Because every game and every platform will 

be different, you can imagine how difficult 

it is to create some kind of formula or table 

that would make this an easier task. It is 

recommended to only go as high as you need 

for the particular game experience, and no 

higher. If the game plays well at 15 frames 

per second, then changing it to 30 frames per 

second is unnecessary and will most likely have 

adverse results. It is best to stick with the lower 

value, especially when dealing with slower 

processors.

Bitmap graphics
Unless your game really relies heavily on 

rotation and scaling, it is best to stick with 

bitmap graphics. Original art can be made 

with vectors, but then parsed into bitmaps 

in Photoshop. This allows you to keep the 

game running in low-quality mode and enjoy 

dramatic improvement in the number of objects 

incorporated into the game as well as improved 

frame rate. You can increase the level of 

quality dynamically on game menus and screens 

that you wish to use for vector art. When 

Contributed by John Say ( www.saydesign.com) 
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HOT TIP
The CPU can 
only do so 
much at any 
given time. If 
you learn to 
structure your 
calculations, 
sounds, and, 
especially, 
animations in 
a way where 
things are 
happening 
in succession 
rather than 
simultaneously, 
you will avoid 
any choking 
points where 
things seem 
to come to a 
screeching halt. 

the user enters the actual gameplay, force the 

quality back to low to optimize playback for 

both animation and ActionScript. Regarding 

which graphic formats are optimal for bitmaps, 

there aren’t any real hard-and-fast rules. 

Sometimes it is best to experiment with a 

few formats before you lock-down on any 

particular one. For critter crossing we stuck 

with 24-bit PNG format with 1-bit transparency 

to avoid making the processor have to deal 

with grayscale alphas. This we felt gave us a 

performance boost. But again, ultimately it is 

best to try a few different approaches and, test 

on the target device, and ultimately you will 

have the optimal strategy for your particular 

game.

Code optimization
There are so many great Flash game 

programming books out there that really go 

into the detail of optimizing code. Flash Lite 

and the devices that employ it demand that one 

becomes adept at understanding what Code 

is friendly, and what work-arounds should be 

utilized in order to contribute to the desired 

end-result. The more you learn these “tricks of 

the trade”, the more you can leverage multiple 

strategies to create outstanding results. Keep in 

mind that just because the Flash Lite instruction 

set may give you a quick and easy way to create 

functionality for your game, you should still 

watch the frame rates achieved once deployed 

to the target platform. Benchmarking a few 

approaches to core functionalities is the best 

thing since you can find that perhaps one out-

performs the others by as much as 200%! There 

are some great resources on the Net that contain 

various benchmarks for various programming 

functions in Flash. The main walk-away is that 

there are numerous ways of accomplishing 

the same desired result or calculation in Flash. 

Nurture your optimization skills by building 

and benchmarking various techniques until you 

find the best solution, and can leverage those 

findings as you progress forward.

  You will always have more compelling 

and engaging content than your competition 

because of your focus on creating more fluid 

and engaging experiences. This can only help 

push the proliferation of the technology into 

yet other devices and platforms, thus allowing a 

much larger audience to enjoy our content.
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Adobe Device Central CS4
BBoonnuus CChhaappptteeerrr  11

1 A wealth of information is available 
for each device just by clicking on the 

device profile folder. Detailed information 
about Flash Lite version, display size, 
operating system, networks and languages 
is just a sample of the information provided. 
There’s even a handy search function 
available to help you quickly find the device 
you are looking for. Probably the biggest 
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3 When you test your Flash Lite 
content in Flash, Device Central 

will launch, allowing you to emulate 
your movie’s performance in the 
included device skin. If your movie 
is designed to react to the device’s 
hardware, you can test these 
features with your mouse by clicking 
the Emulator tab keypad directly or 
using the keyboard shortcuts that 
are specifically mapped to each 
button: the arrow keys on your 
keyboard map to the corresponding 
navigation keys; the E R 
keys correspond to the Emulator tab 
select key; Page Up and Page Down 
keys correspond to the Emulator’s 
left and right soft keys; and the 
number keys on your keyboard map 
correspond to number keys on the 
Emulator keypad.

advantage of using Adobe Device Central is 
having the ability to preview and test mobile 
content for a wide range of mobile devices. 
You don’t even need to own any of these 
devices to get a really good idea as to how 
your content will perform on them. Of course 
nothing is better than testing on the actual 
device(s), but that’s not a realistic option for 
many of us.

THE FLASH LITE™ MOBILE 

platform can be an 

elusive technology for many. It 

wasn’t until I got my hands on 

a Flash-enabled device that I 

started to truly understand the 

platform. But for those of you 

who don’t have a device that 

supports the Flash Lite™ player,   

Adobe Device Central CS4 is 

the closest thing to having 

every supported mobile device 

at your fingertips. 
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2 Your client has just asked you 
to help them develop mobile 

content over a variety of devices. 
Before Device Central, that may 
have been a difficult assignment 
from a technical standpoint. You 
can now organize your project by 
creating a custom device group 
in Device Central and dragging 
the preferred devices to its folder. 
When you click on this folder, 
each device will be categorized by 
screen sizes. You can sort by player 
version, ActionScript version and 
content type from the drop-down 
menus. Click the Create button to 
launch Flash with a new document 
matching the profile for the 
device you had selected. Blissful 
integration.

HOT TIP
The new Online 
Library panel 
is always 
connected to 
the Internet and 
will always keep 
your devices 
up to date 
(assuming you 
are connected 
to the Web). 
You can also use 
the integrated 
search feature 
to quickly find 
the device(s) 
you are looking 
for.

4 In the Display category, adjust the level of backlight to 
simulate the characteristics of the device screen and 

how your content will be seen (or not seen). The Backlight 
slider lets you adjust the amount of backlight to simulate a 
device entering sleep mode. Some mobile device users lower 
their backlight brightness purposely to save battery power. 
When designing mobile content, check if the content is 
visible with low backlight. You can even simulate how the 
display might react to indoor, outdoor or sunshine lighting. 
Simulate Timeout, Contrast and Gamma features and even 
rotate the device if your content is designed for a landscape 
orientation.

5 Simulate the performance of your content with the 
handy Calibrate feature. When you click Calibrate, 

the series of performance tests will begin measuring the 
performance of your content. There’s no substitute for 
testing with the actual device itself, but that is usually not 
realistic when there’s over 450 device profiles to choose 
from. Device Central CS4 is as close to real world testing as 
you can get without the device(s) itself.

HHHHHHooooooowwwwwww tttttttooooooo CCCCCCChhhhhhheeeeeeaaaaaatttttt iiiiiinnnnnn FFFFFFlllllaaaaassssshhhhh
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LAUNCHING FLASH FOR THE FIRST TIME can be an overwhelming experience. Between 

the multitude of panels and menus, knowing where to start can become frustrating almost 

instantaneously. My first experience with Flash was with Version 3 many years ago when it 

was still in its infancy as a simple Web animation program. I had the luxury of incrementally 

growing with each version of Flash through the years. With the latest CS4 toolset Flash has 

to offer, feeling a bit intimidated and not knowing where to start can be normal. At least 

now, with Flash CS4 and its integration into the entire suite of Adobe products, there’s a 

better chance you might feel a little more at home with the general interface. Here are a few 

tips and tricks I have found useful in my daily workflow that aren’t all documented in the 

Help files.

I  N  T  E  R  L  U  D  E

Navigate between 
scenes (if any) using 
the Edit Scenes 
shortcut tool.

Control the 
magnification 
of your stage.

Use this shortcut 
menu to quickly find 
and edit any existing 
symbol in the current 
document.

Indicates where you are in your 
document relative to nested 
timelines and the main timeline.

Use this arrow to navigate 
back to the parent timeline.

Cheap tricks

The new Edit Bar performs a variety of helpful tasks. Alternatively it can 
be removed completely by going to Window > Toolbars > Edit Bar.

Flash CS4 offers a convenient 
drop-down menu for easy access 
to default preset workspaces. 
Throughout a long workday, you 
may find yourself altering a preset 
workspace by moving panels 
around. To return the workspace to 
its original configuration, use the 
drop-down menu to select “Reset 
[name of workspace]”. You can 
design your own custom workspaces 
and save them as presets for easy 
access. If this drop-down isn’t 
quick enough for you, try assigning 
keyboard shortcuts for your favorite 
workspace layouts.
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With an object on the stage selected, zooming in to the stage 
using the keyboard shortcuts will always keep the selected 
object centered. 

The Tools panel can be configured in a variety 
of ways. It works like an explorer window: just 
click and drag a corner or one of the sides of 
the panel.

You can specify any directory for 
your published files by clicking 
on the folder icons to the right 
of the format file name fields. 
Go to File > Publish Settings and 
click on the Formats tab. When 
you click a folder icon, you will 
be prompted to locate the new 
folder on your local hard drive. 
You can provide a new name for 
your published files as well. If you 
ever want to return to the default 
name and the default directory, 
click the Use Default Names 
button.

You can change the default 
document properties every time you 
create a new Flash document by 
opening the Document Properties 
panel (Ctrl + J) and making your 
preferred changes. Before clicking 
“OK”, click the Make Default button 
to force your new settings for every 
new document.

Want a quick way 
to remove all the 
contents of the 
stage for the current 
frame? Double-click 
the Eraser icon in the 
Tools panel.

As you might already know, 
double-clicking a symbol 
instance on the stage will 
bring you to Edit in Place 
mode. What you might 
not know is, to return to 
the parent timeline just 
double-click anywhere 
outside of your artwork in 
the stage area.

HHHHHHooooooowwwwwww tttttttooooooo CCCCCCChhhhhhheeeeeeaaaaaatttttt iiiiiinnnnnn FFFFFFlllllaaaaassssshhhhh
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